1. INTz's Avatar
    So over the last week my battery began draining really quickly. Naturally I took a look at what was happening on my device monitor (what a great tool). I saw that 30% of my battery drain was coming from location services. More specially the location services is causing this drain around the hours I am at work. During the weekend everything drains as normal. Also when I look at the top bar of my phone the location services icon is always on showing something is trying to access my location. I suspect that some grubby code is consistently trying to get my location and failing. And it just keeps retrying and killing my battery.

    So far I am unable to track down what app is doing this. Does anyone know how I can do this? I don't see any such functionality in device monitor.

    I guess my only other option is to start uninstalling apps.

    Posted via CB10
    10-06-14 04:22 PM
  2. russworman's Avatar
    Maybe try turning location services off?

    Posted via CB10
    10-06-14 04:24 PM
  3. Warlack's Avatar
    Get your grubby code out of my location services.-img_20141006_222435.png
    Check all apps with location permission.


    Get your grubby code out of my location services.-img_20141006_222659.png

    Check CPU usage....

    If you see a pattern, then uninstall the app.... surely an android app...

    PassportSQW100-1/10.3.1.632 and a Z30
    MrGabriel likes this.
    10-06-14 04:28 PM
  4. INTz's Avatar
    Hey thanks. Saw that I can check who has location permissions. Will narrow them down one by one. Would be nice to see in the future a list of what apps used location services at the time they used it.

    Posted via CB10
    10-06-14 06:48 PM
  5. INTz's Avatar
    OK this is weird. I have denied everything and still showing the location icon up top. Looking at the cpu usage pattern the only thing that matches my location usage is the system. Can this be misbehaving?

    Posted via CB10
    10-07-14 08:09 AM
  6. Ecm's Avatar
    Under Location Services, be sure to turn off Traffic Data Collection and Location Based Ads. I leave the Location Services on permanently. But turning off those 2 sub options made a huge improvement.
    10-07-14 08:10 AM
  7. PatrickMJS's Avatar
    Under Location Services, be sure to turn off Traffic Data Collection and Location Based Ads. I leave the Location Services on permanently. But turning off those 2 sub options made a huge improvement.
    I leave Traffic Data Collection "On" all the time and Location Based Ads "Off" all the time.

    When I check the battery usage of the Location Services, it is consistently under 10% and often under 1%.

    Posted via CB10
    10-07-14 10:21 AM
  8. INTz's Avatar
    I have both of those settings, traffic and ads, off.

    Posted via CB10
    10-07-14 11:59 AM
  9. genesis101's Avatar
    Maybe your wife is tracking you on BlackBerry protect
    10-08-14 12:06 AM
  10. ealvnv's Avatar
    OK this is weird. I have denied everything and still showing the location icon up top. Looking at the cpu usage pattern the only thing that matches my location usage is the system. Can this be misbehaving?

    Posted via CB10
    You need to reboot the device in order for applications permission changes to take effect.

    If you haven't, you need to do that
    10-08-14 12:10 AM
  11. azimesmail's Avatar
    My location services is at 0.1% total with all the options on.
    10-08-14 12:19 AM
  12. INTz's Avatar
    So even more interesting. It seems to have fixed itself. Today the drain went back to normal with location services only using 1.1%

    Posted via CB10
    10-08-14 07:12 PM

Similar Threads

  1. Sold out in Saudi Arabia
    By Faroukh Naseem in forum General BlackBerry Discussion
    Replies: 30
    Last Post: 10-20-14, 10:17 PM
  2. Which apps you use on your Passport?
    By Marcin Ty in forum BlackBerry Passport
    Replies: 9
    Last Post: 10-08-14, 11:01 AM
  3. Will official 10.3 fix my Z10 Notifications bug?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 10-06-14, 07:13 PM
  4. Why is my Z10 randomly shutting off?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-06-14, 06:04 PM
  5. Google play service
    By ahmad habib in forum Ask a Question
    Replies: 2
    Last Post: 10-06-14, 04:31 PM
LINK TO POST COPIED TO CLIPBOARD