12-14-17 04:16 PM
246 ... 23456 ...
tools
  1. Rebelllious's Avatar
    Just like to give you guys a shout out. Just got around to doing this today and I'm using CB10 through the VPN to post this.
    Which script did you use? The old one (with no dynamic DNS installation option) or the new one?
    Any remarks?
    05-07-14 05:19 PM
  2. dustmalik's Avatar
    Can all this be done from a Windows based PC? Because I have never used Linux, therefore i'm not familiar with it.

    Posted via CB10 using my Gorgeous Z10
    05-07-14 05:41 PM
  3. Serge Simon's Avatar
    I have everything set up since the beginning, but each time i try to connect with putty i get: Network Error: Connection timed out. Scrap that... the IP changed...

    Now i'm back to the old bull**** of "Server Refused our key" error

    I created an new one, i deleted the old, and now i cannot reactivate them because they have no public key and i get an error.

    What have I missed?

    The only 'problem' is that after i made the first Instance, it did not work so I deleted it, and made a second. (recreated private key, oppened ports, etc) I followed the steps as described, but nothing seems to work...

    So.. what is the password Putty asks me after it refuses the key, how do i create/modify/see it?
    Last edited by Serge Simon; 05-07-14 at 07:15 PM.
    05-07-14 07:03 PM
  4. Guyzer's Avatar
    Can all this be done from a Windows based PC? Because I have never used Linux, therefore i'm not familiar with it.

    Posted via CB10 using my Gorgeous Z10
    You do not need to be familiar With Linux. We made it as easy and user friendly ad possible. If you can read and follow instructions you can set this up on Linux

    Posted via CB10
    05-07-14 07:40 PM
  5. Guyzer's Avatar
    Great!

    I was actually planning to give this Vpn another try this weekend!

    I will try tomorrow and let you know how it goes.

    Thank you again!

    Posted via CB10
    So did you actually get this working?

    Sorry everyone it appears like I missed a few posts. I only read the ones emailed to me but it appears it won't email you any in between the the last email and your next visit

    Posted via CB10
    05-07-14 07:43 PM
  6. Guyzer's Avatar
    I have everything set up since the beginning, but each time i try to connect with putty i get: Network Error: Connection timed out. Scrap that... the IP changed...

    Now i'm back to the old bull**** of "Server Refused our key" error

    I created an new one, i deleted the old, and now i cannot reactivate them because they have no public key and i get an error.

    What have I missed?

    The only 'problem' is that after i made the first Instance, it did not work so I deleted it, and made a second. (recreated private key, oppened ports, etc) I followed the steps as described, but nothing seems to work...

    So.. what is the password Putty asks me after it refuses the key, how do i create/modify/see it?
    Okay best advice I can give start over in an entirely new region. Switch to Oregon or Virginia or whatever. Delete everything in the old region after as you may incure charges

    Posted via CB10
    05-07-14 07:46 PM
  7. Guyzer's Avatar
    The link in the initial post now links to the updated version of the script. It includes the dynamic DNS configuration client (user decides on whether or not to use it). Please be patient. Till I make the complete tutorial on all this stuff, use "no" as your answer to the question the script asks about using dynamic DNS. I will write the tutorial soon, presumably during the weekend.
    Now concerning the PROJECT:
    1. Done. Tested. Works smooth, needs minimum initial configuration.
    2. Done. Tested. Works flawlessly, even keeps initial formatting of the configuration file.
    3. I am still convinced of sticking to Dropbox. Any other/better alternative for hosting script? Thinking also of Github as a place to store the script. Any ideas concerning this?
    Excellent work! Major thanks from all. I used the script and it makes the process a billion times better.

    Regarding Github I think that would work. I know Dropbox is also fine but I'm just worried if you move the file or lose it the link will be dead and I will have to update it if I am even still following this thread at that time. Just thinking it's best to get something permanent now so no need to change anything Later.

    Everyone needs to like and thank your Post. Come on guys no need to be shy or hold back

    Posted via CB10
    05-08-14 04:08 AM
  8. Serge Simon's Avatar
    Okay best advice I can give start over in an entirely new region. Switch to Oregon or Virginia or whatever. Delete everything in the old region after as you may incure charges

    Posted via CB10
    Just started an instance in Oregon, no avail... the same problem... server refused key...

    I am thinking of contacting Amazon.
    05-08-14 04:45 AM
  9. Richard Buckley's Avatar
    Which script did you use? The old one (with no dynamic DNS installation option) or the new one?
    Any remarks?
    I think I got it just before dynamic DNS was added. I'm not sure it is working with wireless, the first time I tried it I got an authorization failure, but it does work from several Wi-Fi hot spots, so that would be a carrier issue.

    Edit:

    Checked it on the way to work, I can connect using both UTMS (3G) and LTE (4G).
    Posted via CB10
    Last edited by Richard Buckley; 05-08-14 at 07:26 AM.
    05-08-14 05:00 AM
  10. Rebelllious's Avatar
    Just started an instance in Oregon, no avail... the same problem... server refused key...

    I am thinking of contacting Amazon.
    No need to contact amazon. Kill all your instances. Kill all security groups, all volumes. And the key pairs as well. Only after this start everything once again. You will do it for sure.
    Last edited by Rebelllious; 05-08-14 at 07:55 AM.
    05-08-14 06:56 AM
  11. Serge Simon's Avatar
    No need to contact amazon. Kill all your instances. Kill all security groups, all volumes. And the key pairs as well. Only after this start everything once again. You will do it for sure.

    I terminated and deleted all instances, they even dissapeared. Deleted all keys, security groups.. and started from square 1... before i posted the previous thread...
    05-08-14 03:31 PM
  12. Guyzer's Avatar
    i guarantee its not a amazon problem. you say its a keypair problem. like you mentioned earlier about how you forgot to update your IP address you probably forgot to update your keypair with puttygen.exe. seriously though, there is nothing wrong with the instructions.

    just start over completely... take no shortcuts. get a NEW key, and dont forget to convert it, and UPDATE putty with your Auth settings

    I terminated and deleted all instances, they even dissapeared. Deleted all keys, security groups.. and started from square 1... before i posted the previous thread...
    05-08-14 04:25 PM
  13. Serge Simon's Avatar
    i guarantee its not a amazon problem. you say its a keypair problem. like you mentioned earlier about how you forgot to update your IP address you probably forgot to update your keypair with puttygen.exe. seriously though, there is nothing wrong with the instructions.

    just start over completely... take no shortcuts. get a NEW key, and dont forget to convert it, and UPDATE putty with your Auth settings
    I updated and checked the putty files, re-loaded the key, created a new profile and saved it, checked the key again, even deleted the old keys so no problems appear.

    I have one key that has been converted to a private key, as the tutorial shows. I added it to putty and still get the Server refused key...

    Ip is the correct one, there is no other key on the server... plus, there is no limitation on IP in the security groups. the AWS simply does not want to accept my key. And yes, i am using the correct corresponding keys (Ireland for Ireland and Oregon for Oregon).... I even named them accordingly.

    The only thing i did different is moved the keys after they have been downloaded to a new folder. This sounds strange to say that it's the only thing i do not see anything noted about, nor should it have any influence.
    05-08-14 06:59 PM
  14. Guyzer's Avatar
    I updated and checked the putty files, re-loaded the key, created a new profile and saved it, checked the key again, even deleted the old keys so no problems appear.

    I have one key that has been converted to a private key, as the tutorial shows. I added it to putty and still get the Server refused key...

    Ip is the correct one, there is no other key on the server... plus, there is no limitation on IP in the security groups. the AWS simply does not want to accept my key. And yes, i am using the correct corresponding keys (Ireland for Ireland and Oregon for Oregon).... I even named them accordingly.

    The only thing i did different is moved the keys after they have been downloaded to a new folder. This sounds strange to say that it's the only thing i do not see anything noted about, nor should it have any influence.
    You cannot import keys across regions

    Posted via CB10
    05-08-14 07:04 PM
  15. Serge Simon's Avatar
    You cannot import keys across regions

    Posted via CB10
    I know.. that is why i gave them names according to regions... I just launched a new instance in my first region, Ireland and got it to work with the previous key, and i logged in!!

    now to set-up... and Autentification Error....
    All i need is my public IP, the User 1, 2 and passwors... for simlicity, i have them all identical, does this matter?

    i made sure all are small caracters, if you are willing to try, Guyzer I can send you a PM with the user/Conf details to give it a try. Please advise.
    Last edited by Serge Simon; 05-08-14 at 08:08 PM. Reason: more info on progress.
    05-08-14 07:26 PM
  16. Rebelllious's Avatar
    Use my script. It will definitely help you get it working.
    05-09-14 12:50 AM
  17. Serge Simon's Avatar
    Use my script. It will definitely help you get it working.
    I used the script... it was very easy and quick, Great job on that!!

    ok, i am giving you the details and ask of you to do a test, maybe there is something wrong with my configuration...

    First the configuration setup is here:
    https://imgur.com/Gw9fPfb,kyixdFQ#1

    On My Z10 running OS.10.3: (note: i also tried setting email address as autentification ID, and not just IPv4 as one suggested)
    https://imgur.com/Gw9fPfb,kyixdFQ#0

    Please point me where i am wrong... I am starting to feel like i am an *****... Thanks.
    05-09-14 04:37 AM
  18. Guyzer's Avatar
    I used the script... it was very easy and quick, Great job on that!!

    ok, i am giving you the details and ask of you to do a test, maybe there is something wrong with my configuration...

    First the configuration setup is here:
    https://imgur.com/Gw9fPfb,kyixdFQ#1

    On My Z10 running OS.10.3: (note: i also tried setting email address as autentification ID, and not just IPv4 as one suggested)
    https://imgur.com/Gw9fPfb,kyixdFQ#0

    Please point me where i am wrong... I am starting to feel like i am an *****... Thanks.
    Did you use the script? It really simplifies life

    Posted via CB10
    05-09-14 04:49 AM
  19. Guyzer's Avatar
    Did you use the script? It really simplifies life

    Posted via CB10
    Wow you got your phone setup wrong.

    Serg1 goes with pass1

    Also gateway password is "password" according to your settings

    Posted via CB10
    05-09-14 04:51 AM
  20. Guyzer's Avatar
    Also do not modify any configuration strings until you know they are working.

    You added an extra user even before you got one working

    Redo everything. Just pm me your details

    Posted via CB10
    05-09-14 05:05 AM
  21. Rebelllious's Avatar
    I used the script... it was very easy and quick, Great job on that!!

    ok, i am giving you the details and ask of you to do a test, maybe there is something wrong with my configuration...

    First the configuration setup is here:
    https://imgur.com/Gw9fPfb,kyixdFQ#1

    On My Z10 running OS.10.3: (note: i also tried setting email address as autentification ID, and not just IPv4 as one suggested)
    https://imgur.com/Gw9fPfb,kyixdFQ#0

    Please point me where i am wrong... I am starting to feel like i am an *****... Thanks.
    Moreover, your second screenshot has UDP1700 open, while the port we (possibly) need is UDP1701.
    05-09-14 02:18 PM
  22. Rebelllious's Avatar
    Well, here is the updated How-To for the script.
    This script is for installing the Strongswan IPsec VPN server (with optional dynamic DNS updates using Noip Dynamic DNS Client for Linux).
    Here are the steps on how to use it:
    1. Get a working instance of CentOS with working Internet connection (in our case, follow the instructions of Guyzer to get an Amazon AWS free instance.
    2. In your Terminal window, type or copy-paste the following command:
    Code:
    yum install wget -y
    bash <(wget -qO- --no-check-certificate https://raw.githubusercontent.com/Rebelllious/blackberry10-vpn-server-installation-centos/master/vpn.sh)
    This will start the installation script.
    3. If you want to just install Strongswan, please answer "no" to the question concerning dynamic DNS configuration and switch now to step 4.
    Yet, in case your IP is dynamic, you will have to say "yes" to this question and undergo some additional steps.
    So, before installing the Linux Dynamic Update Client as part of your installation you have to visit Free Dynamic DNS - Managed DNS - Managed Email - Domain Registration - No-IP and register for a free account. When registering, choose the domain name you like to be able to access your server using it afterwards.
    After this you can say "yes" to the script question about dynamic IP and continue. The script will ask you for login and password to your NoIP account. When prompted, set the update interval according to your preferences. Using default suggested 30 minutes interval should be good in most cases. Anyway, your configuration file for VPN server will be updated with your current IP at every boot automatically.
    4. Enter the information the script ask you: IP address of the server, gateway pre-shared key, user name and user password.
    Please notice the script will only create configuration for one user (for test purposes, so to say). To add more users, use your favorite editor (like vi/vim) and edit /etc/ipsec.secrets to introduce or change user credentials. For this, please refer to Google search or the tutorial of Guyzer, as it was mentioned there.

    Congratulations, your VPN server is now ready to use. The whole procedure takes 11-12 minutes of your time from the moment you log in as root. Sure, it depends much on how fast you type in the information you are asked for.

    UPD: So, when having installed the NoIP client and having your dynamic DNS domain, you can write it when configuring your device VPN profile instead of server IP address. Thus you will have connection always.
    Last edited by Rebelllious; 05-09-14 at 03:57 PM. Reason: Mistakes corrected
    05-09-14 03:46 PM
  23. Serge Simon's Avatar
    i added both 1700 and 1701, just to be sure... nothing changed...
    05-09-14 05:12 PM
  24. BCITMike's Avatar
    Just started an instance in Oregon, no avail... the same problem... server refused key...

    I am thinking of contacting Amazon.
    You're updating your Putty session with your new key, right?
    05-09-14 09:26 PM
  25. Guyzer's Avatar
    i added both 1700 and 1701, just to be sure... nothing changed...
    Honestly there are no configuration changes that you need to make. The script does everything.

    Pm me your details to your amazon Aws and I will do it for you. This would have been quicker from the beginning.

    Posted via CB10
    05-09-14 09:39 PM
246 ... 23456 ...

Similar Threads

  1. Z30 Wi-Fi connection unstable.
    By young guy in forum BlackBerry Z30
    Replies: 10
    Last Post: 10-22-13, 11:18 PM
  2. Line App on BlackBerry Q10
    By gnulab in forum BlackBerry Q10
    Replies: 7
    Last Post: 10-22-13, 07:12 PM
  3. How can you copy paste text on the z10?
    By Lee Eshelman in forum BlackBerry Z10
    Replies: 10
    Last Post: 10-21-13, 02:39 PM
  4. Z30 not permitting Facebook posting
    By rosie_parent in forum General BlackBerry Discussion
    Replies: 7
    Last Post: 10-21-13, 12:21 PM
  5. How can i update my z10 software 10.2
    By chitwan in forum BlackBerry Z10
    Replies: 2
    Last Post: 10-21-13, 09:18 AM
LINK TO POST COPIED TO CLIPBOARD