09-08-18 10:09 PM
810 ... 2223242526 ...
tools
  1. johnsliderbb's Avatar
    Probably I did something wrong and probably the answer is hiding already in above 570 posts.

    Exported WA from BB10 WA. Took ages and not all pictures were copied. However the message/chat file was there.
    Deleted BB10 WA
    Installed WA apk
    Registrated
    Ran WAAfixer
    Can send pictures.
    Put the exported message/chat file in the proper new WA folder

    However seems old chats are not opened. Maybe wrong order of steps?

    Could OP put the proper sequence of steps in the 1st post as well for future reference?

    Thanks Hamed Cellninja and wa_kongsberg for all effort regarding BB10 WA

    Posted via CB10
    Last edited by johnsliderbb; 12-30-17 at 07:29 AM.
    12-30-17 06:48 AM
  2. goncal's Avatar
    Possibly not all media on SDcard. I would still try closing whatsapp with device monitor (or rebooting) and if not I would check whether all media files on Android/WhatsApp on the SD card.
    12-30-17 06:55 AM
  3. goncal's Avatar
    Last but not least a big thank you to @Hamed, Cellninja and @dkonigsberg_wa who provided great help. In particular @dkonigsberg_wa really helped us understand what has been going on.
    Last edited by goncal; 01-15-18 at 01:52 AM. Reason: had not included '@'
    12-30-17 06:56 AM
  4. Invictus0's Avatar
    Probably I did something wrong and probably the answer is hiding already in above 570 posts.

    Exported WA from BB10 WA. Took ages and not all pictures were copied. However the message/chat file was there.
    Deleted BB10 WA
    Installed WA apk
    Registrated
    Ran WAAfixer
    Can send pictures.
    Put the exported message/chat file in the proper new WA folder

    However seems old chats are not opened. Maybe wrong order of steps?

    Could OP put the proper sequence of steps in the 1st post as well for future reference?

    Thanks Hamed Cellninja and wa_kongsberg for all effort regarding BB10 WA

    Posted via CB10
    What do you mean by "old chats are not opened"? Do you mean your old chats no longer appear on the main chats screen?
    12-30-17 10:06 AM
  5. johnsliderbb's Avatar
    What do you mean by "old chats are not opened"? Do you mean your old chats no longer appear on the main chats screen?
    Correct. And if I start chatting with eg my wife a new chat is started without showing the chat of yesterday.

    Posted via CB10
    12-30-17 11:04 AM
  6. Invictus0's Avatar
    Correct. And if I start chatting with eg my wife a new chat is started without showing the chat of yesterday.

    Posted via CB10
    Strange, another use wasn't seeing their old chats either when they imported a BB10 backup but they said their old chats reappeared once they would start a conversation with an existing contact.

    Does this happen to all of your contacts?
    12-30-17 01:24 PM
  7. johnsliderbb's Avatar
    Till now with every contact.

    When comparing the backups: The last bb10 backup is 24MB. The exported back-up only 8MB.


    Posted via CB10
    12-30-17 03:43 PM
  8. ChicaneBT's Avatar
    Probably I did something wrong and probably the answer is hiding already in above 570 posts.

    Exported WA from BB10 WA. Took ages and not all pictures were copied. However the message/chat file was there.
    Deleted BB10 WA
    Installed WA apk
    Registrated
    Ran WAAfixer
    Can send pictures.
    Put the exported message/chat file in the proper new WA folder

    However seems old chats are not opened. Maybe wrong order of steps?

    Could OP put the proper sequence of steps in the 1st post as well for future reference?

    Thanks Hamed Cellninja and wa_kongsberg for all effort regarding BB10 WA

    Posted via CB10
    Did WhatsApp gave you a message the backup was found and gave you an option to restore? If not WhatsApp has not restored your backup.

    You have to install the WA Android but not yet open or go through the verification. The backup has to be in place before you open the WA Android app or go through verification otherwise WA can't see your backup.

    I used these steps:
    https://forums.crackberry.com/ask-qu...-50-a-1092204/

    Make sure you backup important information between now and your WhatsApp Blackberry Export Backup!

    You will have to remove WhatsApp Android and install it again. But better just follow the steps in the above post.
    Last edited by ChicaneBT; 12-30-17 at 04:01 PM.
    12-30-17 03:51 PM
  9. dkonigsberg_wa's Avatar
    The Android-compatible backups are compressed. The BB10 backups are not compressed. That is the only reason for the dramatic difference in size.

    As others have pointed out, you have to put the exported DB in-place *before* installing WhatsApp for Android. Otherwise, there's no way it will have the opportunity to "restore" it into the app's internal sandbox.
    12-30-17 07:46 PM
  10. johnsliderbb's Avatar
    Thanks for the headsup.

    Will remove WA.

    However with WA apk not installed yet, what path do I need to copy the backup files to? Found that location on the SD only after installing WA apk and after running WA fixer. Will it be the same path again?

    Edit:
    Just copied it to Device /misc/android/Android

    To see what happens

    And tada, it works. Backup was found when installing apk again.
    A new run of WAfixer made it complete.

    Once again, thanks for all support on this one.

    Posted via CB10
    Last edited by johnsliderbb; 12-30-17 at 09:30 PM.
    vincentkong likes this.
    12-30-17 08:32 PM
  11. henryojo56's Avatar
    This is what my phone is showing after do that. I don't know whether I can send the images now
    01-02-18 03:39 AM
  12. hennesseystealth's Avatar
    I am having issues with sending media files in the Android version of Whatsapp. I have run the below procedure and WhatsFixer says done after hitting the button, but it still won't send something as simple as a photograph. The error message is not being able to share. I have tried the below procedure with running WhatsFixer before and after moving the export files. If I move it before running WhatsFixer, it never completes the work as I believe the volume of media files chokes it (reported elsewhere). Not sure why it says it worked before moving the folder, but it doesn't.

    1) Create the Android export from the BB10 version. It will go into the directory Media Card/Whatsapp/Databases. It will also create a folder Media Card/Whatsapp/Media. 2) Uninstall Whatsapp BB version. 3) Install Whatsapp Android version BUT DO NOT OPEN IT. 4) Run WhatsFixer. 5) Take the entire Whatsapp folder and copy or move it to Device/misc/android/. 6) Open and register Whatsapp Android version.

    Any ideas?
    Last edited by hennesseystealth; 01-03-18 at 01:57 PM.
    01-03-18 01:30 PM
  13. Monther Ajawi's Avatar
    I feel all the time that setup not completed as you see in attachment! Is that true?!!
    01-04-18 01:38 AM
  14. Monther Ajawi's Avatar
    Pls see the attachment below all the time the "done" button is gray is this ok or there are some thing wrong?!!!!
    Attached Thumbnails Finally the Android WhatsApp media sharing problem solved-img_20180104_093401.jpg  
    01-04-18 01:45 AM
  15. Invictus0's Avatar
    Pls see the attachment below all the time the "done" button is gray is this ok or there are some thing wrong?!!!!
    I believe that means it's still running things in the background. How big is your misc/android/WhatsApp folder? Try moving files out of it and restart WhatsFixer?
    01-04-18 09:54 AM
  16. hennesseystealth's Avatar
    I was told that gray Done means Done. I have a very large set of media files and the the Fix label does not change to the gray done. I am going to move out the media files and see what happens. I tried using WhatsFixer and NOT using the Android export and the button went almost immediately to the gray Done and I was able to send media files.
    01-04-18 10:22 AM
  17. Firos Khantsm's Avatar
    01-04-18 11:09 AM
  18. Firos Khantsm's Avatar
    Goodnight
    01-04-18 11:10 AM
  19. Blackberry4everr's Avatar
    Hi, tried every step 2 times but does not work for me.
    I use cobalt app's , did reinstall newest whatsapp version etc. But still can't share media files
    01-04-18 11:48 AM
  20. Invictus0's Avatar
    Hi, tried every step 2 times but does not work for me.
    I use cobalt app's , did reinstall newest whatsapp version etc. But still can't share media files
    Have you tried WhatsFixer?

    https://appworld.blackberry.com/webs...tent/60005088/
    01-04-18 11:59 AM
  21. Blackberry4everr's Avatar
    yes I did, but the help question was about the tutorial of hamed ghorbani.
    I don't know why it is not working, the steps are not that difficult.
    when using BGshell I did get the message " file already excists" at the end
    01-04-18 12:02 PM
  22. Invictus0's Avatar
    yes I did, but the help question was about the tutorial of hamed ghorbani.
    I don't know why it is not working, the steps are not that difficult.
    when using BGshell I did get the message " file already excists" at the end
    WhatsFixer is just automating the steps from OP. If you've already run it before and if you're getting a "file already exists" message that means the fix has already been applied.

    Can you confirm that Android/WhatsApp is present on your SD card?
    01-04-18 01:23 PM
  23. Blackberry4everr's Avatar
    Yes,
    Look at the attachment..
    It is in dutch language but as you can see "Whatsapp" is on the sd card
    Attached Thumbnails Finally the Android WhatsApp media sharing problem solved-img_20180104_203345.jpg  
    01-04-18 01:36 PM
  24. Invictus0's Avatar
    Yes,
    Look at the attachment..
    It is in dutch language but as you can see "Whatsapp" is on the sd card
    It looks like the symlink worked, are you unable to send any media files (pictures, videos, etc) or just certain types?

    If you want to redo the link there should be a command to delete it (File Manager won't let you), my QNX is rusty though but hopefully @RodgerLeblanc or another poster can chime in with some insight.
    01-04-18 02:40 PM
  25. Monther Ajawi's Avatar
    I believe that means it's still running things in the background. How big is your misc/android/WhatsApp folder? Try moving files out of it and restart WhatsFixer?
    Sir I haven't a big files there?!
    01-04-18 02:45 PM
810 ... 2223242526 ...

Similar Threads

  1. The more I use my Priv . . .
    By gebco in forum BlackBerry Priv
    Replies: 24
    Last Post: 01-27-18, 05:20 PM
  2. Should BB10 OS do the same?
    By Zaiah86 in forum BlackBerry 10 OS
    Replies: 32
    Last Post: 11-23-17, 09:15 AM
  3. Android PKB
    By bbarling11 in forum BlackBerry Motion
    Replies: 2
    Last Post: 11-21-17, 03:11 PM
  4. Jio sim problem
    By vikash_1792 in forum Ask a Question
    Replies: 5
    Last Post: 11-20-17, 03:22 PM
  5. Android HUB
    By Radim B in forum BlackBerry Mobile Support
    Replies: 2
    Last Post: 11-20-17, 09:07 AM
LINK TO POST COPIED TO CLIPBOARD