1. tapanpatel88's Avatar
    Sup guys...I picked up my Z10 a couple of days ago and I absolutely love it!

    When I delete an email from my Z10, the email still shows up as read on my Gmail.

    Any way to have it deleted from both places? Thanks!
    02-17-13 05:04 PM
  2. Crisdean's Avatar
    Was your email setup as IMAP?
    02-17-13 05:09 PM
  3. just_luc's Avatar
    Log into gmail from your computer.. go to settings... then to Forwarding and POP/IMAP.. make sure IMAP is enabled.. make sure "When I mark a message in IMAP as deleted" is set to "Auto-Expunge on - Immediately update the server. (default)"

    Then on your device make sure your account is setup IMAP and not POP3
    KemKev likes this.
    02-17-13 05:15 PM
  4. anon(947910)'s Avatar
    I managed to get emails deleted on Gmail after I have deleted them on my Z10. I needed to modify the following Gmail settings:

    1. Labels

    1.1 Show in label list:

    Important: hide
    All Mail: hide
    Trash: hide

    1.2 Show in IMAP:

    Inbox
    Sent Mail
    Drafts

    2. Forwarding and POP/IMAP

    Enable IMAP
    Auto-Expunge off - Wait for the client to update the server
    Move the message to the Trash

    Works for me and MAYBE also for you...
    Attached Thumbnails email deleted on Z10 but stays on Gmail-capture1.jpg   email deleted on Z10 but stays on Gmail-capture2.jpg  
    djmm2, Ecm, dracolnyte and 3 others like this.
    02-28-13 03:04 AM
  5. makaveli86's Avatar
    I managed to get emails deleted on Gmail after I have deleted them on my Z10. I needed to modify the following Gmail settings:

    1. Labels

    1.1 Show in label list:

    Important: hide
    All Mail: hide
    Trash: hide

    1.2 Show in IMAP:

    Inbox
    Sent Mail
    Drafts

    2. Forwarding and POP/IMAP

    Enable IMAP
    Auto-Expunge off - Wait for the client to update the server
    Move the message to the Trash

    Works for me and MAYBE also for you...
    The only thing I did different was only hide the "All Mail" label from showing up in imap on the labels tab under settings. The other steps are the same under imap settings. This works for me

    Posted via CB10
    02-28-13 03:08 AM
  6. anon(947910)'s Avatar
    Yes, you NEED to hide the "All Mail" label. So did I...
    02-28-13 03:19 AM
  7. youngguy7's Avatar
    Yes, you NEED to hide the "All Mail" label. So did I...
    I've tried this but it doesn't seem to work for me. Does it take effect immediately or does it take 24hrs for servers to update?
    03-21-13 03:27 AM
  8. simcell's Avatar
    Me neither!
    03-31-13 02:57 AM
  9. Davidro1's Avatar
    Push is fast. The other stuff is time-lagged. Wait thirty minutes before drawing conclusions. Hope this helps.

    Posted via CB10
    03-31-13 09:26 AM
  10. kevster310's Avatar
    03-31-13 12:53 PM
  11. msweet#CB's Avatar
    I spoke with Blackberry Tech and they said the "DT 6245477" in the KB33533 means the development team has it and is working on it with Google.

    The was no update on the DT case.
    05-02-13 03:16 PM
  12. Spawn12's Avatar
    The only way i can delete my emails from gmail on my z10 is by filing it into trash then it reflects on my gmail account on my pc. But it stays in my trash until i empty it on my pc.

    Posted via CB10
    05-02-13 03:45 PM
  13. msweet#CB's Avatar
    Update from Blackberry:

    Thank you for contacting BlackBerry Technical Support. It has been a pleasure to work on this issue with you. I have confirmed that the BlackBerry Z10 and BlackBerry Q10 running 10.0.X.X and 10.1.X.X do not synchronize the Trash folder for Gmail integrations. This applies to accounts that are setup via Simple Integration (Email and Password) and manual POP/IMAP integration through the Advanced Setup on the BlackBerry 10 OS.

    This may be a feature that is added in the future. I have personally tested and confirmed with our development team and the same applies to personal @gmail.com/googlemail.com accounts.
    05-27-13 03:11 PM
  14. azndoodle's Avatar
    I managed to get emails deleted on Gmail after I have deleted them on my Z10. I needed to modify the following Gmail settings:

    1. Labels

    1.1 Show in label list:

    Important: hide
    All Mail: hide
    Trash: hide

    1.2 Show in IMAP:

    Inbox
    Sent Mail
    Drafts

    2. Forwarding and POP/IMAP

    Enable IMAP
    Auto-Expunge off - Wait for the client to update the server
    Move the message to the Trash

    Works for me and MAYBE also for you...
    Great. Something to go on. I will also give it a try. As well as HIDE "all mail"

    Thanks

    Posted via CB10
    06-11-13 11:58 PM
  15. msweet#CB's Avatar
    None of those settings will work and if you uncheck "all Mail" in iMap mail will stop syncing period.

    I have spoken with BB in detail on this issue and I actually discovered the actual bug which is they do not sync the Trash folder at all on BB10

    Read the KB above and there still is no solution in site.

    Download Email for Gmail from BB World. It works great.
    06-12-13 11:47 PM
  16. Killington's Avatar
    Cool. I just tried kleinhev suggestion and it worked as described.
    10-18-13 04:15 PM
  17. msweet#CB's Avatar
    If you hide All Mail, gmail will stop working shortly
    10-19-13 12:10 PM
  18. Ecm's Avatar
    If you hide All Mail, gmail will stop working shortly
    That's incorrect.
    I've had the All mail label hidden since February and my Gmail is working flawlessly.
    It's also working for Killington as well.
    10-19-13 02:44 PM
  19. Killington's Avatar
    That's incorrect.
    I've had the All mail label hidden since February and my Gmail is working flawlessly.
    It's also working for Killington as well.
    Yup, all good.
    10-19-13 06:07 PM
  20. adtykhndlwl's Avatar
    For Google Apps legacy email (setup via either Gmail wizard i.e. google authorised accounts or IMAP ), I tried deleting emails after turning off auto-expunge (and 'move to trash' option) and unchecking 'All mail' and 'important' from showing on IMAP. The emails are still archiving. The same is true for accounts with 2-step verification enabled as well as disabled.

    However, for regular Gmail (setup via either Gmail wizard i.e. google authorised accounts or IMAP ), I tried deleting emails after turning off auto-expunge (and 'move to trash' option) and unchecking 'All mail' and 'important' from showing on IMAP. The emails are deleting perfectly when deleted from server as well as the same. The same is true for accounts with 2-step verification enabled as well as disabled.

    So the problem still lies with Google Apps legacy account mailboxes.
    03-24-14 07:27 AM
  21. adtykhndlwl's Avatar
    I managed to get emails deleted on Gmail after I have deleted them on my Z10. I needed to modify the following Gmail settings:

    1. Labels

    1.1 Show in label list:

    Important: hide
    All Mail: hide
    Trash: hide

    1.2 Show in IMAP:

    Inbox
    Sent Mail
    Drafts

    2. Forwarding and POP/IMAP

    Enable IMAP
    Auto-Expunge off - Wait for the client to update the server
    Move the message to the Trash

    Works for me and MAYBE also for you...
    For Google Apps legacy email (setup via either Gmail wizard i.e. google authorised accounts or IMAP ), I tried deleting emails after turning off auto-expunge (and 'move to trash' option) and unchecking 'All mail' and 'important' from showing on IMAP. The emails are still archiving. The same is true for accounts with 2-step verification enabled as well as disabled.

    However, for regular Gmail (setup via either Gmail wizard i.e. google authorised accounts or IMAP ), I tried deleting emails after turning off auto-expunge (and 'move to trash' option) and unchecking 'All mail' and 'important' from showing on IMAP. The emails are deleting perfectly when deleted from server as well as the same. The same is true for accounts with 2-step verification enabled as well as disabled.

    So the problem still lies with Google Apps legacy account mailboxes.
    03-24-14 07:28 AM
  22. AndyMaxwell's Avatar
    Yep, me to just needed to change All Mail to 'hide' and it worked. (I also unticked the 'show in imap' box, if that helped).
    01-06-16 02:53 PM
  23. danifulger's Avatar
    Did you try to edit the account and set the following after enabling the IMAP on Gmail?
    Go to hub > select the email account you're interested in> right down corner> settings> actions, 1st option at the top>confirm email deletion> select underneath it hub and server. This should solve it.
    Just tested this and all selected mail moved to trash on both hub and Gmail. It might take a while depending on the time set in the hub to refresh the emails on the mail server. Mine is set at 5minutes with push activated for two Gmail accounts. If you want we could do a screen sharing video walk through over BBM video.
    The email tested on is the one on the 5th.

    Posted on CB10 on Z30, Z 10 10.3.2.2639




    Attachment 386837
    Attachment 386838
    Attachment 386839
    Attachment 386840

    Attachment 386841
    Attachment 386842
    Attachment 386843
    Attachment 386844
    Attachment 386845
    Last edited by danifulger; 01-07-16 at 01:28 AM.
    01-07-16 12:44 AM
  24. ARGENTVS's Avatar
    Why does this happen. Nothing in here helped me, the email still in my gmail account regardless i delete them in my Z10. It always worked and since my last OS reload it doesn't.
    It is very annoying, i don't understand what is the reason, it was working before.
    02-21-17 04:59 PM
  25. modernhetaira25's Avatar
    Did u try this?
    email deleted on Z10 but stays on Gmail-img_20170224_205244.png
    02-24-17 07:53 PM

Similar Threads

  1. Getting some emails on Curve but not on Mac
    By ricrose in forum Mac Users
    Replies: 1
    Last Post: 09-25-09, 10:36 PM
  2. gmail problem - mail not coming in on time on phone, but is on computer
    By bluesky630 in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 03-05-09, 03:04 PM
  3. cant delete txt messages, they stay on menu
    By mnblackberry in forum BlackBerry Curve 83xx
    Replies: 0
    Last Post: 10-13-08, 07:32 PM
  4. BlackBerry video not playing on 8330, but does on 8310...
    By diavolo770 in forum BlackBerry Curve 83xx
    Replies: 0
    Last Post: 05-30-08, 08:04 PM
  5. Replies: 1
    Last Post: 11-16-07, 12:38 AM
LINK TO POST COPIED TO CLIPBOARD