09-26-13 10:08 AM
27 12
tools
  1. Richard Alberg's Avatar
    I use ActiveSync with Exchange. I have a large number of contact records. Several of them can be found when I search my Exchange Contacts folder on my computer and also when I search Contacts on my Z10. However, when I go to Phone / Contacts and search these contacts are not found. They have telephone numbers in in the record.

    Has anyone else experienced this and is there a solution so the record can be found when I search from Phone as opposed to Contacts?

    Thanks

    Richard
    05-06-13 12:40 PM
  2. anon(153966)'s Avatar
    Firstly welcome to the World of CrackBerry.

    Check those that show and those that don't. Do the phone number fields look like they are setup correctly?
    05-06-13 01:05 PM
  3. Kris Simundson's Avatar
    I use ActiveSync with Exchange. I have a large number of contact records. Several of them can be found when I search my Exchange Contacts folder on my computer and also when I search Contacts on my Z10. However, when I go to Phone / Contacts and search these contacts are not found. They have telephone numbers in in the record.

    Has anyone else experienced this and is there a solution so the record can be found when I search from Phone as opposed to Contacts?

    Thanks

    Richard
    Welcome to the forums, while I have not experienced this myself (just tested and my contacts come up with name in Phone/Contacts), I will try to assist with this.

    Firstly, which model Z10 do you use and which OS version is it running?
    05-06-13 01:06 PM
  4. Richard Alberg's Avatar
    Thank you for your welcome and your replies. The vast majority of my contacts are present both from Contacts search and Phone search. I looked at one of the contacts that only appears in Contacts and edited it in Outlook and re-saved it - checking that the mobile number is correctly formatted. There was not a problem with the way it was previously saved and it certainly is correct now. I changed the contact's email address and this has updated to my Z10 so the sync has worked. Still the contact did not appear in a search of the Phone area.

    I continued making changes and saving. Now the record appears in both areas. I don't know what I did that makes the difference. In case it helps some of the record's information comes from Exchange and some from the same person's Facebook record.

    I have an STL100-2 and am using 10.1.0.264. I only applied this version recently and I am reasonably sure that the problem was occurring in the released operating system.
    05-06-13 01:37 PM
  5. Kris Simundson's Avatar
    I'm wondering if it still hasn't fully synced into your phone application than. Maybe try keeping the phone app in an active frame for a bit to see it pulls in all your other contacts

    Posted via CB10
    05-06-13 02:04 PM
  6. sdgandhi's Avatar
    Even I face the same problem on st-002& have contacts sync with Gmail... don't see some contacts on phone app... could be because I have disabled twitter & facebook in contacts app... also in whatsapp I see some contacts without name, & if I edit that contact in contact app, I see that persons name for a while, then again it becomes blank...
    05-06-13 03:31 PM
  7. konvajw's Avatar
    Based on my experience and confirmation by other posts, any contact that is "linked" to another contact (e.g., Facebook, LinkedIn, etc.) won't show up in the phone contacts list (even though they appear fine in the normal contacts app). Hopefully Blackberry fixes this one soon - since should be pretty straight forward.


    I use ActiveSync with Exchange. I have a large number of contact records. Several of them can be found when I search my Exchange Contacts folder on my computer and also when I search Contacts on my Z10. However, when I go to Phone / Contacts and search these contacts are not found. They have telephone numbers in in the record.

    Has anyone else experienced this and is there a solution so the record can be found when I search from Phone as opposed to Contacts?

    Thanks

    Richard
    05-06-13 09:14 PM
  8. Richard Alberg's Avatar
    Based on my experience and confirmation by other posts, any contact that is "linked" to another contact (e.g., Facebook, LinkedIn, etc.) won't show up in the phone contacts list (even though they appear fine in the normal contacts app). Hopefully Blackberry fixes this one soon - since should be pretty straight forward.
    Thanks. This could be the cause of the problem. The workaround is to always search in Contacts (as opposed to Phone) and make the call from there. Hopefully Blackberry are aware of the issue and will fix.
    05-07-13 03:12 AM
  9. sdgandhi's Avatar
    I also see that email received from a particular contact shows name of another contact..... don't know how to correct it...
    05-07-13 05:40 AM
  10. Richard Alberg's Avatar
    Picking up on hpm2048's post. I have two contacts with the same name. The rest of their details are different. However the photo that has appeared next to one contact's details has come from the other contact's Facebook account. I can't find a way of forcing a refresh. Fortunately not a huge deal, albeit, surprising as I had assumed that the email address was the unique identifier.
    05-07-13 06:03 AM
  11. Xopher's Avatar
    Picking up on hpm2048's post. I have two contacts with the same name. The rest of their details are different. However the photo that has appeared next to one contact's details has come from the other contact's Facebook account. I can't find a way of forcing a refresh. Fortunately not a huge deal, albeit, surprising as I had assumed that the email address was the unique identifier.
    I've had a contact get linked like that. You can unlink the entries from the contact app. Select the contact and view the links, then unlink them.

    Posted via CB10
    05-07-13 06:31 AM
  12. knownastron's Avatar
    The thing here is that you have to choose the Phone contact then link the facebook profile. That makes it firstly a phone contact with the additional facebook link.

    The problem exists when you choose the facebook contact and link in the phone number. That makes it firstly a facebook contact with the additional phone contact link. Since you've shut off facebook contacts and it's primarily a facebook contact, it will not show up in the phone.

    Hope this helps!
    05-08-13 06:00 PM
  13. GP158's Avatar
    I'm having the same issue with all of my contacts (Gmail, outlook.com, Facebook, etc). They show fine in the Contacts app but are not found by Search or when creating an email. I've had no problem for 2 month but suddenly yesterday this started.

    The Phone app, like email just says No Contacts. Search finds nothing but if I swipe right, it says "Something went wrong" under Contacts and if I select that it says "There was a problem getting results from Contacts". Restart is suggested but did not help.

    Now I can no longer modify or delete contacts. No errors but the changes aren't saved. I have removed all Contact accounts and have only local contacts. Surely the contact database is corrupt. Is there a way to recreate it without resetting the phone?

    Posted via CB10
    05-09-13 08:12 AM
  14. GP158's Avatar
    10.1 fixed the problem. Search and email find all contacts. Also now able to delete contacts. I deleted all accounts, all local and SIM contacts, then added back outlook.com and social contact feeds. All is well for now.

    Posted via CB10
    05-17-13 09:07 PM
  15. theclipart's Avatar
    dont mean to dig up an old thread, but yea. i just noticed this is happening to my phone contacts too. only a select few are showing up from the phone tab search vs contact app.
    07-19-13 08:19 AM
  16. anon(2570095)'s Avatar
    dont mean to dig up an old thread, but yea. i just noticed this is happening to my phone contacts too. only a select few are showing up from the phone tab search vs contact app.

    Go into contact settings, turn on all contacts (fb, twitter, etc). Exit contacts app. Open phone, contacts should all be there. Re-open contacts settings and turn off the accounts you don't want on. They should stay in phone contacts. This method works for me at least.

    Posted via CB10 with my white Z10
    theclipart and inked18 like this.
    07-19-13 09:02 AM
  17. theclipart's Avatar
    Go into contact settings, turn on all contacts (fb, twitter, etc). Exit contacts app. Open phone, contacts should all be there. Re-open contacts settings and turn off the accounts you don't want on. They should stay in phone contacts. This method works for me at least.

    Posted via CB10 with my white Z10
    very nice! thank you, it worked.
    07-19-13 09:09 AM
  18. anon(2570095)'s Avatar
    very nice! thank you, it worked.
    Happy to help a fellow crackberrian

    Posted via CB10 with my white Z10
    07-20-13 12:51 PM
  19. anon5759238's Avatar
    I get the same thing. If i use contacts from the phone it doesn't show them all. I have to use contacts app to see every contact I've entered and I don't know what the deal is but it's pretty annoying!

    Swordsmanship Channel: C000C9AF6
    07-20-13 02:33 PM
  20. Brandon Orr's Avatar
    I get the same thing. If i use contacts from the phone it doesn't show them all. I have to use contacts app to see every contact I've entered and I don't know what the deal is but it's pretty annoying!

    Swordsmanship Channel: C000C9AF6
    Just noticed this as well. I just went into the contact section in the phone app and left it in active frame for a bit and went into the contacts app and turned everything off and then everything on, and now they all showed up in the phone contact library.

    Posted via CB10
    07-20-13 07:12 PM
  21. Norgoth's Avatar
    Same issue
    07-20-13 11:09 PM
  22. anon(2570095)'s Avatar
    Same issue
    Go into contact settings, turn on all contacts (fb, twitter, etc). Exit contacts app. Open phone, contacts should all be there. Re-open contacts settings and turn off the accounts you don't want on. They should stay in phone contacts. This method works for me at least.

    Posted via CB10 with my white Z10
    07-22-13 09:30 PM
  23. cgentry58's Avatar
    I've had nothing but problems with my contacts since I got my Z10 in March. I was hoping the 10.1 update would help, but nope. One day a contact will be there, the next it won't. Then I'll go to put it back in, and will get a message asking if I want to create a new contact or just update the existing one. If it's existing already, why can't I see it in my contacts???? I never had this problem with my other BBs. Driving me nuts. Please fix this, Blackberry!!!
    07-22-13 10:30 PM
  24. pili4's Avatar
    Contacts not appearing in the phone app was an issue for me until 4543 when it fixed itself. Perhaps loading a different os would help you as well.

    On my sweet Z10 with CB10! Verizon STL100-4 BBM Channel: C000534C0
    07-22-13 11:42 PM
  25. dearsina's Avatar
    This happens to me on a regular basis also. It has something to do with the indexing of contacts. I suppose the reason why the suggested hack might work is that forces the indexing to restart, and hopefully work properly. This is yet another failure with the BlackBerry Contacts system.

    Contact present in Contacts but not when I search in phone-img_20131170.jpg

    It's very frustrating email and contacts are BlackBerry's stronghold, and so far, they are failing pretty badly on the Contacts front.

    Contact present in Contacts but not when I search in phone-img_20131171.jpg

    And yes, of course i have tried restarting and yes, I have the latest 10.1 OS afforded to me by my provider, EE. 10.1.0.4200.
    09-26-13 05:44 AM
27 12

Similar Threads

  1. Movies showing in explorer but not in media section
    By kscrum in forum More for your BBOS Phone!
    Replies: 7
    Last Post: 05-03-09, 01:35 AM
  2. People can hear me when my treadmill is on but not when its off!
    By joshuasmaximus in forum BlackBerry Storm Series
    Replies: 5
    Last Post: 02-03-09, 12:17 AM
  3. Buy in store, but not activate instore?
    By redwings1914 in forum BlackBerry Storm Series
    Replies: 15
    Last Post: 11-19-08, 02:41 AM
  4. Theme in Applications, but not in Theme Manager
    By dmblnd in forum BlackBerry 88xx Themes
    Replies: 5
    Last Post: 11-09-08, 12:27 PM
  5. email in messages but not in email folder
    By AP in forum BlackBerry Pearl Series
    Replies: 0
    Last Post: 10-17-07, 03:59 PM
LINK TO POST COPIED TO CLIPBOARD