1. billc_ia's Avatar
    What part?
    Hpw should I type it? I have the file in my users directory

    At command prompt, I typed: apktool d filename.apk In the script the follows, I get a warning about the directory being volatile and should use --frame-path because frameworks could go missing. So, I just don't know what I'm doing. The apk was named 1.apk and it also created a pool.bin file and placed all in my \AppData\Local\Temp directory. Once I figure out how to control the output directory (which is mostly where I'm lost), do I need to run a b[uild] on the decoded apk file?
    05-29-19 02:50 PM
  2. conite's Avatar
    Hpw should I type it? I have the file in my users directory

    At command prompt, I typed: apktool d filename.apk In the script the follows, I get a warning about the directory being volatile and should use --frame-path because frameworks could go missing. So, I just don't know what I'm doing. The apk was named 1.apk and it also created a pool.bin file and placed all in my \AppData\Local\Temp directory. Once I figure out how to control the output directory (which is mostly where I'm lost), do I need to run a b[uild] on the decoded apk file?
    Just put the new apktool.jar in the lib sub-directory to the patcher app.
    05-29-19 03:13 PM
  3. billc_ia's Avatar
    Just put the new apktool.jar in the lib sub-directory to the patcher app.
    Thanks for helping- I just can't figure out what it's doing.


    I have both files in my C:\Windows directory.
    05-29-19 03:27 PM
  4. conite's Avatar
    Thanks for helping- I just can't figure out what it's doing.
    You don't need to. Just continue to use the Patcher 1.6 app. It is essentially a GUI for the apktool.
    05-29-19 03:28 PM
  5. billc_ia's Avatar
    You don't need to. Just continue to use the Patcher 1.6 app. It is essentially a GUI for the apktool.
    Fianlly figured it out- unfortunately, in trying to do the most recent WeatherBug app, I get "Unable to install app" when I try to install the modified and signed apk.
    05-30-19 10:39 AM
  6. conite's Avatar
    Fianlly figured it out- unfortunately, in trying to do the most recent WeatherBug app, I get "Unable to install app" when I try to install the modified and signed apk.
    That's because it requires Android 4.4.

    The BB10 Android Runtime is in the 3.8% club of Android 4.3 or less.
    05-30-19 10:40 AM
  7. billc_ia's Avatar
    That's because it requires Android 4.4.

    The BB10 Android Runtime is in the 3.8% club of Android 4.3 or less.
    Makes sense- thanks.
    05-30-19 10:47 AM
  8. goncal's Avatar
    I can confirm that also, if you don't want to dig up the two files, just do the full Blitz and you'll be set.
    There are two files you actually need, just forgot their names but in the lines of Android Runtime and Android Shell .sys files

    Posted via CB10
    Correct. Those two files.
    05-30-19 03:52 PM
  9. billc_ia's Avatar
    Seems to patch fine for me.

    https://mega.nz/#!4dgFRapB!MNLDFrNAO...vbgwybqSskt9eI

    Are you using the latest apktool (2.4.0) ?
    Can't get a "dist" folder in trying to run apktool on FoE version 1.155.3. Any luck getting a patched one?
    07-03-19 08:23 AM
  10. conite's Avatar
    Can't get a "dist" folder in trying to run apktool on FoE version 1.155.3. Any luck getting a patched one?
    I don't use the tool directly. I use the Patcher GUI.
    07-03-19 08:25 AM
  11. billc_ia's Avatar
    I don't use the tool directly. I use the Patcher GUI.
    That's what I'm trying next. Do you have a working FoE 1.155.3? I'm getting a error saying it cannot be rebuilt.
    07-03-19 08:26 AM
  12. conite's Avatar
    That's what I'm trying next. Do you have a working FoE 1.155.3? I'm getting a error saying it cannot be rebuilt.
    You bet.

    https://mega.nz/#!1c4zHKST!NjX0Y9bRA...y5KaXYiLxaQEvc
    07-03-19 09:15 AM
  13. billc_ia's Avatar
    Thank you! You used PS Patcher GUI? I'm using ver 1.6 and I keep getting an error. What did you use?
    07-03-19 09:22 AM
  14. conite's Avatar
    Thank you! You used PS Patcher GUI? I'm using ver 1.6 and I keep getting an error. What did you use?
    That's what I used. Make sure that the working folder is just off the root drive.
    07-03-19 10:21 AM
  15. billc_ia's Avatar
    I'll move it there. Haven't had issues in the past, but thanks for the tip!
    07-03-19 10:34 AM
  16. billc_ia's Avatar
    That's what I used. Make sure that the working folder is just off the root drive.
    Moved it to the root drive and still got the error: "Package cannot be recompiled." Is there an option I'm needing to turn on? I have them all off.
    07-03-19 10:44 AM
  17. conite's Avatar
    Moved it to the root drive and still got the error: "Package cannot be recompiled." Is there an option I'm needing to turn on? I have them all off.
    Use default settings ONLY.
    07-03-19 10:56 AM
  18. billc_ia's Avatar
    Use default settings ONLY.
    That's what I've got afaik- I've never changed anything. Using Java ver 8.0_201. Have PS Patcher.exe in a subfolder in C:\. Should I update the lib folder with a current version of apktool.jar and signapk.jar that I downloaded?
    07-03-19 11:06 AM
  19. conite's Avatar
    That's what I've got afaik- I've never changed anything. Using Java ver 8.0_201. Have PS Patcher.exe in a subfolder in C:\. Should I update the lib folder with a current version of apktool.jar and signapk.jar that I downloaded?
    Apktool, yes.
    07-03-19 11:07 AM
  20. billc_ia's Avatar
    Apktool, yes.
    That did it! Thanks! I suspected something like that. I updated Java while I was at it.
    07-03-19 11:15 AM
  21. EndRacism's Avatar
    Is this still functional on a Passport? Does everything work? Does current firefox android function?
    07-11-19 05:16 PM
  22. billc_ia's Avatar
    That's what I used. Make sure that the working folder is just off the root drive.
    So, the new version of FoE came out. I patched it successfully with PS Patcher. When I run it, I keep getting, "Unfortunately, Forge of Empires has stopped." Any thoughts?
    07-31-19 10:50 PM
  23. conite's Avatar
    So, the new version of FoE came out. I patched it successfully with PS Patcher. When I run it, I keep getting, "Unfortunately, Forge of Empires has stopped." Any thoughts?
    I'll try it myself, but it probably means the end of the road for that game on BB10.
    07-31-19 10:54 PM
  24. billc_ia's Avatar
    I'll try it myself, but it probably means the end of the road for that game on BB10.
    That sucks. Still Android 4.1+. Let me know if you find anything out. You've been very helpful.
    07-31-19 11:48 PM
  25. conite's Avatar
    That sucks. Still Android 4.1+. Let me know if you find anything out. You've been very helpful.
    Seems to load fine. Are you sure you got the 32 bit version?
    08-01-19 07:34 PM
9,675 ... 385386387

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 116
    Last Post: 05-19-18, 10:54 AM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 11:23 AM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 10:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 10:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 04:01 AM
LINK TO POST COPIED TO CLIPBOARD