1. IvanTheTolerable's Avatar
    Thanks! I'll try this. I can't remember what version I had before. It worked with bridge to my pebble. V4 doesn't seem to push it.

    BB 10 will outlast Android, just you wait! Stage 1: Denial.
    05-29-17 08:35 AM
  2. conite's Avatar
    Thanks! I'll try this. I can't remember what version I had before. It worked with bridge to my pebble. V4 doesn't seem to push it.

    BB 10 will outlast Android, just you wait! Stage 1: Denial.
    The nice thing about Facebook Lite and Messenger Lite, is that the very latest versions work perfectly.
    05-29-17 08:37 AM
  3. ds1979's Avatar
    Hi!

    First of all: Thanks to Cobalt, my BB Passport gets a second life now! This means saving a lot of resources by the 3R's: Reduce, Reuse, Recycle. Now, this is stage 2.

    I have found one app that I cannot patch: "Fabulous"
    Link on Google Play:
    https://play.google.com/store/apps/d...hefabulous.app

    The log says:

    Code:
    Processing C:\PS_Patcher-1.6\co.thefabulous.app.apk
    The package contains 2 classes.dex files
    [Decompiling classes]
    Decompiled 29.85 MB in 13.29 seconds
    Done.
    [Analyzing Package]
    Google Play services dependencies detected
    Found: C:\PS_Patcher-1.6\tmp\co.thefabulous.app\smali\com\google\android\gms\common\k.smali
    Found: C:\PS_Patcher-1.6\tmp\co.thefabulous.app\smali\com\google\android\gms\common\l.smali
    [Analysis completed]
    
    Press CONTINUE to proceed or CANCEL to abort.
    
    [Patching isGooglePlayServicesAvailable]
    .method public static isGooglePlayServicesAvailable(Landroid/content/Context;)I
    in file C:\PS_Patcher-1.6\tmp\co.thefabulous.app\smali\com\google\android\gms\common\k.smali
    Done.
    [Patching isSignatureValid]
    .method static varargs a(Landroid/content/pm/PackageInfo;[Lcom/google/android/gms/common/j$a;)Lcom/google/android/gms/common/j$a;
    in file C:\PS_Patcher-1.6\tmp\co.thefabulous.app\smali\com\google\android\gms\common\l.smali
    Done.
    [Patching isGoogleSigned]
    .method public static a(Landroid/content/pm/PackageInfo;Z)Z
    in file C:\PS_Patcher-1.6\tmp\co.thefabulous.app\smali\com\google\android\gms\common\l.smali
    Done.
    [Rebuilding]
    I: Using Apktool 2.2.0
    I: Checking whether sources has changed...
    I: Smaling smali folder into classes.dex...
    I: Checking whether sources has changed...
    I: Smaling smali_classes2 folder into classes2.dex...
    I: Checking whether resources has changed...
    I: Copying raw resources...
    I: Copying libs... (/lib)
    I: Building apk file...
    Error: Package cannot be recompiled.
    [Cleaning up]
    Done.
    Can anyone help with some ideas?

    What I do is to use the download folder on the BB to copy the apk to a USB stick, then patch it and install from the USB stick. Unfortunately, it doesn't work with this app.

    I will be very thankful for any advice.

    Cheers
    Dejan
    05-29-17 09:55 AM
  4. conite's Avatar
    I have found one app that I cannot patch: "Fabulous"
    Seems to patch fine for me.

    Make sure you are using Patcher 1.6 with default settings, and the latest apktool (2.2.2).
    05-29-17 10:57 AM
  5. ds1979's Avatar
    Emm... how can I update to 2.2.2?
    05-29-17 11:16 AM
  6. conite's Avatar
    Emm... how can I update to 2.2.2?
    Google apktool. Download, rename and replace the older one in the lib folder.
    05-29-17 11:20 AM
  7. dr kaushal patel's Avatar
    in BGshell plus app» after giving last command » ln -s external_sd/Android/WhatsApp WharsApp......showing-»ln: Target file"WhatsApp/WhatsApp"already exist.use ln-f or ln- i to overwrite

    even -f commnd has no result

    media sharing not resolved

    Posted via CB10
    05-29-17 11:58 AM
  8. conite's Avatar
    in BGshell plus app» after giving last command » ln -s external_sd/Android/WhatsApp WharsApp......showing-»ln: Target file"WhatsApp/WhatsApp"already exist.use ln-f or ln- i to overwrite

    even -f commnd has no result

    media sharing not resolved

    Posted via CB10
    I would ask your question in the other thread. The OP has been helping people.
    05-29-17 12:03 PM
  9. puspitawarna's Avatar
    in BGshell plus app» after giving last command » ln -s external_sd/Android/WhatsApp WharsApp......showing-»ln: Target file"WhatsApp/WhatsApp"already exist.use ln-f or ln- i to overwrite

    even -f commnd has no result

    media sharing not resolved

    Posted via CB10
    Ln -s f external_sd/Android/WhatsApp WhatsApp

    But it's better to go to the whatsapp thread rather than discuss it here

    Z10 is my new friend, come from mighty nokia n9 meego harmattan
    05-29-17 10:33 PM
  10. scubafan's Avatar
    I have what is likely considered either a dumb question or a total noob question but I think I'll ask anyway. I actually have made it through the last 8 years without any android apps but there are a few that would be convenient for business travel. From what I've been able to gather so far, the biggest problem with the way that BlackBerry gave us BB10 loyalists the ability to run android apps is that we have such an ancient version of the runtime that the current versions of most apps won't accept it. I know that my brother was very frustrated with his cheap android cell because all the appss he wanted to run said he needed at least 4.4, and many want newer than that.

    Has there been anyone who has figured out how to get a newer runtime since it's obvious that BlackBerry has zero interest in helping us keep our much better devices (especially regarding privacy and true security!) since they moved to the inferior but widely available OS...

    Frankly I get extremely tired of finding more and more businesses making the only easy way to use their services is by Android (or even more of a toy) IOS!
    The last straw was when I flew Delta last month and discovered that the mediocre but usable BB10 version of their app was deliberately disabled! I can accept that they don't want to spend time or effort to update the app, but they are actively killing it! It sometimes is allowed to open but before you can enter the next page you get a full screen pop-up advising you to update to the newest version. The app was never great but at least I could use it as my boarding pass so I never needed to use an insecure, malware-ridden hotel computer to print out the pass! So all I need is to be able to get some basic functionality, even if it isn't wonderful.
    Am I dreaming of something that won't ever happen?
    Thanks!

    Just my $.02, YMMV ! ;-) sent via my Q10
    05-30-17 07:24 AM
  11. Cobalt232's Avatar
    Android Runtime is stuck at 4.3 forever. Why not buy a KeyOne?
    05-30-17 07:51 AM
  12. thurask's Avatar
    Android Runtime is stuck at 4.3 forever. Why not buy a KeyOne?
    Tin foil hat on too tight?
    05-30-17 08:45 AM
  13. Cobalt232's Avatar
    Evil Google everywhere...
    05-30-17 10:46 AM
  14. Mobajo's Avatar
    what happens when apps are updated? for example, the working youtube patched version via cobalt is 10.3... but there's an update via google play store for version 12. 19.
    how do we updated already patched apps
    please advise, thanks
    05-30-17 02:40 PM
  15. conite's Avatar
    what happens when apps are updated? for example, the working youtube patched version via cobalt is 10.3... but there's an update via google play store for version 12. 19.
    how do we updated already patched apps
    please advise, thanks
    Download, patch, update.
    05-30-17 03:47 PM
  16. Mobajo's Avatar
    Download, patch, update.
    sure but dl from where exactly?
    05-30-17 06:04 PM
  17. conite's Avatar
    sure but dl from where exactly?
    Best place is always Cobalt's Google Play Store. That way you'll always get the right variant for BB10.
    05-30-17 06:19 PM
  18. Mobajo's Avatar
    Best place is always Cobalt's Google Play Store. That way you'll always get the right variant for BB10.
    not to sound like a broken record...can u send a link to this specific play store. all I see here, is c"cobalt's app landing page". there's no actual or specific link titled "cobalt's play store". kindly share
    05-30-17 06:33 PM
  19. conite's Avatar
    not to sound like a broken record...can u send a link to this specific play store. all I see here, is c"cobalt's app landing page". there's no actual or specific link titled "cobalt's play store". kindly share
    My link has all of his newest files. You need to install the entire stack.

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.

    If an app requires Google Play Services:
    Download app with Cobalt's Play Store (but don't install).
    Whitelist unpatched app.
    Patch app on PC with Play Services Patcher 1.6 using defaults settings.

    Install patched app.


    If after all that, your app still won't work, then it's simply not compatible with BB10.
    Mark Mendoza3 likes this.
    05-30-17 06:35 PM
  20. Mobajo's Avatar
    My link has all of his newest files. You need to install the entire stack.

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.

    If an app requires Google Play Services:
    Download app with Cobalt's Play Store (but don't install).
    Whitelist unpatched app.
    Patch app on PC with Play Services Patcher 1.6 using defaults settings.

    Install patched app.


    If after all that, your app still won't work, then it's simply not compatible with BB10.
    got it thanks
    05-30-17 06:38 PM
  21. puspitawarna's Avatar
    what happens when apps are updated? for example, the working youtube patched version via cobalt is 10.3... but there's an update via google play store for version 12. 19.
    how do we updated already patched apps
    please advise, thanks
    If it's work well why bother to update?

    Z10 is my new friend, come from mighty nokia n9 meego harmattan
    05-31-17 03:12 PM
  22. Mobajo's Avatar
    If it's work well why bother to update?

    Z10 is my new friend, come from mighty nokia n9 meego harmattan
    good point
    05-31-17 07:24 PM
  23. Onyros's Avatar
    Greetings, fellas!

    I just got a new Passport and I've been busy setting it all up these last couple of days.

    With the invaluable help from this and other Cobalt threads, I got Google Docs working (just can't open them from Google Drive) — all patched. I also installed Google Calendar, but I can't seem to be able to sync. Has anyone had success with Google Calendar?

    I'm using a corporate gmail account, and everything else is working as well as possible, the calendar's the only thing that I'll need daily not working properly right now. I got the out-of-the-box calendar to sync, but some of the functionality I need isn't working.
    06-01-17 05:24 AM
  24. zx9r170's Avatar
    I have read this article numerous times trying to download google play services so that I can install and use apps that aren't available in BB World but for the life of me I can never figure out what I'm supposed to do. I'm finally reading the article on my computer while trying to to what I need to do on my phone but I don't see any file link for google play services. I'm assuming this is the main thing I need if I can't run apps that require it, but I have never had any luck finding any link for the file.
    06-02-17 08:14 AM
  25. Cobalt232's Avatar
    The link to the file share is in the first post, under DOWNLOAD.
    06-02-17 08:54 AM
9,482 ... 340341342343344 ...

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 116
    Last Post: 05-19-18, 10:54 AM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 11:23 AM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 10:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 10:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 04:01 AM
LINK TO POST COPIED TO CLIPBOARD