1. Juned Sayyad's Avatar
    So you started the Google Accounts app and tried to login from there?
    02-27-17 10:32 PM
  2. conite's Avatar
    Anyone had luck with SnapChat? I know I'm late to the game but the latest version from PlayStore doesn't work (big surprise) so I guess APK Mirror would be the best bet for this app also?

    Posted via CB10
    Snapchat doesn't work. Hasn't for a long time.
    02-27-17 10:37 PM
  3. KGreater's Avatar
    Snapchat doesn't work. Hasn't for a long time.
    Again, I'm late to the game lol but thanks for the info, conite!

    Posted via CB10
    02-27-17 10:41 PM
  4. Theoza's Avatar
    You must be on 10.2.1? In that case you should download Google Maps and login from there. Just make sure that you don't have Google Play services installed (com.google.android.gms) or login will not work.
    the links page goes blank,i tried to open it several times but not working
    02-27-17 11:54 PM
  5. Theoza's Avatar
    I clicked and tried to open the official files link,but it went blank
    02-27-17 11:56 PM
  6. jd smithers's Avatar
    I tried to patch Signal 2.0 on my Passport, but it seems that it didn't work.
    Is it possible to patch Signal2.0 for use on my Passport? Or is there an alternative to communicate witch someone who uses Signal?
    Maybe I didn't patched the app. correct. If there is an step by step instruction how to patch this apk. I would love to receive it from you.
    Hi,

    Signal beta (3.30.4) is now working without play services. I put a summary in den BB 10 Apps subforum. Messaging works flawlessly further tests concerning calling still ongoing (there are some hiccups, see their github issues).

    Regards

    Btw: signal 2 is quite outdated. If you still want to patch on, use the latest stable - it works but w/o calling support.
    02-27-17 11:59 PM
  7. roufster's Avatar
    Hi Guys, i need some help.

    I had the whole cobalt play store setup on my bb passport running 10.3.3 and then i did a security wipe. Now, it refuses to install play store with error "unable to install this app". I can install google account, blackberry id and the old version of play services. Play services version 10 gives same error as play store "unable to install this app".

    I also tried auto-loading the full OS again and its not working. What the hell happened???

    thank youuuu
    02-28-17 03:48 PM
  8. conite's Avatar
    Hi Guys, i need some help.

    I had the whole cobalt play store setup on my bb passport running 10.3.3 and then i did a security wipe. Now, it refuses to install play store with error "unable to install this app". I can install google account, blackberry id and the old version of play services. Play services version 10 gives same error as play store "unable to install this app".

    I also tried auto-loading the full OS again and its not working. What the hell happened???

    thank youuuu
    Erase Cobalt files and start over.

    Cobalt's file share:

    [url]https://mega.nz/#F!lIUWjSSQ!yoLoiNX3PNG3Sef1Fa_fMA

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.*
    coffee-turtle likes this.
    02-28-17 03:57 PM
  9. roufster's Avatar
    its not working ... I can't install play service v10. It says "Unable to install this app" ...
    02-28-17 04:06 PM
  10. roufster's Avatar
    Erase Cobalt files and start over.

    Cobalt's file share:

    [url]https://mega.nz/#F!lIUWjSSQ!yoLoiNX3PNG3Sef1Fa_fMA

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.*
    can't install play services v10. says "unable to install this app"
    02-28-17 04:07 PM
  11. conite's Avatar
    can't install play services v10. says "unable to install this app"
    Download it again.
    02-28-17 04:09 PM
  12. roufster's Avatar
    Download it again.
    it worked! that's pretty weird because they're the same file version, dates and sizes i had and installed 2 days ago!!!

    thank you either way!
    02-28-17 04:42 PM
  13. roufster's Avatar
    another question, trying to use the download app feature from PS Patcher 1.6, i check in and get the gid ... but then when i put the package URL or package name, i directly get unknown error. anything else i should use? thanks
    02-28-17 05:10 PM
  14. conite's Avatar
    another question, trying to use the download app feature from PS Patcher 1.6, i check in and get the gid ... but then when i put the package URL or package name, i directly get unknown error. anything else i should use? thanks
    Just download to your device, transfer to computer, patch, transfer back, install. Don't forget to whitelist the unpatched version of the apk.
    02-28-17 05:44 PM
  15. roufster's Avatar
    Just download to your device, transfer to computer, patch, transfer back, install. Don't forget to whitelist the unpatched version of the apk.
    got it, i was trying to download them from within PS Patcher ... already patched a couple of apps. thanks!

    last question (promise), is it normal that uber is showing me 9 dependencies and then tells me this app doesn't need to be patched?
    02-28-17 05:57 PM
  16. conite's Avatar
    last question (promise), is it normal that uber is showing me 9 dependencies and then tells me this app doesn't need to be patched?
    No. Show me a screen shot.
    02-28-17 06:23 PM
  17. Twan01's Avatar
    Thanks.
    I just installed Signal 3.30.4 and it semms that it works.

    Regards,
    coffee-turtle likes this.
    03-01-17 09:39 AM
  18. ilyasuzair's Avatar
    IF YOU ARE NEW TO THIS, YOU MAY WANT TO PRINT THIS PAGE OR READ IT ON A PC SCREEN!

    Hi!

    This thread is all about running Google apps on your Blackberry 10 device. But before we're talking about how to do that, you should first get familiar with some specialities of the Blackberry 10 Android runtime.

    The Android runtime in BB OS 10.3 is based on a modified Android OS 4.3 (Jelly Bean). Blackberry removed all Google services from the runtime and replaced them with a Blackberry specific counterpart.

    The following components have been removed or replaced by Blackberry:
    • Google Account Manager -> Replaced with Blackberry Account Manager
    • Google Services Framework -> Replaced with a stub that redirects Google Cloud Messaging requests to Blackberry Servers (used for push messaging).
    • Google Play Store -> Replaced with Blackberry World
    • Google Play Services -> Removed with no replacement

    As most of the Google apps cannot run properly with this setup, the missing components must be added again to the Blackberry Android runtime. I got my hands on the Android 4.3 GAPPS package, reverse engineered the apps and patched them (Google Account Manager, Google Play Store, Google Play Services), and I wrote an fully compliant emulation of the Google Services Framework (now called Blackberry Google ID) that supports device checkin to the Google services.

    If all files are installed and configured, your BB10 device will be able to run almost every Google app with full features (i.e. Google Maps, Google Photos, Google Sheets). Also 3rd Party apps like Clash of Clans will be able to use Google features (i.e. link the game to your Google account and save progress in the cloud).

    Please note that you will have to patch apps like Google Maps, Google Photos or Clash of Clans so that they can work together with the new Google files on your device. These apps will display an error message such as "This app requires Google Play Services..." if they are not patched. After patching, the message will be gone and the app will be able to use all Google Play Services features.

    Known limitations:
    * Push messaging in Android apps does not work (if the device is in sleep mode)
    * Android Wear is not supported

    INSTALLATION OF ANDROID APPS

    Enable "allow installation of foreign apps" in BlackBerry Settings->App Manager. Download the apps directly to your device and tap the apk file to install. Do not sideload .apk files with Sachesi or any other sideloading tool.


    DOWNLOAD

    All files are available on one single file share. Pick the correct file according to your needs. Read the information section below for more details about the apps.

    Cobalt's official file share


    Google Account Manager: ESSENTIAL

    The Google Account Manager provides full support for Android apps that require a Google login. It is required for most of the Google apps such as Google Maps, Google Play store or Chrome browser. Install the Google Account Manager and login to create a Google system account on your device. Do not remove the app after installation.

    If you are NOT using Google Play Services:
    * Install Google Account Manager 4.3.3 and login.

    if you are using Google Play Services:
    * Install Google Account Manager 4.3.3 and login
    * Install Google Account Manager 4.4.4 over 4.3.3 (do not login again)


    Blackberry Google ID: ESSENTIAL

    The Blackberry Google ID app emulates low level functions of the Google Services Framework. It allows to sign in the device to Google Play Store and it provides content providers that are used to exchange data between Google apps. This app must be installed if you want to use Google Play Store or Google Play Services. Do not remove after installation. Do not unregister after successful registration!

    Latest version: Blackberry Google ID 2.8 [Released on December 23, 2015]


    Google Play Services

    The Google Play services APK contains several individual Google services and runs as a background service in the Android OS runtime. If installed, it provides full Google+ login support. Apps like Clash of Clans or Boom Beach can then synchronize progress with the remote servers. To synchronize game progress, you must also install the patched Google Play Games app.

    Please note that the Google Play Services icon will be labled "Google Settings" and not "Google Play Services" after it has been installed on the device!

    Latest version: Google Play Services 10.0.84 [Released on Januar 6, 2017]

    Latest version:Google Play Games 3.9.08 [Released on January 6, 2017]


    Patching your own apps

    Some apps that you download from Play Store may display an error message such as "Google Play Services is not installed on your device". These apps must be patched in order to run on a Blackberry device. Patching is required because my modified Google Play services is signed with a non-Google signing key and this key doesn't match to the hardcoded key in the apps.

    Please take note of the following rules for installing patched apps:

    1. ALWAYS UNINSTALL ANY UNPATCHED VERSION BEFORE ATTEMPTING TO INSTALL A PATCHED ONE
    2. A patched app can never update an unpatched app (signature mismatch)
    3. An unpatched app can never update a patched app (signature mismatch)
    4. A patched app can always update an patched app (signature is the same, because the patcher always uses the same signature)

    You can download the patcher in this thread. Read the instructions there carefully:
    http://forums.crackberry.com/android...rvices-914930/

    DO NOT PATCH ANY OF THE APPS THAT YOU DOWNLOAD FROM THIS PAGE. THEY ARE PREPATCHED AND READY TO INSTALL!


    Google+ Whitelist

    This helper app spoofs the developer signature of patched apps so that they can use Google features. All patched apps MUST be whitelisted, otherwise they won't work.

    When you run the Whitelist app for the first time, a basic set of spoofed signatures is inserted into the database. You can then add your own signatures by following the instructions below.

    Instructions:
    1. Run Google+ Whitelist
    2. Click on the three dots in the top right and choose add
    3. Select the UNPATCHED apk file of the app and add it to the whitelist
    4. Patch the app with Play Services Patcher
    5. Install the patched version of the app

    Pre-spoofed apps (you don't have to add them anymore):

    com.google.android.youtube
    com.google.android.apps.photos
    com.google.android.apps.chromecast.app
    com.google.android.videos
    com.google.android.apps.fitness
    com.google.earth
    com.google.android.apps.docs.editors.docs (Google Drive)
    com.google.android.apps.docs.editors.slides
    com.google.android.apps.docs.editors.sheets
    com.google.android.apps.cloudprint
    com.google.android.apps.vega (Google My Business)
    com.google.android.apps.enterprise.cpanel (Google Admin)
    com.google.android.apps.m4b (Google My Maps)
    com.google.android.apps.genie.geniewidget (Google News & Weather)
    com.google.android.apps.unveil
    com.google.android.apps.hangoutsdialer
    com.google.android.apps.youtube.creator
    com.google.android.gms
    com.google.android.gm
    com.google.android.talk
    com.google.android.keep
    com.google.android.launcher
    com.google.android.play.games
    com.google.android.googlequicksearch
    com.google.android.music
    com.google.android.apps.books
    com.android.chrome
    com.google.android.calender
    com.google.android.apps.plus
    com.google.android.apps.docs
    com.google.android.apps.magazines
    com.google.android.apps.inbox

    com.supercell.boombeach
    com.supercell.clashofclans

    Google+ Whitelist REQUIRES Blackberry Google ID to be installed on the device, as this app provides the database where the signatures are saved in. If you remove Blackberry Google ID from your device, you will lose your custom added signatures.

    Latest version: Google+ Whitelist 1.0.0.6 [Released on January 6, 2017]


    Google Play store

    The Google Play store APK provides Access to the Google Play app market, where you can browse and download your favorite free and paid Android apps, books or even music. Play Store is also is required by some apps to run correctly, especially if they use any kind of license verification. Google Play store requires Google Account Manager and Blackberry Google ID to be installed on your device.

    The discussion and the download link have been moved to this thread:
    http://forums.crackberry.com/android.../#post11189556



    Community patched apps

    These apps have been patched by community members using my patching tools. They require all of my apps to be installed on the device.

    GetTaxi, Wheely, Lyft, Uber Driver, Uber Cab, TaxiForSure, Ola Cabs, Sidecar Drive [by tatail]
    http://forums.crackberry.com/android.../#post11580948

    Google Youtube 10.37.58 [by hasmukh1]
    https://mega.nz/#!qxxBzAQJ!3p4Zqaef-...tBBwR-KkJDgU9c

    Google Photos 1.6.0.103330409 [by hasmukh1]
    https://mega.nz/#!XgATySRY!VGMFLAx3h...IiS6HKDTtEFvmc


    Android Settings

    The Android Settings APK provides a direct access to the hidden Android settings of the Blackberry device. It also allows to edit the Google Account synchronization settings or to turn off app-notifications being sent to Blackberry hub.

    Android settings with included mobile data configuration option
    https://www.mycloud.ch/s/#S861C2793C...6898FDFF816FF8


    Android Browser

    The Android Browser APK provides a direct access to the original (and hidden) Android browser.


    How to get ALL features working in Google Maps

    • Install Google Account Manager and login
    • Install Blackberry Google ID and checkin
    • Install Google Play Sevices (wait 5 minutes after you installed and let the app settle)
    • Patch Google Maps with Play Services Patcher
    • Remove any unpatched version of Google Maps from your device (if existent)
    • Install patched Google Maps

    All features like instant AGPS lock-on, timeline, starred places etc. will now work as they would on an Android device.


    How to synchronize your village in COC or Boom Beach

    You can fully synchronize your village with your Google Account. The village will then be save, even if you delete the app or change your device.

    If you already have a village in COC/Boom Beach, you'll have to contact Supercell and tell them to link your village to your Google account. Don't tell them that you have a Blackberry device. Tell them that you have a Samsung S6. Supercell will ask you some questions about your village and then give you a code that identifies your village. You can then use that code to link the village on your Blackberry device.

    If you got the code, do the following:

    1. Install the full Cobalt Stack (all of my apps)
    2. Uninstall the existing Clash of Clans
    3. Patch Clash of Clans with Play Services Patcher
    4. Install the patched vesion and then connect your village with the code that your received from Supercell

    If you are a new player and don't have a village yet, you can simply patch the game, install it and link it right after the turorial. Contacting Supercell is not required.
    google play store and some google apps are not running on mobile data but only on wifi connections!. . loving your solutions please update me on thism
    03-03-17 12:51 AM
  19. Cobalt232's Avatar
    Turn on mobile data in Android settings.
    03-04-17 01:14 AM
  20. josher02's Avatar
    I tried to download/open the links from MEGA, it gives my a java error saying it can't open it in my browser. Im pretty tech savvy (or I'd like to think) but i can't see a way around it since it specifically says it can't be opened from pc and must be from mobile device... thoughts?
    03-04-17 09:35 AM
  21. BBwild's Avatar
    I tried to download/open the links from MEGA, it gives my a java error saying it can't open it in my browser. Im pretty tech savvy (or I'd like to think) but i can't see a way around it since it specifically says it can't be opened from pc and must be from mobile device... thoughts?
    You need to download the Mega app from BlackBerry world & then use that
    http://appworld.blackberry.com/webst...ntent/46810890

    Posted on CB10 with my  Passport SE but previously my  Q10
    03-04-17 01:21 PM
  22. josher02's Avatar
    Thabks for the reply. I tried that initially and still got the same java error.
    03-04-17 01:25 PM
  23. ALi Sefidgar's Avatar
    He's just reminding you that you would have to update the framework for 1.3.1 again if you went back.
    03-04-17 01:52 PM
  24. crazy41's Avatar
    Great stuff here. Anyone has experience with the latest working version of Google maps? I'm currently using patched 9.47.3 on Classic SQC 100-1 and they are quite lagy. Thanks.

    Posted via CB10
    03-06-17 03:22 AM
  25. conite's Avatar
    Great stuff here. Anyone has experience with the latest working version of Google maps? I'm currently using patched 9.47.3 on Classic SQC 100-1 and they are quite lagy. Thanks.

    Posted via CB10
    No lag here. Runs as well as any decent Android app.

    Of course the word "lag" is relative when talking about our android runtime.
    Last edited by conite; 03-06-17 at 09:39 AM.
    03-06-17 09:24 AM
9,507 ... 327328329330331 ...

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 116
    Last Post: 05-19-18, 10:54 AM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 11:23 AM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 10:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 10:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 04:01 AM
LINK TO POST COPIED TO CLIPBOARD