1. tayl0rd's Avatar
    Soo... I'm trying to get Google Services to work on my Z10. I had already had older versions of Google ID, Google Account, and Google Play Store working on my phone for a couple of years. There are some new apps that I need to use that require Google Services, so I figured I'd give this a whirl. I uninstalled the old (and working) versions of the aforementioned apps, and installed the newer versions from the links provided in the first post.

    Using the newer files, I can't login to my Google account. I can't register my device. Google Play Store won't connect. When I try to login with the Google Account app, I persistently get:

    "There was a problem communicating with the Google servers.

    Try again later."

    When I try to register my device with the BlackBerry Google ID app, it opens up the Google Play Store app which displays a box with my Google account selected, but when I click "Next", it just re-displays that same box.

    Well, I was going to list out all the issues I was having, but I was troubleshooting while I was writing this post, and fixed my own issue. I'll list the steps that helped me just in case someone else has the same issue and also doesn't want to read through 318 pages of posts.

    If the Google Account app won't connect:
    - Click the 3 dots in the upper right corner
    - Select "Browser sign-in"
    - Enter your login info
    After you do the above, you can (or should be able to) continue on with successfully registering your device and signing in to Google Play Store. However, I tested the services out on a patched version of the Quora app, and it still won't successfully connect to my Google account. It runs through the motions, but after all is said and done, it won't connect. I then tried a patched version of iDevices Connected, but that one crashes immediately upon opening. The un-patched version will run, but gives the "Google Services required" popup and continues on to run and work, sluggish though it may be. I've tried a few other apps, and I'm having better luck with un-patched apps than with patched apps.

    My conversion back to BB10 is almost complete!
    01-21-17 04:19 PM
  2. C_McD's Avatar
    I haven't tried the latest scenario, but my apps were stable, so I saw no need.

    However, now GPS no longer seems to show my current apps, nor those that have updates available?

    Any thoughts on this?

    Z30 10.3.2.556 USA
    01-21-17 04:48 PM
  3. Sergio1997's Avatar
    Thanks Cobalt are there any updates for Google play services?
    01-21-17 04:55 PM
  4. conite's Avatar
    Thanks Cobalt are there any updates for Google play services?
    Just read back even a little bit.

    Check his Mega file share.
    01-21-17 04:56 PM
  5. Sergio1997's Avatar
    Idk if this will help but I find deleting any apps, that have issues rebooting my phone and then installing it again works Idk if that will help but helps me.
    01-21-17 04:57 PM
  6. tayl0rd's Avatar
    I'm having unreliable results with apps. The iDevices Connected app will work one time then not work another time. Weird. The Quora app still won't work properly. It initially went through the motions of logging in, now it just says there's a problem logging into Google Services. Zillow just hangs. Maybe a bunch of reboots will eventually make things more stable and reliable. I've done a series of uninstalls/reinstalls. It's like there's progress but no progress at the same time.
    Last edited by tayl0rd; 01-21-17 at 06:15 PM.
    01-21-17 05:47 PM
  7. Sergio1997's Avatar
    Thank you . Any news on pokemon go?
    01-22-17 04:58 PM
  8. sekulamarko's Avatar
    Hello

    Plese help I have spend a lots of time trying to patch the uber apk and lyft to and it doesn't work. I have downloaded apktool news one. How can I do it and on what version I have to do uber and lyft. thanks
    01-22-17 05:55 PM
  9. joeldf's Avatar
    Thank you . Any news on pokemon go?
    Doesn't that require Android 4.4 or newer? The BB10 runtime is stuck at 4.3.

    Posted via CB10
    01-22-17 06:39 PM
  10. tdtooke's Avatar
    I'm unable to get in app billing to work. It does work on clash of clans which was pre spoofed but apps I whitelist and patch myself get the playstore not configured for billing message even though whitelist says that should be enabled.

    Posted via CB10
    01-22-17 07:43 PM
  11. Cobalt232's Avatar
    What app is that?
    01-23-17 01:05 AM
  12. tdtooke's Avatar
    Basically all non pre spoofed apps I have. Forge of empires, Battlestar Galactica Squadrons and bejeweled classic. I can buy things in the playstore. I mispoke before. The message is that the app I'm using isn't configured for for billing. Do I need to sign in with Google whatever 4.4.4? On blackberry google id I registered with 4.4.3 installed and also signed in when it was 4.3.3 then updated to 4.4.4 without signing in again. Pretty sure this is something I did, just don't know what.

    Posted via CB10
    01-23-17 01:30 AM
  13. Cobalt232's Avatar
    Just be sure that you are using the latest app versions from Post 1. Read the install instructions in post 1 (I updated then recently).
    01-23-17 02:20 AM
  14. Wolfgan's Avatar
    Does anyone else have issues with Google Maps navigation mode? When trying to get directions, any GMaps version newer than 9.33.1 gives me connection errors while trying to retrieve the route (no issues with browsing the maps nor search or even accessing my saved locations).
    I made sure I have the latest Cobalt services up and running and no issues with any other android app. Anyone else suffering the same? Thx, Wolf
    01-23-17 07:51 AM
  15. Sergio1997's Avatar
    It does yea just wanted to ask if anyone found a way to bypass the whole thing to work again.
    01-23-17 11:40 AM
  16. tdtooke's Avatar
    OK I uninstalled everything and started from scratch. First I installed google play services, then account 4.3.3 and logged in. Then I updated With 4.4.4 and did not login again. Then I installed blackberry google id but could not register because of an error having to do with a rejected account token or something. I could only register with 4.3.3. Then I updated to 4.4.4, not logging in, then installed whitelist, then playstore. I still cannot use inapp billing for non prespoofed apps. Every single other thing with whitelist works, maps, using playservices, etc. Did I get the order right?

    Posted via CB10
    01-23-17 10:06 PM
  17. conite's Avatar
    OK I uninstalled everything and started from scratch. First I installed google play services, then account 4.3.3 and logged in. Then I updated With 4.4.4 and did not login again. Then I installed blackberry google id but could not register because of an error having to do with a rejected account token or something. I could only register with 4.3.3. Then I updated to 4.4.4, not logging in, then installed whitelist, then playstore. I still cannot use inapp billing for non prespoofed apps. Every single other thing with whitelist works, maps, using playservices, etc. Did I get the order right?

    Posted via CB10
    Cobalt's file share:

    [url]https://mega.nz/#F!lIUWjSSQ!yoLoiNX3PNG3Sef1Fa_fMA

    Install and login with 4.3.3.
    Install and register with 2.8.
    Install Play Services v10.
    Update 4.4.4 over 4.3.3 (but don't open).
    Install Play Store v6.
    Install whitelist 1.0.0.6.

    If an app requires Google Play Services:
    Download app with Cobalt's Play Store (but don't install).
    Whitelist unpatched app.
    Patch app on PC with Play Services Patcher 1.6 using defaults settings.
    Install patched app.
    gregdjones likes this.
    01-23-17 10:09 PM
  18. tdtooke's Avatar
    I did all of that to the letter but I still have the same problem.

    Posted via CB10
    01-23-17 11:58 PM
  19. conite's Avatar
    I did all of that to the letter but I still have the same problem.

    Posted via CB10
    I don't think you did, otherwise you wouldn't have a problem. Delete everything, reboot, and start again.
    01-24-17 12:08 AM
  20. Sergio1997's Avatar
    Yea just delete everything reboot your phone and reinstall everything, works for me.
    01-24-17 03:27 AM
  21. tdtooke's Avatar
    I assure you I did exactly as I said. I did not however reboot after I deleted everything. After work I'll see what I see.

    Posted via CB10
    01-24-17 11:07 AM
  22. BKA001's Avatar
    Guys i have a problem I can't install new Viber as it shows that old one is still there. Any idea about it? I googled but I found only one video about it on youtube Did anyone try it? I'll really appreciate any help. Thanks you.
    pavanbhokray likes this.
    01-24-17 12:25 PM
  23. conite's Avatar
    Guys i have a problem I can't install new Viber as it shows that old one is still there. Any idea about it? I googled but I found only one video about it on youtube Did anyone try it? I'll really appreciate any help. Thanks you.
    Couple problems here.

    1) you don't sideload Android apps
    2) latest Viber doesn't work, you need an older one:
    http://www.apkmirror.com/apk/viber-m...-apk-download/
    01-24-17 12:34 PM
  24. BKA001's Avatar
    conite Thank you for your advice.
    01-24-17 01:00 PM
  25. vikreddy51's Avatar
    Hey guys quick question. If you install an APK off of Google play store, and it does NOT give you any "missing Google play services" errors. As long as it does not need maps, do you see any reason to patch the apk?

    Posted via CB10
    01-24-17 03:58 PM
9,589 ... 317318319320321 ...

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 116
    Last Post: 05-19-18, 11:54 AM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 12:23 PM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 11:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 11:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 05:01 AM
LINK TO POST COPIED TO CLIPBOARD