1. conite's Avatar
    I'm using Google Maps 9.25.1 patched along with all the Cobalt Google files. No problem running Maps, even signing in.

    The problem is that Google Maps just doesn't work well in terms of voice directions. It often cuts out or doesn't give any directions at all, or gives them too late, say, one freeway exit too late. This isn't a cell signal or GPS issue, as far as I know, because when I use BlackBerry Maps on the same route (for comparison) there are no delays or cutouts. I like Google Maps much better if it's working. I'm not even sure if BlackBerry Maps is being updated these days.

    I'm on a Passport SE with 2876 and the ART update. No other problems with Android apps that I use.

    Is there a better or just different version of Google maps I can patch? Am I just stuck with this problem? Time to go to the Priv (horrors) or worse, an iPhone?



    Posted via CB10
    I don't seem to have issues like that with GMaps on my BB10 devices.

    Maybe you can try Waze. It works well too.
    05-17-16 05:16 PM
  2. KenV54's Avatar
    I don't seem to have issues like that with GMaps on my BB10 devices.

    Maybe you can try Waze. It works well too.
    Thanks, Conite. If /you/ don't have trouble with G-maps, then it is clearly a problem on my phone or with the OS or with my Maps install.

    I prefer Google Maps to Waze. Any suggestions as to G Maps version or installation or ways to troubleshoot this?



    Posted via CB10
    05-17-16 05:23 PM
  3. conite's Avatar
    Thanks, Conite. If /you/ don't have trouble with G-maps, then it is clearly a problem on my phone or with the OS or with my Maps install.

    I prefer Google Maps to Waze. Any suggestions as to G Maps version or installation or ways to troubleshoot this?



    Posted via CB10
    I use v9.25.1 (#925101123)
    05-17-16 05:33 PM
  4. Blackberry Diehard's Avatar
    It works the same way. Just put it in the Patcher 1.4 folder. Don't forget to "update framework".

    Apktool - just Google it and replace the one in the Patcher sub-folder.

    Instructions about getting a developer key for the maps api are back in this thread.
    I did change the (Java) Path. Is there something else that goes into changing the framework.

    Posted via CB10
    05-17-16 06:03 PM
  5. conite's Avatar
    I did change the (Java) Path. Is there something else that goes into changing the framework.

    Posted via CB10
    Check the "update framework" box under options. You only have to do this once.
    05-17-16 06:13 PM
  6. Blackberry Diehard's Avatar
    Check the "update framework" box under options. You only have to do this once.
    Got it, thanks! I'm receiving an error message "Java.exe could not be found)" after I press analyze APK file. Is there any fix for that?

    Posted via CB10
    05-17-16 06:23 PM
  7. AzN_KnIGHT's Avatar
    Anyone able to get Google Chrome to login to their own account? I want to merge my bookmarks
    05-17-16 07:24 PM
  8. conite's Avatar
    Got it, thanks! I'm receiving an error message "Java.exe could not be found)" after I press analyze APK file. Is there any fix for that?

    Posted via CB10
    Under "paths" tab, navigate to your java.exe file.
    05-17-16 08:04 PM
  9. Rizal Khoiruddin's Avatar
    Thanks very much Cobalt for your amazing work! But I got a problem here can anybody help?
    Cobalt's official Google Apps landing page-img_20160518_070516.png
    My maps just shows black screen

    Posted via CB10
    Last edited by Rizal Khoiruddin; 05-17-16 at 11:55 PM.
    05-17-16 08:09 PM
  10. AzN_KnIGHT's Avatar
    Anyone able to get Wechat to work? I can't seem to get the app to load pass the login screen. After I hit login the screen just blanks out. I tried download it directly from Google playstore and I always patched the app and tried it with no success.
    05-17-16 08:33 PM
  11. Blackberry Diehard's Avatar
    Check the "update framework" box under options. You only have to do this once.
    Got It! Now this is message that I'm getting after I press "Analyze APK File":

    Processing Z:\downloads\com.instagram.android.apk
    The package contains 1 classes.dex file
    [Decompiling classes]
    Fatal error: Decompilation failed, aborting.
    [Cleaning up]
    Done.
    05-17-16 10:05 PM
  12. conite's Avatar
    Got It! Now this is message that I'm getting after I press "Analyze APK File":

    Processing Z:\downloads\com.instagram.android.apk
    The package contains 1 classes.dex file
    [Decompiling classes]
    Fatal error: Decompilation failed, aborting.
    [Cleaning up]
    Done.
    Instagram does not use Google Play Services. No need to patch.
    05-17-16 10:32 PM
  13. z30_van's Avatar
    Hi All,

    I have a z30 with 10.3.2.2474 .... been running cobalt Gapps for about 7 months without issues. About a month or two ago I noticed android apps started hanging to the point the ART will hang and any android apps just launch black... reboot needed to resolve.

    Also noticed when this happens even device monitor will not populate properly (CPU, memory ect blank just says loading and spinning circle).

    I've reloaded cobalt Gapps.. (BlackBerry Google id, Google account, Google play services, Google playstore)... I've cleaned third party data from Google accounts.. I've done various combinations... what I have found is that this problem only occurs after I load Google play services.

    Any ideas?? Is this to do with the old OS version I'm on (latest for my carrier rogers). Any suggestions to further troubleshoot appreciated!

    Thanks!

    Posted via CB10
    05-17-16 11:13 PM
  14. conite's Avatar
    Hi All,

    I have a z30 with 10.3.2.2474 .... been running cobalt Gapps for about 7 months without issues. About a month or two ago I noticed android apps started hanging to the point the ART will hang and any android apps just launch black... reboot needed to resolve.

    Also noticed when this happens even device monitor will not populate properly (CPU, memory ect blank just says loading and spinning circle).

    I've reloaded cobalt Gapps.. (BlackBerry Google id, Google account, Google play services, Google playstore)... I've cleaned third party data from Google accounts.. I've done various combinations... what I have found is that this problem only occurs after I load Google play services.

    Any ideas?? Is this to do with the old OS version I'm on (latest for my carrier rogers). Any suggestions to further troubleshoot appreciated!

    Thanks!

    Posted via CB10
    You are describing running low on memory. That's why a reboot fixes it.

    I usually rebooted every couple of days. This is necessary if you have a number of Android apps installed, as the Runtime is prone to memory leaks.
    05-17-16 11:17 PM
  15. z30_van's Avatar
    You are describing running low on memory. That's why a reboot fixes it.

    I usually rebooted every couple of days. This is necessary if you have a number of Android apps installed, as the Runtime is prone to memory leaks.
    Thanks Conite for the suggestion, I will try and watch the memory usage.. if I don't load the Google play services I don't see the issue at all... if I do it will crash within a few hours.. this didn't happen before to me.. racking my brain for what has changed.. wondering if it is an android app I updated ect.

    Posted via CB10
    05-17-16 11:22 PM
  16. Blackberry Diehard's Avatar
    Instagram does not use Google Play Services. No need to patch.
    I installed Watch ESPN, I received an error message "Watch ESPN relies on Google Play Services". I attempted a patch , and received the same error message. Could there be something else preventing the patch?

    Posted via CB10
    05-17-16 11:42 PM
  17. insanan's Avatar
    Unfortunately, CoC is no longer working properly on BB10.
    oh Im very sad to hear tht
    and thanks to tell me
    05-17-16 11:46 PM
  18. Rizal Khoiruddin's Avatar
    Google maps shows black, how to fix it? I am using BlackBerry Z3 with os 10.3.2 and already installed other Cobalt's apps.

    Posted via CB10
    05-18-16 01:14 AM
  19. yachir0's Avatar
    Hey,

    I got myself a blackberry passport but I have trouble after installing the apps. When I try to download an app via play store it immediatley crashes and I am unable to connect to google services entirely. It appears that the app isn't even trying to connect but rather immediatley prompts an error message, saying that it is currently not able to connect. Any ideas why that is happening?

    Thanks in advance!
    05-18-16 02:34 AM
  20. dede koswara's Avatar
    How to install play store on BlackBerry z10 ? Thanks

    Posted via CB10
    05-18-16 05:23 AM
  21. Sri Read's Avatar
    Thanks cobalt, yes I am I 2813 runtime I will wait for 10.3.3 update..then finally will do that.

    Posted via CB10
    05-18-16 05:48 AM
  22. Rizal Khoiruddin's Avatar
    How to install play store on BlackBerry z10 ? Thanks

    Posted via CB10
    -install android gsf login, and login your Google account
    -install the BlackBerry Google ID, and register your device
    -install the app store

    Links to download at page 1

    Posted via CB10
    05-18-16 06:51 AM
  23. Smokeaire's Avatar
    Hey,

    I got myself a blackberry passport but I have trouble after installing the apps. When I try to download an app via play store it immediatley crashes and I am unable to connect to google services entirely. It appears that the app isn't even trying to connect but rather immediatley prompts an error message, saying that it is currently not able to connect. Any ideas why that is happening?

    Thanks in advance!
    First off you did install all of Cobalt's apps per the easy to follow instructions? Did you try patching those apps with Cobalt's Patcher? If not then you should try it.
    05-18-16 07:06 AM
  24. yachir0's Avatar
    Hey, thanks for your reply! I did a reinstall of all files and applied a patch, but now i am stuck in play store where i see a white page and "error unable to connect to server". The login worked for play store but not for google services.
    05-18-16 12:50 PM
  25. Smokeaire's Avatar
    Hey, thanks for your reply! I did a reinstall of all files and applied a patch, but now i am stuck in play store where i see a white page and "error unable to connect to server". The login worked for play store but not for google services.
    I did not mean to imply that you should patch Cobalt's apps. I hope that is not what you did. I meant patch the app from Cobalt's Playstore that you want working.

    Maybe you should uninstall all of Cobalt's apps, reboot your phone and start over step by step.
    05-18-16 05:42 PM
9,365 ... 245246247248249 ...

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 115
    Last Post: Today, 04:07 PM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 12:23 PM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 11:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 11:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 05:01 AM
LINK TO POST COPIED TO CLIPBOARD