1. Thrace Ist's Avatar
    Do you have the Google Play Store and associated services (Account Manager and Google ID) installed? For the patched version of Google Maps to work properly that may be necessary.

    For the Bitaksi app, does the Patcher show a Recommended Patch for Google Maps V2? If not, the Patcher isn't seeing that dependency. I've had this happen a couple of times today and will be writing to Cobalt to see if this is something he can fix.
    Yes, i do have Google Play Strore and associated services installed.
    For Bitaksi app, The patcher only shows depenancy on Google Play. Not A recommended Patch For Google Maps.
    04-13-16 05:31 PM
  2. dman2009's Avatar
    Yes, i do have Google Play Strore and associated services installed.
    For Bitaksi app, The patcher only shows depenancy on Google Play. Not A recommended Patch For Google Maps.
    ```````

    I thought that may be the issue as I've found the same thing with a couple of apps. That patcher isn't identifying the dependency. I'll post to Cobalt now and see what he thinks.
    04-13-16 05:42 PM
  3. Josuemental's Avatar
    Hi cobalt,
    I can't install Google play services in BlackBerry silver? Can u help please!!

    Posted via CB10
    What build did you try? Because build 4 wasn't working for me either, but I just tried build 5 released/uploaded today by Cobalt and it installed just fine, also, have you updated to the latest Android runtime from BlackBerry World?
    04-13-16 05:44 PM
  4. Thrace Ist's Avatar
    ```````

    I thought that may be the issue as I've found the same thing with a couple of apps. That patcher isn't identifying the dependency. I'll post to Cobalt now and see what he thinks.
    Thank you. I really appreciate your efforts to solve this issue. Hope Cobalt will find a solution for Bitaksi.
    04-13-16 05:45 PM
  5. dman2009's Avatar
    Cobalt:

    I'm happy to report that the modified Patcher version 1.5 is working great for the most important apps that I use. I've updated apktool in the lib directory as well.

    However, I've noticed odd behavior while attempting to patch the following apps:

    1. Open Table: The Patcher doesn't identify the Google Maps dependency. Only identifies and patches Google Play Services dependency. App is patched but maps still do not work.

    https://ln.sync.com/dl/e71082820#t3p...vr2uf-yk5p3ub7

    2. Chargepoint: Same as above.

    https://ln.sync.com/dl/63df2b9c0#nvr...hd2x7-n4u6wgia

    3. Garmin Connect: Patcher identifies both Google Maps V1 and V2 dependencies and gets all the way to the end but fails during rebuilding.

    https://ln.sync.com/dl/659ec3940#ity...eafiz-n4hgg75g

    I've attached links to the APKs if you want to analyze what's going on with these apps as I'm sure these issues are present across others.

    Some else mentioned that the Patcher is not identifying Google Maps dependencies in the Bitaksi app either.

    Thanks again for your efforts!
    crmabbitt likes this.
    04-13-16 05:50 PM
  6. Lusitano17's Avatar
    Thank you. I really appreciate your efforts to solve this issue. Hope Cobalt will find a solution for Bitaksi.
    Send Cobalt a BIG donation!
    gfondeur likes this.
    04-13-16 05:51 PM
  7. Lusitano17's Avatar
    Big thank you Cobalt!
    All patches and updates are working well for me too...very happy to have Flightradar Pro integrated and fully functional again..another donation definitely on the way!
    04-13-16 05:54 PM
  8. TGIS's Avatar
    For anyone who doesn't know this already, the official Google Play services does not work.
    With the Cobalt stack installed, it will not install. It will continually give you an "Unable to install" message.
    The problem is traced to the Google Account Manager.
    With it installed, unpatched GPS will not install. If it is deleted, GPS can be installed.
    This creates problems in itself. Deleting Google Account Manager deletes the Google Account on your device, which immobilizes BlackBerry Google ID, because it needs the account.
    When GPS is installed, Google Account Manager cannot be installed, and I haven't found any other way of getting a Google Account.
    Moreover, official GPS doesn't work. No GPS will work. BB10 doesn't support GPS, so it will only give you a "Not supported" message, virtually the same as Cobalt's GPS.
    04-13-16 06:07 PM
  9. dman2009's Avatar
    For anyone who doesn't know this already, the official Google Play services does not work.
    With the Cobalt stack installed, it will not install. It will continually give you an "Unable to install" message.
    The problem is traced to the Google Account Manager.
    With it installed, unpatched GPS will not install. If it is deleted, GPS can be installed.
    This creates problems in itself. Deleting Google Account Manager deletes the Google Account on your device, which immobilizes BlackBerry Google ID, because it needs the account.
    When GPS is installed, Google Account Manager cannot be installed, and I haven't found any other way of getting a Google Account.
    Moreover, official GPS doesn't work. No GPS will work. BB10 doesn't support GPS, so it will only give you a "Not supported" message, virtually the same as Cobalt's GPS.
    So why don't you install Cobalt's modified GPS? That is designed to work with the modified Account Manager and Google ID. The first page of this thread provides the links to all of the necessary files.
    04-13-16 06:30 PM
  10. Ginowine's Avatar
    I guess so,
    I have my Google Play Services 8.4.89-cobalt-Build5 installed
    2. Download Play Services Patcher 5 and coped to existing Play Services folder (which was 1,4)
    3. On develepor console, i created an android key.
    Run Play services Patcher and entering the API key with checking the decompile resources. I am patching correctly.
    Decompiling and patching without any error.

    I run the application and no MAPS.

    both in Google maps or Bitaksi.

    ((
    I guess you forgot to update the JAR file ( APK Tool ) in the lib folder.

    Posted via CB10
    04-13-16 07:13 PM
  11. Lusitano17's Avatar
    So why don't you install Cobalt's modified GPS? That is designed to work with the modified Account Manager and Google ID. The first page of this thread provides the links to all of the necessary files.
    I believe RBF was directing his comment to all the posters who do NOT install the complete Cobalt stack and continue to post the complaints of "unable to install". At least that is how I read it.
    04-13-16 09:44 PM
  12. ganzboy's Avatar
    Now my turn to quit

    My Super Passport OS 10.3.xxx (KITKAT ART)
    04-13-16 10:06 PM
  13. anon(6046683)'s Avatar
    Thank you for your work, Cobalt!
    Tried patching on my bank app. Just like you explained. And works!
    Keep it up!
    04-14-16 12:40 AM
  14. dman2009's Avatar
    I believe RBF was directing his comment to all the posters who do NOT install the complete Cobalt stack and continue to post the complaints of "unable to install". At least that is how I read it.
    Yup, I just read it again and see what you're talking about. My bad. I totally agree with RBF.
    Lusitano17 likes this.
    04-14-16 12:50 AM
  15. Cobalt232's Avatar
    Cobalt:

    I'm happy to report that the modified Patcher version 1.5 is working great for the most important apps that I use. I've updated apktool in the lib directory as well.

    However, I've noticed odd behavior while attempting to patch the following apps:

    1. Open Table: The Patcher doesn't identify the Google Maps dependency. Only identifies and patches Google Play Services dependency. App is patched but maps still do not work.

    https://ln.sync.com/dl/e71082820#t3p...vr2uf-yk5p3ub7

    2. Chargepoint: Same as above.

    https://ln.sync.com/dl/63df2b9c0#nvr...hd2x7-n4u6wgia

    3. Garmin Connect: Patcher identifies both Google Maps V1 and V2 dependencies and gets all the way to the end but fails during rebuilding.

    https://ln.sync.com/dl/659ec3940#ity...eafiz-n4hgg75g

    I've attached links to the APKs if you want to analyze what's going on with these apps as I'm sure these issues are present across others.

    Some else mentioned that the Patcher is not identifying Google Maps dependencies in the Bitaksi app either.

    Thanks again for your efforts!

    I looked into that app. The patcher doesn't find a dependency because there is no dependency to Google Maps Android API.

    But there is a dependency to Google Maps Geolocation API, which seems to be a different kind of API:
    https://developers.google.com/maps/d...on/intro?hl=en

    I modified the patcher to additionally support custom Google Maps Geolocation API keys:

    Play Services Patcher 1.5 beta 2:
    http://homepage.bluewin.ch/simonsmit...-1.5-beta2.exe

    Did not test though, maybe someone can take the task.
    dman2009, gfondeur and Furell like this.
    04-14-16 01:42 AM
  16. Terence SO's Avatar
    Finally found an update but somethings wrong with the server and not downloading, any ideas?

    Posted via CB10
    04-14-16 03:17 AM
  17. Thrace Ist's Avatar
    I looked into that app. The patcher doesn't find a dependency because there is no dependency to Google Maps Android API.

    But there is a dependency to Google Maps Geolocation API, which seems to be a different kind of API:
    https://developers.google.com/maps/d...on/intro?hl=en

    I modified the patcher to additionally support custom Google Maps Geolocation API keys:

    Play Services Patcher 1.5 beta 2:
    http://homepage.bluewin.ch/simonsmit...-1.5-beta2.exe

    Did not test though, maybe someone can take the task.

    The link is gone it seems ??? oh it is back.. again. let me try.
    04-14-16 03:42 AM
  18. dman2009's Avatar
    I looked into that app. The patcher doesn't find a dependency because there is no dependency to Google Maps Android API.

    But there is a dependency to Google Maps Geolocation API, which seems to be a different kind of API:
    https://developers.google.com/maps/d...on/intro?hl=en

    I modified the patcher to additionally support custom Google Maps Geolocation API keys:

    Play Services Patcher 1.5 beta 2:
    http://homepage.bluewin.ch/simonsmit...-1.5-beta2.exe

    Did not test though, maybe someone can take the task.
    Cobalt:

    I tested the new Patcher on Open Table and Chargepoint and both now work PERFECTLY!

    Another donation has been sent. Your hard work is truly appreciated as I love BB10. I know the 4.3.3 RT will soon be completely outdated but I'm trying to keep this going as long as possible and your help has been invaluable.

    Do you think the rebuilding issue can be fixed?
    04-14-16 04:06 AM
  19. Thrace Ist's Avatar
    For Bitaksi.. unfortunately there is no maps yet.. ((
    added geolocation api.. replaced the java with the new one.. compiled with no error. and unfortunately still no maps.. but although i still have no maps, i wanna donate cobalt for his efforts to solve my problem, dman, can you private message me how to donate him ? Thanks.
    04-14-16 04:20 AM
  20. Smokeaire's Avatar
    Update: I vanquished a few monsters this morning. I updated the APK Tool (had to delete the version number because received fatal error), lesson learned. Created Maps Key, and decompiled and patched GPS Essentials, which failed rebuilding yesterday, and was successful. Maps works now.
    Now that I think I know what I'm doing I'm going to try the beta version later today.
    04-14-16 05:51 AM
  21. karswarnava's Avatar
    How did you Patch it?
    I did it using play service patcher.


    Posted via CB10
    04-14-16 06:09 AM
  22. Akure4Life's Avatar
    I get this message

    "The requested URL /simonsmith/files/com.google.android.gms-8.4.89-cobalt-build5.apk was not found on this server."

    When I try to download the latest apk

    Posted Via CB10 from Z30 OS 10.3.2.2836 
    04-14-16 08:59 AM
  23. anon(6046683)'s Avatar
    04-14-16 11:40 AM
  24. chickenman23's Avatar
    Gamin Connect only requires you to have play service installed on your phone to work.
    04-14-16 12:51 PM
  25. dman2009's Avatar
    Gamin Connect only requires you to have play service installed on your phone to work.
    True but it has Google Maps dependencies in it. You can get the basic functionality by patching without the maps fix though. I'm just trying to get full functionality.
    04-14-16 01:52 PM
9,507 ... 230231232233234 ...

Similar Threads

  1. Which android app you want to run on your BlackBerry
    By amritanshu singh in forum General BlackBerry Discussion
    Replies: 116
    Last Post: 05-19-18, 10:54 AM
  2. Will the amazon app store kill the blackberry world app store?
    By Allgoodnicknamesaretaken in forum BlackBerry Passport
    Replies: 26
    Last Post: 01-28-15, 11:23 AM
  3. Getting the PayPal app for my new Passport?
    By JVRudnick in forum BlackBerry Passport
    Replies: 22
    Last Post: 12-22-14, 10:29 PM
  4. Facebook & Crackberry Apps on Passport
    By UKAsh in forum CrackBerry Apps
    Replies: 5
    Last Post: 11-05-14, 10:43 PM
  5. BB Link type App for iphone 6 - ipad ??
    By Chopper110 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-06-14, 04:01 AM
LINK TO POST COPIED TO CLIPBOARD