1. PatrickMJS's Avatar
    I have an unlocked Z30. At home in Canada, I use a Bell simcard. No problem with the APN settings, but if I need to change it, I just go Settings/Mobile Network/APN and all the fields there can be edited.

    In the last couple of years, I've used foreign simcards in Spain, Mexico and Turkey. No problem.

    But this week, in Spain, I purchased a new Spanish simcard and when I put it in, at first I had voice but no data even tho my purchase included data. The APN settings were wrong but I couldn't figure out how to change them. The retailer told me the correct settings. But he didn't know how to access it either.

    I checked on CB and it turns out you have to pull up the keyboard (swipe up from the bottom using 2 fingers) and type APN, then the settings can be edited.

    Funny thing is, when I put my Bell simcard back in, it automatically picked up the correct APN settings for Bell. Then when I put the Spanish simcard back in, it reverts to some other APN settings, not the right one for this simcard. When I checked the help app for apn, it simply says to tap the "gear" icon, which just takes you to the Apn settings screen. Nowhere does it explain about swiping up with 2 fingers and then typing the letters "APN".

    I don't know if this is new due to the OS changes or if it is unique to this mobile carrier, Legara. In any case, it took me some digging to find this solution. I thought some folks out there might have the same issue and if so, hopefully this new thread will be helpful.

    Posted via CB10
    Smitty13 likes this.
    04-16-15 06:39 PM
  2. Zeridialous's Avatar
    Thanks for posting this, it'll be helpful to those who need access to their APN settings quickly.

    Typically what will happen when swapping SIM cards is that your device will read the APN settings from the SIM, which are set by the carrier. This is why you are seeing the behavior of the APN settings reverting to their defaults when swapping out the SIM cards. Changing the APN settings only happens at the device level and doesn't get saved to the SIM card in most cases, hence why they return to the default (and in your case, non-functional values for the Spanish SIM).
    04-16-15 09:48 PM
  3. PatrickMJS's Avatar
    Thanks for your input. You make a good point about reverting to some default apn.

    It seems that the major mobile carriers like Bell & Orange & Vodaphone have the Apn settings stored on their simcards. But the discount carriers like Legara, the one I'm using here in Spain, don't. They assume the retailer or the consumer will change the APN settings themselves.

    I have to say BlackBerry could have made this a little easier by putting a button or some instructions on the APN screen.

    Attachment 347898

    When you tap the APN "gear" icon at the bottom of that screen, here is what you see:

    Attachment 347899

    I also checked the "Help" app and it was ermmm unhelpful to say the least. See screenshot below.

    Changing APN settings-img_20150417_121641.png

    All they had to do was say "Type the letters APN to edit the settings. For all-touch models, use 2 fingers to swipe up from the bottom edge of the screen to pull up the virtual keyboard." Sheesh. Why BlackBerry, why???

    Couldn't they try to be just a little more user friendly?
    Last edited by PatrickMJS; 04-17-15 at 06:47 AM.
    04-17-15 06:26 AM
  4. dpw09's Avatar
    Are you kidding me?
    I got a Telus tablet plan sim (data only) for my z30

    When I put the sum in my z30 it recognizes it's a phone and puts in APN sp.telus.com

    In order to be properly billed for the "tablet" plan I pay for the APN needs to be isp.telus.com

    I had to go through the trouble of messing with escreen to modify APN because I couldn't edit it from APN screen.

    Of course your way is WAY easier. Wish I knew then.
    Thanks for sharing.

     Z30STA100-5/10.3.1.2708 
    04-17-15 09:37 PM
  5. PatrickMJS's Avatar
    You're welcome.

    I also went thru a hassle till I figured this out. My hassle didn't involve escreens. Instead I was treated to an angry simcard vendor who claimed it was my phone that was the problem. (So I walked out without parting with any cash, feeling kinda embarrassed.)

    The next day I found another vendor and, assuming the first guy just had a defective simcard, I was stymied when the same issue arose. The phone recognized the sim as voice-only even though the vendor had authorized the sim for data and voice. This guy tried to be helpful by doing a Google search which led him to Crackberry. But to no avail.

    I took the sim anyway so I could make some phone calls. That night, I decided to check CB and that's when I found a 2 year old thread on this topic.

    All this hassle when they just needed a leetle more detail in the bb10 as I mentioned above. Don't know why they don't focus on the customer's perspective in matters like this. Like, not even in the help screens. Grrrr

    Posted via CB10
    04-18-15 04:08 AM
  6. dpw09's Avatar
    Weird thing is. Before telus I had wind which was awesome. It auto put in the correct APN but it was editable on the first screen.

    Then I moved to an area that does have wind... boo.
    So I tried virgin. It defaulted to BlackBerry.net which gave me voice only

    It was also editable on the first screen so I could change it to pda.bell.ca which then I got data.
    When I switched to Telus it was different. My unlocked z10, my daughter's unlocked z10, my unlocked z30, and my wife's lock(to telus) z10. All the same behaviour. Wonder why some carrier Sims are different than others.

     Z30STA100-5/10.3.1.2708 
    04-18-15 07:23 AM

Similar Threads

  1. Replies: 14
    Last Post: 04-19-15, 10:34 PM
  2. browser settings
    By preeti111 in forum BlackBerry Classic
    Replies: 1
    Last Post: 04-17-15, 09:56 AM
  3. Replies: 2
    Last Post: 04-16-15, 09:51 AM
  4. Replies: 1
    Last Post: 04-16-15, 09:20 AM
  5. Quick set of questions before switching
    By WhinerFoX in forum BlackBerry Classic
    Replies: 0
    Last Post: 04-15-15, 11:56 AM
LINK TO POST COPIED TO CLIPBOARD