1. Thomas_S_Finland's Avatar
    On Wednesday I received my new BlackBerry Z10 - White- Model: Regional Nordic. It is purchased from a bankruptcy auction, presumably from a former carrier called Cubio, which was the_only_BB_retailer here in Finland. I live in Finland and I have intended to use this device here.

    After that, I descended to hell for one (1) reason: I can get the device working on all other things, except....it cannot access the Internet except via WI-FI. For three consecutive days I have tried to get a solution to this, to no avail. I have also had DM discussions with BlackBerrySupport on Twitter.

    The SIM I have is for a Finnsh carrier called Saunalahti. It has talk, sms and unlimited data on 3g. I have used the same piece of plastic for two years on my previous device, a Nokia 808 PureView without any problems. As a matter of fact I had to go back to that one, since I cannot access the Internet using my BlackBerry Z10.

    I checked from BlackBerry. My device, with this PIN, is not locked to any carrier, it is an unlocked device.

    I checked from Saunalahti. There seems to be one thing missing in my settings on the BlackBerry: The APN Settings need to have the word "internet" in the Access Point Name (APN) field. No username or password needed. Just the word internet.

    It's just....I cannot add that word into that field, the device does not let me! No matter how much I tap on that field, I cannot add that small needed piece of information/value. I took a screen print of the issue, it is here as an attachment.

    I am totally clueless. I do not know what to do. My carrier tells me to add that word manually there, my device does not let me. BlackBerrySupport tells me to ask my carrier. Checkmate. I cannot get any help from the (former and only) BB representative in Finland as it has gone bankrupt.

    Everything else is normal. I can call, be called, send SMS'ses and receive them. I just cannot go to the Internet and that is tearing me apart.

    All settings are otherwise normal. My Mobile Network is "On", and so is Data Services (see the other attachment)

    I'm devastated. What to do? Can anybody help?
    Attached Thumbnails Can someone help me get the internet working on my Z10?-img_00000002.png   Can someone help me get the internet working on my Z10?-img_00000003.png  
    12-19-14 04:34 PM
  2. apfx's Avatar
    I tried to delete and manually add the APN values to my Z10 and I had no problem

    Can someone help me get the internet working on my Z10?-img_20141219_225059.png

    Posted via CB10
    12-19-14 04:51 PM
  3. Joshu42's Avatar
    The "Reset to default" icon at the bottom of your APN settings panel is missing... APN settings is usually stored on the SIM card. Changing the card (which can be faulty) might resolve your issue.
    But first, can you type the 5 letters "myver" in your next post, without the quotes, followed by a space, and let the auto-correct change it to your phone version.
    12-19-14 05:04 PM
  4. BenHysa's Avatar
    I have the same problem, cannot edit. In my case, its the carrier. They do not support my model of z10, its just their laziness. I'm planning to switch carrier.

    Posted via CB10
    12-27-14 05:56 PM

Similar Threads

  1. What's the newest Instagram that works?
    By Telvin Mason in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 12-21-14, 02:54 PM
  2. Q5 owner looking to upgrade to the Q10
    By 485 in forum BlackBerry Q10
    Replies: 4
    Last Post: 12-20-14, 07:44 AM
  3. Replies: 4
    Last Post: 12-20-14, 03:05 AM
  4. Replies: 1
    Last Post: 12-19-14, 05:16 PM
  5. Why is my battery life so short?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-19-14, 03:51 PM
LINK TO POST COPIED TO CLIPBOARD