1. CrackBerry Question's Avatar
    The Blackberry passport comes already with a preinstalled OS 10.3. Can i change it to the original version of OS10. OS10.3 is making problems
    03-20-15 03:58 AM
  2. rthonpm's Avatar
    You cannot downgrade to an OS level below the original version on the device. 10.3.0 will be the lowest version your Passport will support.

    Posted via CB10
    03-20-15 04:59 AM
  3. JamBueree's Avatar
    Software versions below 10.3 are not optimised for the Passport.
    03-20-15 05:58 AM

Similar Threads

  1. how to play clash of clans on bbq10??
    By Somskyy in forum Android Apps (Amazon Store & APK Files)
    Replies: 6
    Last Post: 05-12-15, 09:36 AM
  2. How to delete paused downloads in Amazon app store
    By Charliefr3sh in forum BlackBerry Z10
    Replies: 4
    Last Post: 03-21-15, 09:24 AM
  3. 10.3.1.2582 OTA Update
    By shivam kalra121 in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 03-21-15, 03:05 AM
  4. Add memory to Classic?
    By thidisbogus in forum BlackBerry Classic
    Replies: 6
    Last Post: 03-20-15, 06:34 PM
  5. Can BB passport run iOS app?
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 03-20-15, 05:21 AM
LINK TO POST COPIED TO CLIPBOARD