1. frisco49ers's Avatar
    I keep getting this popup on link install
    "An updated Blackberry Desktop Software component must be installed before you can continue"
    I have done this and it gives me an error.
    What am I doing wrong?
    11-29-14 02:30 PM
  2. motomobra's Avatar
    Uninstall BlackBerry Link first. Then head over to blackberry.com/blend and Download BlackBerry Blend for PC (don't worry, it contains Link as well). Run the installer. Blend only works with Passport or P'9983 for now, so if you don't have one of those don't bother installing it. Install just Link and Drivers. Once that's done try de-bricking your device again. Good luck!
    frisco49ers likes this.
    11-29-14 08:07 PM
  3. frisco49ers's Avatar
    YAHOO, it seems to be working, thanks...........
    11-30-14 09:41 AM

Similar Threads

  1. Just bought a white Q10 (anyone switched from iPhone to BB)
    By mactron in forum Rehab & Off-Topic Lounge
    Replies: 7
    Last Post: 12-29-14, 12:59 AM
  2. Cannot save to SD Card
    By aminrajabi in forum BlackBerry Passport
    Replies: 8
    Last Post: 12-03-14, 07:21 AM
  3. Blackberry Classic is Bell going to be adding this unit?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-29-14, 06:11 PM
  4. Replies: 4
    Last Post: 11-29-14, 02:30 PM
  5. How to take a screen shot in BB Passport?
    By Shashikantiyengar in forum BlackBerry Passport
    Replies: 4
    Last Post: 11-29-14, 11:52 AM
LINK TO POST COPIED TO CLIPBOARD