02-01-15 08:00 PM
32 12
tools
  1. heading4tomorrow's Avatar
    Why is this happening on my Z30?

    I know caller is in my contacts address book (Exchange Account) but it only displays the number.

    Any idea?

    Sent from my Z30 using Tapatalk
    03-04-14 03:38 PM
  2. Bdot-1's Avatar
    Happens to me everyday for the last few months (I was on the latest leak before the update)... In fact just an hour ago happened again!

    It's not your phone, it's a bug. A quite annoying one at that

    Posted by a leaky CB10.1
    03-04-14 03:56 PM
  3. wentouch's Avatar
    My Z10 does this too since the latest update from VZ, so I suspect a bug.

    Has the update rolled out for your phone and did you install it if so?
    03-04-14 03:58 PM
  4. heading4tomorrow's Avatar
    Happens to me everyday for the last few months (I was on the latest leak before the update)... In fact just an hour ago happened again!

    It's not your phone, it's a bug. A quite annoying one at that

    Posted by a leaky CB10.1
    My Z10 does this too since the latest update from VZ, so I suspect a bug.

    Has the update rolled out for your phone and did you install it if so?
    Strange that this wasn't reported.
    I am on 10.2.1.2141, which version are you guys running? This is in fact very annoying, I usually avoid answering if caller is not one my 3000 contacts, so now I have to answer everything because of this issue. I am in no mood to downgrade, so I hope this is fixed soon.
    03-04-14 04:42 PM
  5. wentouch's Avatar
    I'm on Z10 VZ 10.2.1.537.

    Yeah, I too usually don't pickup unknown numbers but for some reason I did these recent time, then had to do a double take, since the calls were from peeps in my contacts. Thought I was tripping.
    03-04-14 04:52 PM
  6. heading4tomorrow's Avatar
    I'm on Z10 VZ 10.2.1.537.
    Thought I was tripping.
    Haha, same with me, I kept saving the numbers and then when I go back I realized the number is there!
    03-04-14 05:05 PM
  7. ppeters914's Avatar
    Crap! That's seriously annoying, and another reason for me to stick w/ OS6.

    Anyone know if this bug has been reported to BBRY?
    03-04-14 05:42 PM
  8. trroystory's Avatar
    Thought it was my phone

    Posted via CB10
    03-04-14 09:06 PM
  9. hteszler's Avatar
    Also happening to me since updated to 10.2.1.537

    It displays names for outgoing calls and sms but not incoming.

    Does anybody have a solution?

    Rgds, from Uruguay.
    03-04-14 09:21 PM
  10. heading4tomorrow's Avatar
    This is really weird. So it is not just limited to Z30 either, or 10.2.1.2xxx.
    Let's see if there is anywhere we can report this bug.
    03-04-14 11:33 PM
  11. Elite1's Avatar
    I have it on my Z30 too. I'm also on Z30STA100-5/10.2.1.2141. It also did it on 10.2.1.1925 (which is release 10.2.1.537).

    It's not every call. I'd say it's about half the calls though, so that's a pretty significant percent.
    03-04-14 11:55 PM
  12. heading4tomorrow's Avatar
    I have it on my Z30 too. I'm also on Z30STA100-5/10.2.1.2141. It also did it on 10.2.1.1925 (which is release 10.2.1.537).

    It's not every call. I'd say it's about half the calls though, so that's a pretty significant percent.
    Hmm.. Time for another tweet to BB support?
    Or should we wait to get more people on this thread?
    I'll hold my tweets and let the big guys (like you) do the talking when it's time.
    03-05-14 12:00 AM
  13. erniel's Avatar
    So I'm not imagining it.... its happening to my Z30 alright

    Z30STA100-2/10.2.1.1925

    Z30 STA100-2
    03-05-14 08:18 AM
  14. Bdot-1's Avatar
    Tweet away.. someone needs to tell them

    Posted by a leaky CB10.1
    03-08-14 11:29 AM
  15. mariosraptor's Avatar
    Thought it was only me. It's happening since 1925. Fix it BlackBerry

    Posted via CB10
    03-08-14 12:23 PM
  16. heading4tomorrow's Avatar
    The latest official T-Mo OS running on Z10, still have the problem.
    Latest official Vodafone running on Z30, still have the problem.
    And it is annoying the hell out of me and my wife, she told me yesterday when her friends call her she can't tell who is calling, and she thinks some of her contacts are missing, she had no idea about the caller ID problem.

    Can't get some more exposure on this please? I assume some people don't even realize this is an issue, and to me, it is actually a very serious issue, making the phone feel like a cheap imitation device can't even tell the contact is saved on the device.. Yet I love my Z30.
    04-07-14 10:41 PM
  17. hteszler's Avatar
    How Bdot-1 ?
    04-07-14 11:16 PM
  18. heading4tomorrow's Avatar
    How Bdot-1 ?

    What do you mean?

    Isn't anyone else having this issue, I am trying to figure out if it is the number formatting or some other reason..
    04-09-14 12:14 PM
  19. heading4tomorrow's Avatar
    This crap is still happening!
    07-18-14 03:51 PM
  20. f1mx's Avatar
    Up to Z10STL100-3/10.2.1.3247 still happens to me as well

    The constant updates create also duplicated Facebook contacts. That has got to be related

    Posted via CB10
    07-18-14 03:54 PM
  21. 007Storm's Avatar
    Happening to me as well on my Z10 it's very annoying.

    Posted via CB10
    07-18-14 06:29 PM
  22. heading4tomorrow's Avatar
    This is still happening!
    08-24-14 11:51 PM
  23. Serbanescu Daniel's Avatar
    do you have work space activated ?
    08-25-14 02:24 AM
  24. davinci4real's Avatar
    Happening to me on my z30. Latest official Os. Very annoying

    From Zarafet my Z30.
    08-25-14 02:32 AM
  25. curvezzz's Avatar
    Same issue on Z30STA100-5/10.2.1.3247

    Z30STA100-5/10.2.1.3247 on ATT ?
    08-25-14 05:58 AM
32 12

Similar Threads

  1. Replies: 7
    Last Post: 06-18-14, 09:12 AM
  2. Powertool - Wave not working!
    By lanctot in forum BlackBerry 10 Apps
    Replies: 18
    Last Post: 03-13-14, 07:41 AM
  3. Update to 2102 not booting?
    By chrissmartin in forum BlackBerry Z10
    Replies: 4
    Last Post: 03-05-14, 08:39 AM
  4. Android apps not responding?!?!??
    By obey101 in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 03-05-14, 06:59 AM
  5. Q10 and BB WS-430 Headset Not Working
    By audiostatic in forum BlackBerry 10 Accessories
    Replies: 1
    Last Post: 03-04-14, 07:30 PM
LINK TO POST COPIED TO CLIPBOARD