1. johnnyuk's Avatar
    I'm seeing strange behaviour in the Hub with emails in my Exchange mailbox that are moved by Exchange rules to subfolders of my Inbox. I have 'Sync All Email Folders' enabled in the account on the phone, a god-send of a feature as I have so many email folders so thumbs up for that BlackBerry.

    I also have 'Show Filed Messages' disabled in the Hub settings. What I'm seeing is that some but not all of the emails that go straight to one of my subfolders rather than my Inbox are also appearing as new emails in the Hub, even though the same rule successfully moved both emails that don't appear in the Hub and emails that do.

    At first before I realised it doesn't always happen I thought maybe that's just how it works, only if I file an email from the phone then it disappears from the Hub. But then I noticed something else which made me question how it's supposed to work and if there is a bug as if I read one of the mysterious emails that have appeared in the Hub and then go Back the email vanishes from the Hub view. It's still in the subfolder but no longer shown in the Hub.

    What I want to see is only the emails in my Inbox and Sent Items in the Hub and only the emails that are moved by rules to my subfolders when I go and look inside those subfolders. But what exactly is supposed to happen? And why do the mysterious emails in the Hub vanish after being read?



    Posted via CB10
    04-12-13 02:38 PM
  2. Ecm's Avatar
    I believe this is by design, not a bug.
    I too have rules set up to automatically certain messages to particular folders. Some are automatically marked as Read, others left as Unread.
    The ones marked as read when filed do not appear in the hub; the unread do appear, but with a somewhat different yellow icon. If I open and read the message then return to the hub it disappears.
    This works well for me!

    *** Side question for you... When you manually file a message, do your sub folders appear in alphabetical order? mine don't, and it's a pain in the but since I have about 25-30 at any given time. From what I can recall, they seem to be listed by creation date.
    04-13-13 03:20 PM
  3. johnnyuk's Avatar
    If this is by design then it's a perplexing design!

    The different icon that we see is to tell us that it's a filed message in a subfolder. But as I have disabled 'Show Filed Messages' to me that means they shouldn't appear in the Hub or mailbox top level view. It rather defeats the point of having certain emails go to subfolders if they are always going to appear in the message list.

    As for the order of the subfolders when I go to file a message, yes they are in alphabetical order for me. My mail system is Exchange 2010.

    Posted via CB10
    04-13-13 05:03 PM
  4. Ecm's Avatar
    I think it boils down to the fact that BlackBerry considers it more important to give a notification of an unread message.

    Let's see if anyone else chimes in on this.
    04-13-13 05:34 PM
  5. Hilton_K's Avatar
    My filed messages still show also, not 100% of them but the majority of them.

    Think there is a slight glitch in the hub.

    Posted via CB10
    04-13-13 06:55 PM
  6. johnnyuk's Avatar
    Yes the hit and miss nature where some filed emails still show and some don't makes me think it's not working as intended. I'll be studying the list of fixed issues in 10.1 for this one assuming there will be a list.

    Posted via CB10
    04-14-13 04:40 PM
  7. rockivy's Avatar
    This is happening to me as well with my active sync outlook, u have selected sync all folders and have turned off having them in the hub, when I file those messages to there proper folder on my outlook account they stay in my hub but show as a white folder with yellow border in the hub, it worked for the first few emails I sent to be filed but now it doesn't do that they just stay in the hub and have the yellow border. Pointless to Mr that they stay there since I'm trying to remove it from the hub. Can sone explain what they did to get this to work with an active sync outlook account

    From the Zed of Rockivy
    04-15-13 03:20 PM
  8. johnnyuk's Avatar
    Just read in the comments for the leaked OS 10.1 that this bug is fixed.

    http://crackberry.com/leaked-os-10101429-blackberry-z10

    So we should see things work the way they should when 10.1 is officially released.

    Posted via CB10
    04-20-13 09:49 PM
  9. Hilton_K's Avatar
    Sounds promising.

    Only thing that is needed now is the forward and reply icons and it's pretty much set!

    Posted via CB10
    04-21-13 05:27 AM
  10. drewread's Avatar
    I think it boils down to the fact that BlackBerry considers it more important to give a notification of an unread message.

    Let's see if anyone else chimes in on this.
    I'll chime in.

    If I chose not to "Show filed Messages" I want them hidden. I don't care if they are read, flagged, unread, whatever. They are 'filed' and I have decided not to show them.

    Perhaps two switches, one 'show filed unread messages' and one 'show filed read messages ' would make it more clear as to the intent of that selector.

    Yeah.. from the ZED on CB10
    johnnyuk likes this.
    04-21-13 07:23 AM
  11. rockivy's Avatar
    Well installed the leaked 10.1 and this issue is gone, you have to move whichever filed ones are still showing back to the inbox but once you do that then re file them they leave the hub


    Cheerz

    From the Zed of Rockivy
    05-09-13 02:43 PM
  12. Hilton_K's Avatar
    Good to hear!



    Posted via CB10
    05-13-13 06:41 AM
  13. jhnptrlimo1's Avatar
    This may be true, but if you move something from the inbox to another folder on Outlook at work or wherever, it still shows up as filed under the inbox. You should not be able to see them no matter where you file the message...phone or computer. I'm on 10.1 and it is still happening.

    Well installed the leaked 10.1 and this issue is gone, you have to move whichever filed ones are still showing back to the inbox but once you do that then re file them they leave the hub


    Cheerz

    From the Zed of Rockivy
    05-13-13 11:12 AM
  14. rockivy's Avatar
    This may be true, but if you move something from the inbox to another folder on Outlook at work or wherever, it still shows up as filed under the inbox. You should not be able to see them no matter where you file the message...phone or computer. I'm on 10.1 and it is still happening.
    I saw this too, make sure the folder you are sending to is synced with the spinning arrows. Try moving the filed messages back to your inbox then make sure your folder is sync enabled them move them back that worked for me

    From the Zed of Rockivy
    05-13-13 02:23 PM
  15. jhnptrlimo1's Avatar
    Yikes!! Thats a lot of emails!!! Urgh!!! Thx for the tip!
    I saw this too, make sure the folder you are sending to is synced with the spinning arrows. Try moving the filed messages back to your inbox then make sure your folder is sync enabled them move them back that worked for me

    From the Zed of Rockivy
    05-13-13 02:57 PM
  16. dlwillia's Avatar
    I have Comcast (pop3) and am unable to file messages and I still have a copy of sent messages cluttering up my hub even with show filed and sent messages turned off. How can I get this to stop.

    Posted via CB10
    05-16-13 07:03 PM
  17. ssprecher01's Avatar
    Guys, I am still having problems with this, and it is a year later.
    05-07-14 07:24 AM
  18. Omnitech's Avatar
    The thing I'm having trouble with these days is Hub ignoring "show sent messages" for certain accounts, and displaying them even though I have that set OFF. (POP3 in this particular case, and possible some IMAP accounts as well)
    05-07-14 09:07 AM
  19. ramsrule45's Avatar
    The thing I'm having trouble with these days is Hub ignoring "show sent messages" for certain accounts, and displaying them even though I have that set OFF. (POP3 in this particular case, and possible some IMAP accounts as well)
    I just switched Q10's, has anyone found a fix for this. It is really annoying for sure.
    08-07-14 06:36 PM
  20. ramsrule45's Avatar
    I honestly can't take credit for this but i found this on another post. If i knew how to share the post i would give credit where credit is due!

    "Switch from single message view to conversation view and back again. This has fixed things in the Hub when the Hub reset hasn't because it forces a reindexing of the messages."
    08-07-14 07:02 PM
  21. Ruskafarian's Avatar
    I honestly can't take credit for this but i found this on another post. If i knew how to share the post i would give credit where credit is due!

    "Switch from single message view to conversation view and back again. This has fixed things in the Hub when the Hub reset hasn't because it forces a reindexing of the messages."
    Just experiencing this problem in 10.3, on a Passport, with Blend... man, you can't imagine how annoying this is.... but doing the "single" display style seems to fix it - somewhat... you lose the ability to keep the "conversation" display style, but at least all of your filed e-mails disappear....

    however, (as per the recommended trick above), when I switch back to "conversation" style, all of the filed messages re-appear....

    sucks.
    11-17-14 08:51 AM

Similar Threads

  1. Filing Messages in BIS (Verizon)
    By SirVancelot in forum Native BlackBerry OS Apps
    Replies: 1
    Last Post: 12-03-11, 12:42 PM
  2. Replies: 1
    Last Post: 09-04-11, 03:39 AM
  3. Replies: 0
    Last Post: 08-31-11, 05:11 AM
  4. Bridge only showing 20 messages in All Message view
    By mdkirstein in forum BlackBerry PlayBook
    Replies: 1
    Last Post: 08-03-11, 12:33 PM
  5. Showing BBM messages in Hidden Today themes
    By BellaLuna in forum Theme Developers Corner
    Replies: 6
    Last Post: 08-14-09, 10:22 PM
LINK TO POST COPIED TO CLIPBOARD