08-17-16 11:07 PM
43 12
tools
  1. Farzeen25's Avatar
    Yeah they are just all holding it wrong...

    It's an outdated Browser... if it works for you use it. But don't tell others that they are doing something wrong - the BB10 browser is outdated and not working well on some sites with updated security requirements and clearly on Google with what they are doing or testing.

    Those still using BB10 will have to hope that 10.3.3 does in fact include an update to the Browser.
    As you can clearly see it was the google server causing the issue. We all know for a fact that the BB10 Browser is the outdated, but it has still not lost all its shine and glory. It still does its job pretty well. An updated browser and all such things are just wishful thinking. Let's see how blackberry goes with the updates for bb10.

    Posted via CB10
    08-04-16 12:53 PM
  2. Bonnie Bonzai's Avatar
    I have never had my browser crash at all! I don't understand why people complain about the BlackBerry 10 browser. It does page rendering much faster than the other android browsers. I firmly believe you all have to clear of your browser history, cache once in a while!

    Posted via CB10
    I feel the same way! No problems with my browser and yes it renders pages faster! I clear my history most nights and clear the cache once every few months.

    Posted via CB10
    08-04-16 01:00 PM
  3. keliew's Avatar
    It started to happen for me recently as well.

    I removed an app cleaner for cache, RAM, etc and so far it works fine.

    BlackBerry Passport via CB10
    08-05-16 01:20 AM
  4. Heavens1's Avatar
    Okay, so my 2 week old Classic crashed and did an auto reset last night. The only app open was the browser and I was reading the Crackberry Forum page (lol!) when it happened. (And I don't have any apps not already supplied and installed by Blackberry on the device.)

    I immediately put it down to my telco (Optus AU), but hey, who the devil knows
    08-05-16 04:27 AM
  5. gunnergrrl's Avatar
    For those of you fortunate enough not to experience crashes - bravo for you. But don't patronize those who are experiencing it by putting it down to user error or impatience. Something is wrong. I'm on my second Leap - serviced, wiped, custom non-native app-free and media free reloaded several times and it still. keeps. happening. At least there's the validation of knowing I'm not alone.
    Heavens1 likes this.
    08-12-16 07:18 PM
  6. Farzeen25's Avatar
    For those of you fortunate enough not to experience crashes - bravo for you. But don't patronize those who are experiencing it by putting it down to user error or impatience. Something is wrong. I'm on my second Leap - serviced, wiped, custom non-native app-free and media free reloaded several times and it still. keeps. happening. At least there's the validation of knowing I'm not alone.
    Why not try loading another OS Version? Maybe that can be a temporary fix until 10.3.3 rolls out.

    Posted via CB10
    08-12-16 11:38 PM
  7. zambanini's Avatar
    you also may remove the facebook apps
    08-13-16 01:58 AM
  8. ZeBB45's Avatar
    There's certain sites my native and third-party browsers refuse to play nice with.

    I plan to ride out the BB10 days to the end, but the browser is the one thing I wont overlook when it inevitably worsens.

    PP SE - 10.3.2.2876/SR .2836  < α∂∂ιт > 
    08-13-16 05:46 AM
  9. Farzeen25's Avatar
    There's certain sites my native and third-party browsers refuse to play nice with.

    I plan to ride out the BB10 days to the end, but the browser is the one thing I wont overlook when it inevitably worsens.

    PP SE - 10.3.2.2876/SR .2836  < α∂∂ιт > 
    Could you please mention those sites? Maybe I could confirm.

    Posted via CB10
    08-13-16 10:01 AM
  10. ZeBB45's Avatar
    Could you please mention those sites? Maybe I could confirm.

    Posted via CB10
    This site (for me) doesn't 'play nice' and gets stuck in a perpetual loading loop:
    http://animalcrossing.wikia.com/wiki..._Crossing_Wiki

    Thank you!

    PP SE - 10.3.2.2876/SR .2836  < α∂∂ιт > 
    08-13-16 11:04 AM
  11. Farzeen25's Avatar
    This site (for me) doesn't 'play nice' and gets stuck in a perpetual loading loop:
    http://animalcrossing.wikia.com/wiki..._Crossing_Wiki

    Thank you!

    PP SE - 10.3.2.2876/SR .2836  < α∂∂ιт > 

    Browser crash on BlackBerry 10-img_20160813_215252.png

    Attachment 406341


    Your welcome.

    I frankly didn't have any issues loading the website. And, I was surprised to find the website had loaded within a few seconds. I am not sure what is causing you the issue. As a side note: I do not use a PPSE, I have the piano black edition. I know it does not help, but I just wanted to confirm.

    Browser crash on BlackBerry 10-img_20160813_215831.png

    I use the exact similar OS version as yours. This is really weird...

    Posted via CB10
    08-13-16 12:30 PM
  12. wilkto's Avatar
    I have a similar problem. Don't sweat it, download Evolution Browser. Problem solved.

    Posted via CB10
    08-13-16 01:05 PM
  13. xpentor's Avatar
    Same here. From the last 2 weeks, there are numbers of random crashes. Never happened before. A reset does not do wonders, random crash is now inevitable, signs of obsolete browser?

    Posted via CB10
    08-14-16 01:15 AM
  14. zambanini's Avatar
    I removed the facebook app, now I do not havy any browser problems
    08-14-16 02:20 AM
  15. ioan_calin's Avatar
    Now the Facebook browser stopped working, in spite of clearing cache, history, bla bla. In general, the performance of my Passport has decreased. Looks like it's time to change it. Random reboots now are happening, too.

    Posted via CB10
    08-17-16 02:52 AM
  16. dman2009's Avatar
    Admittedly, I'm also having some browser crashes on a Verizon Z30. On certain sites, including Crackberry, the browser will close and every other app I had minimized will close as well leaving me with the "grayed out" tiles. I thought it was just me. I'm actually kind of glad that others are experiencing this. Hope it gets fixed in 10.3.3!

    Posted via CB10
    08-17-16 06:07 PM
  17. Invictus0's Avatar
    Admittedly, I'm also having some browser crashes on a Verizon Z30. On certain sites, including Crackberry, the browser will close and every other app I had minimized will close as well leaving me with the "grayed out" tiles. I thought it was just me. I'm actually kind of glad that others are experiencing this. Hope it gets fixed in 10.3.3!

    Posted via CB10
    That's likely a available memory issue, do you have any Android apps installed? If so, can you close all of them from the CPU tab of Device Monitor (you may have to open all of them at once and then close from DM ) and see if the browser still crashes as often?
    08-17-16 06:35 PM
  18. diegodiazvaldez's Avatar
    BlackBerry 10 devices are becoming a paperweight, selling the phone ASAP to recover some investment and buy an Apple or Samsung flagship seems to be the most logical decision.
    08-17-16 11:07 PM
43 12

Similar Threads

  1. On Android, how do I add BBM to Hub?
    By CrackBerry Question in forum Ask a Question
    Replies: 11
    Last Post: 08-08-16, 10:12 PM
  2. Replies: 5
    Last Post: 08-04-16, 11:46 AM
  3. my browser crashes in ver 10.3.2.2836 & Model STA100-2
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 08-03-16, 06:20 PM
  4. Where is the IP address on my Q5 located?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 08-02-16, 08:21 PM
  5. Blackberry Porsche Design P'9983 Normal (Carbon) or P'9983 Graphite?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 08-02-16, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD