1. brian4591's Avatar
    **Edit Dec 30th, 2015. Replaced phone with new Passport. Did the phone switch through BlackBerry Link. The new phone has no issues with Bluetooth now. It was a HARDWARE ISSUE. **

    I installed the leaked version of 10.3.1.2267 (which is apparently the version sent out to unlocked passports, so kinda official). My Bluetooth has had major issues staying connected. I have used this Bluetooth visor mount (BlackBerry) for years with no problems with my 9900, Z10 and Passport.

    Details:
    - Bluetooth connects and works for around 20min
    - then disconnects and reconnects automatically
    - then will disconnect and reconnect automatically again a couple minutes later
    - this will continue on with the time inbetween getting shorter and shorter until it won't connect again

    Troubleshooting:
    - I have removed Bluetooth device and re-setup fresh
    - I have removed the Bluetooth bar file and reinstalled using Sachesi

    Nothing seems to fix my problem yet.
    Anyone else having these issues?
    Any suggestions?
    Last edited by brian4591; 12-30-15 at 11:32 PM.
    02-23-15 08:06 PM
  2. anon(9208252)'s Avatar
    Had the same problem in an older OS, i had to switch the radio to make it stay connected.
    brian4591 likes this.
    02-23-15 08:08 PM
  3. brian4591's Avatar
    Had the same problem in an older OS, i had to switch the radio to make it stay connected.
    I have never had to switch a radio file. Is it easy? Is it the same as switching the Bluetooth bar file using Sachesi?

    Thanks.
    02-24-15 10:45 AM
  4. anon(9208252)'s Avatar
    I have never had to switch a radio file. Is it easy? Is it the same as switching the Bluetooth bar file using Sachesi?

    Thanks.

    Its easier to do with an auto loader as doing the radio only is non destructive, so you don't lose anything.
    Just find out which radio is best for your carrier or device, then get it from Thurask os archive, its in the stickies in the leaks/beta section on the threads,
    02-24-15 12:09 PM
  5. tmurphx5's Avatar
    I am having issues with the Pebble watch, Pebble battery only lasts around 16hrs vs 5. Days before the update. Pebble battery is draining 10% every 90 mins or so. I hope the latest leaked patch fixes it, I have read elsewher that the radio file was updated.

    Passport running on 10.3.1.2267
    02-24-15 12:48 PM
  6. anon(9208252)'s Avatar
    I have never had to switch a radio file. Is it easy? Is it the same as switching the Bluetooth bar file using Sachesi?

    Thanks.

    Also have you noticed in the leaked os section Bla1ze has come out with a file you load through Sachesi and it might fix all your problems.
    02-24-15 12:54 PM
  7. dcwbearsaint's Avatar
    I just paired my new SQW100-3 Passport to my Ford F150 King Ranch (SYNC2) and had this disconnect issue. My old phone SQW100-1 I had for 5 months did not have an issue. I did load the new 10.3.1.2480 leak on it as well (on top of 2267).

    I will experiment with some radios in the next few days and see if this issue gets better with a radio downgrade. Does anyone know what radio had success?



    Also have you noticed in the leaked os section Bla1ze has come out with a file you load through Sachesi and it might fix all your problems.
    02-25-15 08:59 AM
  8. dcwbearsaint's Avatar
    Did some more work on the Bluetooth issue. Loaded a radio from 1956 and it still disconnects a couple minutes after connecting. I did not have this on my SQW100-1 with the same code. I am now trying Bluetooth bars from earlier releases to see if this helps. Quickly is this new and lovely device beginning to irritate me.
    02-25-15 04:45 PM
  9. dcwbearsaint's Avatar
    I called BB tech support (as there was a nice card in the AT&T box that said I had 30 days of complimentary support)...that was the nice part about it. I talked to Peter (probably not his real name...his accent did not fit Peter). Anyway, after starting to explain my problem where I had just bought a new AT&T Passport and had an original Passport, where as one worked with my Ford 2010 F150 King Ranch SYNC system and the other drops out after a minute. I got disconnected after trying to supply him the second PIN number.

    Anyway...called back in and got someone else, who did some research and began telling me that Ford has not tested 10.3.1 and it was their problem and not Blackberry. Nevermind that the original gen Passport worked just fine with the same OS as the new AT&T. I then explained that the new AT&T Passport also had issues with a couple of other Bluetooth external speakers whereas the other phone did not. She spent another 10 minutes trying to tell me that the devices had to qualify their product with the new OS.

    Anyway, she finally told me she would open a case to upload logs etc and they would get back to me in a few days after submitting the logs.

    Being just a bit frustrated (as I have owned OS7 devices, Z10, Z30, and OG Passport without this kind of issue), I just picked up the phone and called AT&T Customer Care, gave them my business account info and explained the problem. 15 minutes later, I had an return label, and another Passport on order. While I will probably not get the new one before I send the old one back, at least they took charge of the problem. I have had good praise of Blackberry before, but this experience has put that in question. Still love my Blackberry's, but the company needs to improve its support.
    02-25-15 08:59 PM
  10. tmurphx5's Avatar
    I called BB tech support (as there was a nice card in the AT&T box that said I had 30 days of complimentary support)...that was the nice part about it. I talked to Peter (probably not his real name...his accent did not fit Peter). Anyway, after starting to explain my problem where I had just bought a new AT&T Passport and had an original Passport, where as one worked with my Ford 2010 F150 King Ranch SYNC system and the other drops out after a minute. I got disconnected after trying to supply him the second PIN number.

    Anyway...called back in and got someone else, who did some research and began telling me that Ford has not tested 10.3.1 and it was their problem and not Blackberry. Nevermind that the original gen Passport worked just fine with the same OS as the new AT&T. I then explained that the new AT&T Passport also had issues with a couple of other Bluetooth external speakers whereas the other phone did not. She spent another 10 minutes trying to tell me that the devices had to qualify their product with the new OS.

    Anyway, she finally told me she would open a case to upload logs etc and they would get back to me in a few days after submitting the logs.

    Being just a bit frustrated (as I have owned OS7 devices, Z10, Z30, and OG Passport without this kind of issue), I just picked up the phone and called AT&T Customer Care, gave them my business account info and explained the problem. 15 minutes later, I had an return label, and another Passport on order. While I will probably not get the new one before I send the old one back, at least they took charge of the problem. I have had good praise of Blackberry before, but this experience has put that in question. Still love my Blackberry's, but the company needs to improve its support.
    I guess my Pebble watch wasn't qualified and that is why the battery on it drains in 16 hrs rather than 120 hrs like on the original OS released on the passport

    Passport running on 10.3.1.2267
    02-26-15 12:20 AM
  11. BBPandy's Avatar
    @Brian try the 2480 leak as it sounds like that will be the official release for the Passport (a number of carriers are waiting for it B4 pushing their updates)

    Posted via CB10
    brian4591 likes this.
    02-26-15 01:59 AM
  12. tmurphx5's Avatar
    I just got a notification that TalkToWatch App has been updated, I just installed it. There is no change log, I am hoping it fixes the battery issue. Will report back later.

    Passport running on 10.3.1.2267
    02-26-15 08:35 AM
  13. brian4591's Avatar
    Did some more work on the Bluetooth issue. Loaded a radio from 1956 and it still disconnects a couple minutes after connecting. I did not have this on my SQW100-1 with the same code. I am now trying Bluetooth bars from earlier releases to see if this helps. Quickly is this new and lovely device beginning to irritate me.
    Did you get around to trying any other Bluetooth bar files?

    I might try installing the leaked 2480 and see if that changes anything
    02-28-15 10:29 AM
  14. tmurphx5's Avatar
    Did you get around to trying any other Bluetooth bar files?

    I might try installing the leaked 2480 and see if that changes anything
    I installed the 2480 patch and it did not solve the pebble battery drain issue. Apparently BlackBerry are aware of the pebble issue and have some type of fix but it is not yet available

    Passport running on 10.3.1.2480
    02-28-15 12:04 PM
  15. BBPandy's Avatar
    Apparently BlackBerry are aware of the pebble issue and have some type of fix but it is not yet available

    Passport running on 10.3.1.2480
    Just curious. What's your source?

    Posted via CB10
    02-28-15 08:56 PM
  16. tmurphx5's Avatar
    Just curious. What's your source?

    Posted via CB10
    Someone on the Talk2Watch thread.

    http://forums.crackberry.com/showthread.php?p=11403386

    I have just received a response by BlackBerry about the battery issue. They say they have fixed the issue internally but don't know yet when the update will be available.




    Passport running on 10.3.1.2480
    02-28-15 11:03 PM
  17. anon6040766's Avatar
    I just bought my AT&T Passport on Feb 20. Since that day my phone has had issue connecting to and/or staying connected to the Bluetooth in my car. It's a Ford Fusion 2014. I think I know the issue. The Fusion has Sync which is different from myFord Touch. My Q10 use to link up perfect with Sync and no changes to home screen, etc. Now the Passport home screen changes to the myFord Touch screen with BlackBerry Steering Wheel Logo, etc. So I think my phone isn't connecting correctly. I'd say it stays connected 60% of the time. Does that make sense. Anybody have any advise besides reloading the OS, loading a leak, or changing the radio?

    Posted via my amazing BlackBerry Passport
    02-28-15 11:15 PM
  18. dcwbearsaint's Avatar
    Did you get around to trying any other Bluetooth bar files?

    I might try installing the leaked 2480 and see if that changes anything
    I resolved the issue by returning the AT&T phone via an RMA and reordering a new one. I could only find one person that had a similar issue and that was his or her solution. I called BB support and got the "it must be Ford issue" answer as Ford had not tested this version OS...while the rep totally ignored the statement that my other BB 10 devices on the same version did not have the issue.

    I will have my new replacement on Monday and the first thing I will do before connecting to Balance or installing apps, will be testing the Bluetooth on my Ford truck. There are too many vehicles like this on the road for this to be an Mfg wide problem...I am hoping it was a phone defect and this will be history tomorrow.
    03-01-15 11:47 AM
  19. dcwbearsaint's Avatar
    A follow-up on my issue. The new phone was received yesterday. It was factory sealed this time where-as the first time it was not. Anyway, the new phone works correctly with the default OS (10.3.1.1955) and the new/patched OS (10.3.1.2480). So in my case it was a hardware issue.
    03-03-15 12:38 PM
  20. brian4591's Avatar
    Fixed my issue.

    Replaced Passport because of screen lifting and the new one has had no issues with Bluetooth connection.

    It has nothing to do with OS, Bluetooth settings nor Bluetooth device. It was hardware issue!

    Posted via CB10
    12-30-15 11:30 PM

Similar Threads

  1. Snapchat on Passport
    By blanc71 in forum BlackBerry Passport
    Replies: 56
    Last Post: 02-10-16, 11:34 PM
  2. Replies: 63
    Last Post: 09-30-15, 10:22 AM
  3. Sprint: No 10.3 update.
    By Virg54 in forum Ask a Question
    Replies: 9
    Last Post: 03-09-15, 06:20 PM
  4. Replies: 8
    Last Post: 02-24-15, 08:38 AM
  5. How to install an APK on 10.3.1
    By hugh_jorgan in forum BlackBerry Q10
    Replies: 2
    Last Post: 02-23-15, 08:05 PM
LINK TO POST COPIED TO CLIPBOARD