11-11-15 01:04 PM
41 12
tools
  1. SackHarry's Avatar
    Everyone including me has had the problem of trying to backup your phone and it shows as backing up but then just stops and goes away as if it's completed, meanwhile nothings been backed up.. as well, when restoring the same thing, have to try to restore it four or five times before the software will actually do it..

    Blend, is this software completely pointless? Everytime I try to use it when I click text msgs or some other icon on the computer it freezes and relaunches. This is on a mac.

    Just horrible pieces of software that can only guarantee you one thing: constant crashes.

    I'M TALKING ABOUT MAC ONLY. NOT PC. The issues are with MAC only it seems!!
    Posted via CB10
    Last edited by SackHarry; 11-07-15 at 05:01 PM.
    10-26-15 08:43 AM
  2. theonecid's Avatar
    Everyone including me has had the problem of trying to backup your phone and it shows as backing up but then just stops and goes away as if it's completed, meanwhile nothings been backed up.. as well, when restoring the same thing, have to try to restore it four or five times before the software will actually do it..

    Blend, is this software completely pointless? Everytime I try to use it when I click text msgs or some other icon on the computer it freezes and relaunches. This is on a mac.

    Just horrible pieces of software that can only guarantee you one thing: constant crashes.

    Posted via CB10
    I agree. I still can't even backup using Link. It keeps erroring with "backup did not complete". Not even settings alone will back up.
    10-26-15 09:22 AM
  3. james-007's Avatar
    Can't even connect half of the time. Got a good backup but could not restore to another device. Something to do with IDs don't match. It won't accept my password on the old device for BlackBerry ID and won't restore the backup on the old. All I want are the text messages. Piece of sh!!!!!t

    Posted via CB10
    10-26-15 09:44 AM
  4. skstrials's Avatar
    Both are working perfectly on my Windows 10 tablets.


    Windows brah.

    Posted via CB10
    10-26-15 10:14 AM
  5. Dr J39's Avatar
    Not including me. Maybe I am just lucky, but I use Link to back up, every couple of weeks, and am not having any problems. I can't speak for Blend, because, even though I have it installed, I have just never used it. Using Z10 (probably until it dies.)
    10-26-15 11:02 AM
  6. mad_mdx's Avatar
    Link has always worked perfectly for me.
    I've had an issue lately where my phone wasn't being detected, and reinstalling the software fixed it. Maybe you can try that?

    It's also the only software capable of doing what it does. Even apple doesn't have software capable of the same type of backup as link.

    Blend works for me, except it's really terrible with SMS. I'm not sure which systems it's optimized for, but it needs optimization for the SMS part of it. I think this is also because of the SMS app itself in the phone
    10-26-15 12:04 PM
  7. Richard Buckley's Avatar
    I have Link on my desktop and laptop, both Windows 7 and have used them without issue for at least 18 months. Blend is on my iPad and also works well.

    LeapSTR100-2/10.3.2.2639
    Toodeurep likes this.
    10-26-15 12:24 PM
  8. theonecid's Avatar
    I think it messes up when your backup file starts being too large. I think a full backup for me would be larger than 5GB if the backup worked.
    Consistently getting Backup did not complete as it seems it cannot access the data to backup, I read a lot of people have had this similar issue.
    10-26-15 12:31 PM
  9. mad_mdx's Avatar
    I think it messes up when your backup file starts being too large. I think a full backup for me would be larger than 5GB if the backup worked.
    Consistently getting Backup did not complete as it seems it cannot access the data to backup, I read a lot of people have had this similar issue.
    I made a 6gb backup yesterday and restored to a new device without a hitch
    10-26-15 12:35 PM
  10. theonecid's Avatar
    I really wonder why my data appears corrupt to Link then.
    10-26-15 12:44 PM
  11. scullcy's Avatar
    For me Blend is working great.
    In my opinion the only and worst issue with Link is the synchronization with Outlook. We have so many customers complaining about that, very very horrible! Everybody who worked the synchronization with the good old Desktop Software knows what I mean - that was awesome...

    10-26-15 12:46 PM
  12. conite's Avatar
    I'm another one of the lucky ones I suppose.

    No issues ever, on Windows 7 through to Windows 10, on any of my devices (Z10, Z30, Passport, Q5). On multiple laptops and desktops.

    PassportSQW100-4/10.3.2.2789
    10-26-15 01:00 PM
  13. BCITMike's Avatar
    You got problems with your pc. Try
    Sfc /scannow

    Also, you can check Windows Event Log for errors, likely will help narrow down the issue (ie, permissions, mdns, etc)

    Posted via CB10
    10-26-15 02:47 PM
  14. tdaye's Avatar
    Yeah don't speak for everyone unless you have personally spoke to everyone. Both my programs work flawlessly.

    Posted via CB10
    10-26-15 02:55 PM
  15. SackHarry's Avatar
    You got problems with your pc. Try
    Sfc /scannow

    Also, you can check Windows Event Log for errors, likely will help narrow down the issue (ie, permissions, mdns, etc)

    Posted via CB10
    did you even read my post? i said i'm using a mac. majority of mac users are experiencing problems. it seems like link/blend works good on windows but is garbage on mac
    elfabio80 likes this.
    10-31-15 01:14 PM
  16. jhimmel's Avatar
    I've never had a problem with Blend. Don't use it that much though. I've had my ups and downs with Link, but mostly it works as it should.
    I'm on Windows.
    Posted via CB10
    10-31-15 01:20 PM
  17. valer466's Avatar
    New blend update on phone has reduced the times blend didnt want to work at all. But still randomly stops working and refuses to connect at startup.

    Drivers anyone?
    11-01-15 04:08 AM
  18. paulwallace1234's Avatar
    You never met Nokia Suite #PunchScreenAwful

    But yeah, it's pretty damn awful (even on Windows); my link won't recognise my device once again :sigh:

    Posted via CB10 v....not telling
    11-01-15 04:28 AM
  19. last_attempt's Avatar
    On link mine worked reasonably well with Windows 7 not so well with 8.1 and not at all on Windows 10, I gave up trying to get it to work a while ago. I guess I should try again as maybe an update fixed something, it's such a chore though!

    Blend seems to have always worked but I don't really use it and only tried for the novelty.

    Posted via CB10
    11-01-15 09:00 AM
  20. roleli's Avatar
    I am not sure who everyone is.

    I have no problem with either so far. Link was even very helpful with restoring a colleague's BB Z10 device.

    I actually love Blackberry blend. Hope they continue to improve it.
    11-01-15 11:08 AM
  21. David Tyler's Avatar
    Link and Blend have always worked well for me. Windows 7 Pro.

    Passport SE: All the snooty prestige of a device with a precious metal in the name at less than half the price!
    11-01-15 10:49 PM
  22. Drenegade's Avatar
    Both have always performed flawlessly for me.

    I think the issue is your Mac/PC or your settings. Stop blaming everybody but yourself.

    Posted via CB10
    11-02-15 01:08 AM
  23. theonecid's Avatar
    Both have always performed flawlessly for me.

    I think the issue is your Mac/PC or your settings. Stop blaming everybody but yourself.

    Posted via CB10
    Just wait til your backup file becomes too big. A lot of users have been getting "Backup did not complete" and cannot access the data they want to backup, so if everything works perfectly for you, it doesn't mean it does for everyone else.
    11-02-15 10:17 AM
  24. illlya's Avatar
    No problem here!

    Passport Silver Edition
    11-02-15 09:07 PM
  25. 6stringriffs's Avatar
    It's a very problematic software. Especially Link. My phone is never recognized. And apps are never updated. I'm just counting the days when I receive my Nexus 6P. This BB10 has been an unmitigated disaster!
    11-02-15 10:02 PM
41 12

Similar Threads

  1. Another One Bites the Dust
    By HonnyBrown in forum PlayBook Apps & Games
    Replies: 11
    Last Post: 11-12-15, 02:03 PM
  2. Is there any possibility of a bb10 version?
    By mania626 in forum BlackBerry Priv
    Replies: 60
    Last Post: 10-27-15, 04:35 PM
  3. Calling and Internet at the same time?
    By Neil9800 in forum BlackBerry Passport
    Replies: 9
    Last Post: 10-26-15, 05:38 PM
  4. Why aren't I receiving incoming caller ID's on my BB Leap?
    By CrackBerry Question in forum BlackBerry Leap
    Replies: 1
    Last Post: 10-26-15, 08:45 AM
LINK TO POST COPIED TO CLIPBOARD