1. broncot's Avatar
    I haven't been able to successfully backup my Q10 for several months, it will start with computing backup, then move to preparing to backup, then after about 30 minutes it will fail, saying to ensure the Blackberry is connected to the computer.
    I've got another device I want to switch to, but don't want to start from scratch.
    My questions:
    Does the switch device process simply backup the old and restore to the new? Or will it somehow work even though the backups fail.
    How can I troubleshoot what's causing the backups to fail?
    Is there an app that will backup BB10 app data?
    01-19-17 08:59 PM
  2. Henry Jr's Avatar
    If you haven't already, I recommend uninstalling Link, rebooting your PC, restart phone at same time, reinstall Link. Then plug in the phone and try again. Don't forget to sign in to Link.

    Good luck

    Q10 (SQN100-3 : 10.3.2.158), Passport (SQW-100 : 10.3.2.2474)
    01-20-17 05:48 PM
  3. semime's Avatar
    I haven't been able to successfully backup my Q10 for several months, it will start with computing backup, then move to preparing to backup, then after about 30 minutes it will fail, saying to ensure the Blackberry is connected to the computer.
    I've got another device I want to switch to, but don't want to start from scratch.
    My questions:
    Does the switch device process simply backup the old and restore to the new? Or will it somehow work even though the backups fail.
    How can I troubleshoot what's causing the backups to fail?
    Is there an app that will backup BB10 app data?
    First, I'd recommend ensuring that your USB cable is good. If possible, obtain another OEM BlackBerry cable to test. Often, if the cable has become bad or generic cables used the device may adequately charge but transmit data poorly. It sounds strange but I've found that to be the case with my own BlackBerry devices.

    This should answer most of your concerns regarding device switch: http://us.blackberry.com/support/Dev...vice:q10switch

    Beyond BlackBerry Link, there are third party apps available in BBW to backup your BB10 device. I've found both BackupPro and Ultimate Backup (yes, I have both) to be comprehensive and excellent for the task.
    01-20-17 06:15 PM
  4. broncot's Avatar
    The main reason for me to backup is to save app data, I have Ultimate Backup, it doesn't backup app data, does BackupPro?
    01-21-17 02:09 PM
  5. semime's Avatar
    The main reason for me to backup is to save app data, I have Ultimate Backup, it doesn't backup app data, does BackupPro?
    No. Aside from a few individual apps that will backup their specific data to the cloud, Link is the only way to manage that.
    01-21-17 03:02 PM
  6. semime's Avatar
    Were you able to try another USB cable?

    http://forums.crackberry.com/showthread.php?t=1097628
    01-21-17 03:07 PM
  7. broncot's Avatar
    I tried another cable and installed Link on a Windows XP computer instead of the Windows 7 computer, it too failed. I backed up every week for over a year without issue before this started. I setup a new device from the last successful backup (12/4/16), then restored from a limited app data backup I got to work a few weeks ago, now this second Q10 won't backup either, although I haven't tried it on the Windows XP computer.
    01-21-17 03:20 PM
  8. semime's Avatar
    I tried another cable and installed Link on a Windows XP computer instead of the Windows 7 computer, it too failed. I backed up every week for over a year without issue before this started. I setup a new device from the last successful backup (12/4/16), then restored from a limited app data backup I got to work a few weeks ago, now this second Q10 won't backup either, although I haven't tried it on the Windows XP computer.
    Ouch.

    So, the new device was connecting before the restore... You restored if from a backup, and the issue has returned? Am I understanding that correctly? If so, it sounds like you're copying the corruption right back to the phone.
    01-21-17 03:39 PM
  9. Bobglen's Avatar
    BlackBerry link doesn't work with windows 10 since a windows update

    Posted via CB10
    01-21-17 05:48 PM
  10. broncot's Avatar
    Yes, that's what's happening. What could be causing the corruption?
    01-21-17 05:57 PM
  11. semime's Avatar
    BlackBerry link doesn't work with windows 10 since a windows update

    Posted via CB10
    I've seen many posts to that effect. It stopped on mine for a time. Guess I got lucky because I just uninstalled it, reinstalled, and all was well again. Going on 3 machines and not a problem.
    01-21-17 07:04 PM
  12. semime's Avatar
    Yes, that's what's happening. What could be causing the corruption?
    I don't know caused the corruption but it sounds as though the most reasonable thing to do may be the factory reset at this point.
    01-21-17 07:12 PM
  13. techhatesme's Avatar
    BlackBerry link doesn't work with windows 10 since a windows update

    Posted via CB10
    For Win10, I found success by running both Link and Blend in compatibility mode. Uninstall Link. Restart. Right click the .exe install file, select trouble shoot compatibility, select second option, set to run in Win7 compatibility mode, install Link, right click newly created Link desktop shortcut, troubleshoot, select Win7, run.

    -- Give me a keyboard, a 5 star rated Browser and a fulcrum point and I could move the world.
    01-21-17 08:14 PM
  14. mvirard's Avatar
    Tried it on two different win 10. To no avail ... same problem: Link says the connexion to my Passport is not working yet it did detect the Passport correctly at connect time. :-(
    05-01-17 08:14 PM
  15. Alloyjane's Avatar
    For a while it wasn't working for me either, so I started using Sachesi. Then out of the blue, backup by Link started working again. I'm on an OG Passport using El Capitan.

    I know this is an obvious thing to ask, but are you disabling mass storage or charge only mode?
    05-02-17 05:04 PM

Similar Threads

  1. BlackBerry Mobile Uber experience
    By curves2000 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 03-10-17, 04:38 PM
  2. BlackBerry NYC stories!
    By d987654321 in forum General BlackBerry Discussion
    Replies: 39
    Last Post: 02-02-17, 08:26 PM
  3. Email that I have put in my FOLDERS, I cannot see them on a BlackBerry
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-21-17, 08:59 AM
  4. I cannot install fresh BB Link. "You've got the latest version" message
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 01-19-17, 07:50 PM
  5. Blackberry Mercury
    By billmicheal in forum BlackBerry KEYone
    Replies: 1
    Last Post: 01-19-17, 04:48 PM
LINK TO POST COPIED TO CLIPBOARD