1. komali's Avatar
    Greetings!
    After spending a good chunk of my first day as a BlackBerry Classic owner trying and failing to install the BlackBerry Blend/Link/driver software package -- which is really a book in itself, and suffice it to say eventually required me to hack the registry to disable rollback in order to hunt down and dredge up the extracted MSI files from an obscure subfolder off the root directory so I could run each one individually, which is not what I'd describe as the most user-friendly experience ever -- I have (at last) managed to install the first two elements of the software package: namely, Link and Blend.

    What I haven't been able to do, however, is install the accompanying drivers, which renders my device inexplicable to both applications when connected by USB cable. (Both apps can see and interact with the phone when connected via Wifi.)

    Even now that both programs are happily ensconced, and the main setup program helpfully points out that both are up to date, and offers to install just the drivers, it crashes out with a generic error code (I googled it, and it was reassuringly non-helpful).

    At this point, I'm almost ready to say, eh, who really needs backups anyway when you sync your contact/etc data with cloud-based email, and the BlackBerry ID system makes it relatively easy to reinstall programs if necessary. As far as I can tell, that -- and, of course, connecting to Blend via USB -- is the only operation that requires those elusive drivers.

    Still, in order to get some sort of closure to the above referenced ordeal, I'm wondering if there's an alternative method to install *just* the USB drivers -- by hand, if necessary -- just in case it ever becomes necessary for my PC to communicate with my phone via USB and not Wifi.

    Possibly useful information for anyone who has read this far and has the slightest desire to help a fellow Blackberry loyalist out:

    I'm running Windows 7 64 bit on an otherwise non-remarkable machine.

    The computer *can* see the phone as a USB drive when I turn on mass storage (and yes, I've been meticulous about turning that feature off when trying to communicate with Link/Blend), so it's not a cable/port issue..

    Somehow, Blackberry Desktop Manager is still hanging around my system -- I think it may have been reinstalled with Link or Blend, although the 2010-2012 copyright date on the about tab suggests that it may be a vintage build (8.0.05). It sort of sees the phone, in the sense that it pops up when I plug it in and claims that the phone is connected, but then gets stuck at the 'Initializing device access' stage, and never actually shows it in the window unless it is in mass storage mode. (Plugging it in also revs up Link, but it doesn't see the actual device as connected unless I switch to Wifi.)

    Finally, Device Manager does indeed show a "Blackberry Device" as connected when I plug the phone in, and even claims to have the latest driver, but I am sceptical, what with it not actually working. Under 'driver details' it lists two files: RimUSB_AMD64.sys (version 4.2.0.32 with a 2014 copyright date) and WdfCoInstaller01007.dll.

    So, anyone have any ideas/suggestions/URLs for stand-alone driver files?

    Note: Please don't tell me to reboot/restart anything unless you've got a really good reason to do so, as I've obviously done all that repeatedly while going through the above steps. Or ask me to test a different USB cable, because I have -- and as noted, it works fine in USB storage mode. Or tell me to reinstall Link/Blend because man, I've finally got those apps working and life is too short to go through that horror show again.

    I just want to update the USB drivers. That's all.

    .
    Last edited by komali; 12-31-14 at 12:20 PM. Reason: Removed inadvertently redundant subclause because it was driving me crazy
    12-31-14 09:41 AM
  2. anon1727506's Avatar
    Sorry you are having so many problems...

    I'm on Windows 8.1.... download the updated Blend package from Blackberry, installed it and it works.

    I do remember having a number of USB issues on a 64 Bit Windows 7 machine back when I got my first BB10 device. Can't remember what I had to change (just did a quick search and couldn't find it) but there was something in the USB setting (maybe stack).
    12-31-14 09:47 AM
  3. Joshu42's Avatar
    The easy way is still to start over.
    • Uninstall Blend and Link properly. Check with CCleaner if needed.
    • Don't plug your phone, disconnect from Internet, stop your firewall/Antivirus and just run the Blend package as an Administrator, which install Blend, Link and Device Manager.
    • After this last reboot, you will be able to plug your phone and start Link to backup if you want.

    That said, on a new computer, if you plug your phone without enabling the USB Mass Storage, Windows start installing BlackBerry Device Manager...

    By the way, I'm using Windows 7 x64
    12-31-14 12:04 PM
  4. komali's Avatar
    Oh, I tried installing the package as an administrator -- both the one downloaded automagically via setup.exe on the device, and a fresh download of BlackBerryDesktopSoftware1_1_b29.exe. Unfortunately, it tries to install the drivers first, and when that fails due to whatever the underlying issue is, the entire process grinds to a halt.

    (Yes, I've tried downloading just the drivers, as well as every possible combination to install/update Link/Blend.)

    Since you're using the same O/S as me, is there any chance you could give me the details of the driver(s) you have installed -- file name/version/date -- as displayed in Device Manager, that is), as well as the name by which DM identifies your phone? Mine grudgingly acknowledges "Blackberry Device", but will have no truck nor trade with "BlackBerry Smartphone".
    12-31-14 12:16 PM
  5. Joshu42's Avatar
    Oh, I tried installing the package as an administrator -- both the one downloaded automagically via setup.exe on the device, and a fresh download of BlackBerryDesktopSoftware1_1_b29.exe. Unfortunately, it tries to install the drivers first, and when that fails due to whatever the underlying issue is, the entire process grinds to a halt.

    Since you're using the same O/S as me, is there any chance you could give me the details of the driver(s) you have installed
    BlackBerry Desktop Manager is for BBOS, not for BB10. Your issue is probably there.
    I'll check the driver when home.
    12-31-14 01:56 PM
  6. komali's Avatar
    Sorry, I should have been more specific -- I meant Windows Device Manager. But yes, any details at all on the specifics of a driver that works would be much appreciated! On the off chance that it might trigger a Eureka moment for someone who has successfully wrangled the USB connection into submission, I've attached a screenshot of what I see in DM. BlackBerry (Classic) Drivers: Stand-alone install package/download available?-bbss.jpg
    12-31-14 02:15 PM
  7. Joshu42's Avatar
    Same drivers :
    BlackBerry (Classic) Drivers: Stand-alone install package/download available?-01.jpg

    But you have issues with your BlackBerry network adapters and COM ports :
    BlackBerry (Classic) Drivers: Stand-alone install package/download available?-02.jpg

    Here the version of each component as seen in BlackBerry Device Manager :
    BlackBerry (Classic) Drivers: Stand-alone install package/download available?-03.jpg
    (I edited to add the last line)
    12-31-14 03:09 PM
  8. komali's Avatar
    I believe you may have nailed it. Unfortunately, I can't seem to find a fix -- quick or otherwise -- that will let me install the network adapter/port drivers. I may just have to give up my dream of being able to connect my phone to my PC via USB cable. (I'm not missing that much, really, I just hate being beaten by a program.)
    12-31-14 03:51 PM
  9. Mr4aces's Avatar
    The easy way is still to start over.
    • Uninstall Blend and Link properly. Check with CCleaner if needed.
    • Don't plug your phone, disconnect from Internet, stop your firewall/Antivirus and just run the Blend package as an Administrator, which install Blend, Link and Device Manager.
    • After this last reboot, you will be able to plug your phone and start Link to backup if you want.

    That said, on a new computer, if you plug your phone without enabling the USB Mass Storage, Windows start installing BlackBerry Device Manager...

    By the way, I'm using Windows 7 x64
    I'm unable to uninstall BB Desk top, took off fire wall Mafee, I get Error to Close Blend, Dont have it open. Using Windows 8
    _______________________________________

    Post this on BB Forum:

    I just downloaded BB Blend when I went to open the exc file it says: Close BB Window.
    Options an hour ago

    First sorry for any typeos lost a finger last month.
    Closed all open BB winow still wont let me upload to my pc.
    Upload Blend last week and Link. Today it would not let me connect to my PC and Device SQC100-4 Classic. So i deleted Blend off my pc and downloaded Blend. Went to down load fold to open. I said To Close Blackberry Blend.
    ----------------------------------------------
    Initial problem try to update BB10.3.1949 couldnt up load on device so up loaded on PC w/Windows 8
    Blend no on pc. Down loaded several times did not work. STOP just found it on my pc. Opened it up to connect still gives same error "Please Up Load Latest Version"



    Down loaded OS 10.3.1.1949 to my pc because cant get to web page. so I have two problems.

    1. Can not connect to my Classic to my PC using Blend;

    2. Need to update OS to Classic;
    01-01-15 12:44 PM
  10. Alain_A's Avatar
    I'm unable to uninstall BB Desk top, took off fire wall Mafee, I get Error to Close Blend, Dont have it open. Using Windows 8
    _______________________________________

    Post this on BB Forum:

    I just downloaded BB Blend when I went to open the exc file it says: Close BB Window.
    Options an hour ago

    First sorry for any typeos lost a finger last month.
    Closed all open BB winow still wont let me upload to my pc.
    Upload Blend last week and Link. Today it would not let me connect to my PC and Device SQC100-4 Classic. So i deleted Blend off my pc and downloaded Blend. Went to down load fold to open. I said To Close Blackberry Blend.
    ----------------------------------------------
    Initial problem try to update BB10.3.1949 couldnt up load on device so up loaded on PC w/Windows 8
    Blend no on pc. Down loaded several times did not work. STOP just found it on my pc. Opened it up to connect still gives same error "Please Up Load Latest Version"



    Down loaded OS 10.3.1.1949
    don't put that on your Classic

    1. Can not connect to my Classic to my PC using Blend;

    2.
    Need to update OS to Classic;
    no you don't

    your post is kind of confusing

    how did you put Blend on the pc?? from website or from phone?
    01-01-15 02:28 PM
  11. Mr4aces's Avatar
    no you don't

    your post is kind of confusing

    how did you put Blend on the pc?? from website or from phone?
    From: BlackBerry's website, my phone has both Blend and Link. Was reading on BBsupport forum said to uninstall Blend and Link then reinstall. Was sucessul uninstalling Link but when I tried to uninstall Blend I got the same error to Close Program. So I could not uninstall Blend. I'm sure Blend is my problem. Just need to uninstall it.
    01-01-15 03:45 PM
  12. Alain_A's Avatar
    From: BlackBerry's website, my phone has both Blend and Link. Was reading on BBsupport forum said to uninstall Blend and Link then reinstall. Was sucessul uninstalling Link but when I tried to uninstall Blend I got the same error to Close Program. So I could not uninstall Blend. I'm sure Blend is my problem. Just need to uninstall it.
    what I did was, deleted everything from the computer then plug for Classic for it to reinstall Link,Blend and the driver..Everything went smooth and everything work
    01-01-15 05:23 PM
  13. Alain_A's Avatar
    From: BlackBerry's website, my phone has both Blend and Link. Was reading on BBsupport forum said to uninstall Blend and Link then reinstall. Was sucessul uninstalling Link but when I tried to uninstall Blend I got the same error to Close Program. So I could not uninstall Blend. I'm sure Blend is my problem. Just need to uninstall it.
    ok, On that you just had to go to the pan at the right bottom corner of your window where the arrow is, click on it then find blend there, right click or something to exit the program
    01-01-15 05:26 PM
  14. Alain_A's Avatar
    because blend is always running (driver)
    that is where you close the program
    BlackBerry (Classic) Drivers: Stand-alone install package/download available?-img_20150101_152845.jpg

    From Classic
    01-01-15 05:29 PM
  15. tdyhedge's Avatar
    @OP, I know this isn't going to help much but some time ago on my Windows 7 Ultimate 64-bit machine I had a similar issue. I tried everything mentioned in this thread as well. I removed/reinstalled various drivers, messed with my anti-virus and firewall, found msi files and repaired them, used CC Cleaner, etc, etc, etc. Eventually I got fed up enough, backed everything up and went ahead and did a fresh install of windows. Long story short, it all works wonderfully now. So there's hope.

    Via my simply amazing  Q10 10.3.1.1949
    01-01-15 05:41 PM
  16. Alain_A's Avatar
    @OP, I know this isn't going to help much but some time ago on my Windows 7 Ultimate 64-bit machine I had a similar issue. I tried everything mentioned in this thread as well. I removed/reinstalled various drivers, messed with my anti-virus and firewall, found msi files and repaired them, used CC Cleaner, etc, etc, etc. Eventually I got fed up enough, backed everything up and went ahead and did a fresh install of windows. Long story short, it all works wonderfully now. So there's hope.

    Via my simply amazing  Q10 10.3.1.1949
    right...very long process
    01-01-15 05:52 PM
  17. Mr4aces's Avatar
    @OP, I know this isn't going to help much but some time ago on my Windows 7 Ultimate 64-bit machine I had a similar issue. I tried everything mentioned in this thread as well. I removed/reinstalled various drivers, messed with my anti-virus and firewall, found msi files and repaired them, used CC Cleaner, etc, etc, etc. Eventually I got fed up enough, backed everything up and went ahead and did a fresh install of windows. Long story short, it all works wonderfully now. So there's hope.

    Via my simply amazing  Q10 10.3.1.1949
    because blend is always running (driver)
    that is where you close the program
    Click image for larger version. 

Name:	IMG_20150101_152845.jpg 
Views:	100 
Size:	33.8 KB 
ID:	324697

    From Classic
    Alain doesn't show up, I'm think of doing a restore back 2 mos. What files do I need to save on CD to do this? download folder with vnbb10 and snap?
    01-02-15 03:58 PM
  18. Alain_A's Avatar
    Alain doesn't show up, I'm think of doing a restore back 2 mos. What files do I need to save on CD to do this? download folder with vnbb10 and snap?
    when you were trying to delete it the first time that is when you had to do to close blend...So if blend is still on your computer open it up and it will show in that tray. After you go to uninstall through the control panel. it might be possible that link has to be in the computer before deleting everything again

    Dean I sent you an invite to BBM
    Mr4aces likes this.
    01-02-15 05:59 PM
  19. Mr4aces's Avatar
    when you were trying to delete it the first time that is when you had to do to close blend...So if blend is still on your computer open it up and it will show in that tray. After you go to uninstall through the control panel. it might be possible that link has to be in the computer before deleting everything again

    Dean I sent you an invite to BBM
    I think your right. I "think" I might have fixed it by cleaning off the desk top. I'll let you know tomorrow.

    I will look for your channel

    Again thank you

    Posted via CB10
    01-03-15 12:20 AM
  20. Alain_A's Avatar
    I think your right. I "think" I might have fixed it by cleaning off the desk top. I'll let you know tomorrow.

    I will look for your channel

    Again thank you

    Posted via CB10
    it not a channel it is my BB pin...I was think to go BBM with you to help removing BB 10 from that pc of yours. and re-install it
    Last edited by Alain_A; 01-03-15 at 12:38 AM.
    01-03-15 12:24 AM

Similar Threads

  1. Replies: 55
    Last Post: 01-21-15, 10:19 PM
  2. Replies: 5
    Last Post: 12-31-14, 03:44 PM
  3. Cocoppa for Blackberry 10 devices?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 12-31-14, 12:03 PM
  4. Crippling hack forced Sony to use old BlackBerrys
    By domcos in forum News & Rumors
    Replies: 3
    Last Post: 12-31-14, 09:57 AM
  5. How do I get my Blackberry off of the boot screen?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-31-14, 07:35 AM
LINK TO POST COPIED TO CLIPBOARD