10-17-17 02:10 AM
80 ... 234
tools
  1. Polaris2222's Avatar
    This was driving me insane with my Passport until I noticed it was all with shared links. I tried "open in a new tab" and every one of the blocked sites worked.
    How exactly did you perform this? I tried opening a new tab and logging into Outlook but got the same message. I tried opening a new tab after this with the first tab open but got the same message. I tried opening in private browser while I had the site blocked message up and got the same result. No option was there, with the site blocked message up, to open in another tab - just open in Private Browser. What exactly are steps you are using? Thanks for your help?

    Posted via CB10
    05-29-17 02:54 PM
  2. HanzWurst's Avatar
    To all the folks who still have this issue.

    The answers are all in this thread. You have to import the certificats. Do this by placing an empty .txt file on your SD. Make (rename) it to a .pem file. Paste the certificate as a text (everything including ----begin certificat .... end certificate----) into the .pem file.
    Import the certificat. Go to settings -> security -> certificats and simply import. You can also navigate to the .pem file with the native file explorer and tap on the file

    Now comes the part with the clue. You also have to import the corresponding "root certificate".
    For example I had the issue with Let's Encrypt certificats too. Import the Let's Encrypt certificat. Then google for "Let's Encrypt root certificate" and also import this. In this example the corresponding root certificate is called "DST Root CA X3". Just google. (Don't know exactly, but on the device the sub certificats get checked, so there has to be somehow this root certificat to fullfill needs of the certificate chain.)

    I did all this on my Q10 without PC. Natively you can't create an new file and change the fiel ending on BB10. I did a workaround with the android app "ES file explorer". Maybe you can also do it with ghost comander, but I never got used to that.
    With a PC at hand you should alternatively manage to get this done.

    This way my old BB10 Browser keeps going now. Hopefully for some more time (Love my tiny Q10)


    P.S. I can recommend Browsie Browser, native BB10 app.
    10-03-17 05:27 AM
  3. Anatoly Weinstein's Avatar
    Google was blocked. Same was YouTube.
    10-15-17 09:13 AM
  4. iSaeed makhtoomi's Avatar
    not work!!!! :|

    Posted via CB10
    10-17-17 02:09 AM
  5. iSaeed makhtoomi's Avatar
    Downloaded Amazon Root CA 1, Starfield G2 from

    https://www.amazontrust.com/repository/

    Downloaded Let's Encrypt root and intermediate "active" certificates from

    https://letsencrypt.org/certificates/

    Importing in Settings - Security - Certificates requires a *.pem filename extension. This can be corrected in File Manager after a long tap on the file, choosing Properties, Rename (not editing the name in Properties).

    A site using Let's Encrypt still did not open, so I figured I needed an extra "DST Root CA X3" linked to from the above page. Copying and pasting the PEM text, then attempting to import resulted in an infinite wait. I found a copy of the same "DST Root CA X3" in a random Github file, and saving it with "Save Page" and importing worked. I guess the original pem text missed the "begin certificate"/"end certificate" lines.

    https://raw.githubusercontent.com/ki...%20CA%20X3.pem
    your way is not work!!! :|

    Posted via CB10
    10-17-17 02:10 AM
80 ... 234

Similar Threads

  1. (Leaked)BlackBerry next two smartphones
    By Tony Morfin in forum BlackBerry KEYone
    Replies: 10
    Last Post: 05-01-16, 01:27 AM
  2. What happened to the Skype App on BlackBerry World?
    By CrackBerry Question in forum Ask a Question
    Replies: 6
    Last Post: 04-30-16, 09:29 PM
  3. BlackBerry Passport Android System completely crashed, any fixes for this?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 6
    Last Post: 04-28-16, 04:41 PM
  4. An honest BlackBerry Priv review
    By FishhPoohh in forum BlackBerry Priv
    Replies: 6
    Last Post: 04-28-16, 10:25 AM
  5. How to install Google maps in BlackBerry q10
    By Saransh Walia in forum Ask a Question
    Replies: 3
    Last Post: 04-28-16, 06:55 AM
LINK TO POST COPIED TO CLIPBOARD