02-19-17 03:21 PM
33 12
tools
  1. spacemanZ10's Avatar
    In the last day or two the browser keeps freezing on certain websites? (nothing nsw!) might be the website, but happens on a few not on others?
    Anyone any issues?
    Still on 10.3.2.2286 been on it ages so don't think it's the OS?

    Swiped on my Passport!
    02-18-17 04:59 AM
  2. HaberNik's Avatar
    I find the browser has been choking a lot over the past six months and sadly, even with the OS updates, it is not getting better.

    Posted via CB10
    02-18-17 06:26 AM
  3. anon(6125289)'s Avatar
    Yeah several websites don't work anymore on my passport. It's gotten worse over the past few months.

    Posted via CB10
    02-18-17 06:30 AM
  4. sidtek50's Avatar
    Same here. Thought it was just me. To be honest, as much as I love the keyboard on it, things like this make me want to jump ship. It's not as if I can install firefox or chrome and have them running smoothly (I've tried).

    I've been having to close the entire browser when it happens. Hate to say it but I highly doubt it'll ever be fixed.

    Posted via CB10
    02-18-17 07:07 AM
  5. Farzeen25's Avatar
    In the last day or two the browser keeps freezing on certain websites? (nothing nsw!) might be the website, but happens on a few not on others?
    Anyone any issues?
    Still on 10.3.2.2286 been on it ages so don't think it's the OS?

    Swiped on my Passport!
    Could you list out the Websites that you are having issues with? I am on 10.3.3.2205, the latest build, Maybe I can confirm.

    Posted via CB10
    02-18-17 07:55 AM
  6. Emaderton3's Avatar
    I find the browser has been choking a lot over the past six months and sadly, even with the OS updates, it is not getting better.

    Posted via CB10
    Met too, particularly websites with a lot of embedded media or menus like CNN and ESPN.

    Posted via CB10
    02-18-17 07:58 AM
  7. The_Passporter's Avatar
    Get Browsie Browser then go into settings and make the search engine firefox and you will be golden again.

    http://appworld.blackberry.com/webst...ntent/59952700


    Posted via CB10
    anon(9742832) likes this.
    02-18-17 11:29 AM
  8. crackbb10's Avatar
    Ever restart the phone? Clearing cache and cookies from time to time?

    Posted via CB10
    02-18-17 11:34 AM
  9. Emaderton3's Avatar
    Ever restart the phone? Clearing cache and cookies from time to time?

    Posted via CB10
    Never helps. Only time I got it to work was OS reinstall, but it quickly degraded again.

    Posted via CB10
    02-18-17 12:01 PM
  10. crackbb10's Avatar
    What websites does this occur with? Or just any website?

    Posted via CB10
    02-18-17 12:05 PM
  11. Emaderton3's Avatar
    What websites does this occur with? Or just any website?

    Posted via CB10
    Like I said above, CNN and ESPN. They constantly freeze for me.

    Posted via CB10
    02-18-17 12:08 PM
  12. crackbb10's Avatar
    Weird stuff, they seem to be working fine on my Classic. I'm still on 10.3.2 as well. I'll check the Passport later. Have you considered updating to 10.3.3? It might solve the problem.

    Posted via CB10
    02-18-17 12:17 PM
  13. medic22003's Avatar
    This is why I stopped using my z30 a year ago. Sad but true. Not many apps, browser had to work.
    02-18-17 12:33 PM
  14. meattray's Avatar
    Espn is a hog of a site that really seems to destroy the browser. That being said browsie browser as mentioned above can help a bit but not enough for those sites in my opinion.
    02-18-17 01:46 PM
  15. sidtek50's Avatar
    I am against buying a browser. It seems crazy. I understand browsie is supposed to be good but the stock browser should be good enough to use without having to resort to spending money, albeit a small amount on getting basic things to work.

    Posted via CB10
    02-18-17 01:59 PM
  16. Emaderton3's Avatar
    Weird stuff, they seem to be working fine on my Classic. I'm still on 10.3.2 as well. I'll check the Passport later. Have you considered updating to 10.3.3? It might solve the problem.

    Posted via CB10
    Same problem with update.

    Posted via CB10
    02-18-17 02:00 PM
  17. Emaderton3's Avatar
    I am against buying a browser. It seems crazy. I understand browsie is supposed to be good but the stock browser should be good enough to use without having to resort to spending money, albeit a small amount on getting basic things to work.

    Posted via CB10
    I have the same mindset lol.

    Posted via CB10
    02-18-17 02:01 PM
  18. oldmangeddyboy's Avatar
    Happens all the time on my classic it takes an age for any images or text to load up,even small sites such as local news or sports channels just become to much hassle to wait through.

    Posted via CB10
    02-18-17 02:01 PM
  19. ATI nsider's Avatar
    Browser freeze up isn't associated with the BB10 Browser. This also happens sometimes with my Galaxy 6 and Tab.
    The issue is the actual select websites.

    Posted via CB10
    02-18-17 03:28 PM
  20. bob03sue's Avatar
    Sadly I cannot get into my own website henrithomae.com.au

    Posted via CB10
    02-18-17 03:38 PM
  21. bob03sue's Avatar
    Sorry www.henrithomae.com.au

    Posted via CB10
    02-18-17 03:38 PM
  22. bob03sue's Avatar
    I can get in to my site on 10.3.3 which I have on my second Z10

    Posted via CB10
    02-18-17 03:50 PM
  23. Emaderton3's Avatar
    I can get in to my site on 10.3.3 which I have on my second Z10

    Posted via CB10
    I have gotten on your website too celebrant.

    Those problem webpages have a ton of embedded graphics, videos, and menus. My Q10 has never liked them. My wife's Galaxy 4 does just fine.

    Posted via CB10
    02-18-17 04:11 PM
  24. bob03sue's Avatar
    Yes it works beautifully on galaxy and iPhone etc just not bb10

    Posted via CB10
    02-18-17 04:31 PM
  25. HaberNik's Avatar
    Since the first 10.3.3 update and the one that just came out again last week or so, the browser seemed to just freeze randomly requiring a slide up and close to do anything. The tabs would all just "grey" out when trying to slide right to close a tab only and so the whole thing had to be closed. I have not had as much of this since my most recent update, but it is still slow on many sites. Not horribly slow. I also have resizing issues on some sites (where the site will not resize to my screen ratio) but I'm not sure if this is my browser or their coding (likely both I suppose).

    Posted via CB10
    02-18-17 04:33 PM
33 12

Similar Threads

  1. Would I lose my files after upgrading from 10.3.2 to 10.3.3???
    By Terry Mhlanga in forum Ask a Question
    Replies: 13
    Last Post: 02-24-17, 06:25 AM
  2. Where can I buy the BlackBerry Mercury online?
    By Ucup Ulo in forum BlackBerry KEYone
    Replies: 37
    Last Post: 02-20-17, 07:33 PM
  3. Whatsapp BlackBerry 10 OS default wallpaper
    By hilmishahir96 in forum BlackBerry Passport
    Replies: 3
    Last Post: 02-18-17, 02:56 PM
  4. Blackberry Q 10 My Os version is 10.3.2.2876
    By Subro Ashu in forum BlackBerry Q10
    Replies: 3
    Last Post: 02-18-17, 04:13 AM
  5. Unable to register BB Google Id after updating to 10.3.3
    By Farzeen25 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 02-18-17, 02:52 AM
LINK TO POST COPIED TO CLIPBOARD