02-12-16 08:08 AM
33 12
tools
  1. SleepyMSP's Avatar
    Hey all,

    I recently updated my Z10 (STL100-3) to 10.3.1.1154 via Sarchesi for the purpose of getting access to the new features of BB10.3.1 specifically the Bluetooth LE support in the new android 4.3 runtime to be able to connect my Fitbit Charge HR to the Z10.

    Thusfar everything on the phone works 100% with one exception, the bluetooth radio seems to get stuck in this weird loop with the tracker constantly asking for an "Authorization Request" every 20 or so seconds with the message "Do you Trust the Charge HR that is trying to communicate to you?". I can see in the bluetooth settings that the phone will connect to the tracker for a few seconds and then disconnect and back and forth.

    I've tried wiping the device back to factory and re-installing the apps, resetting tracker, forgetting the BT device, etc... and with the lack of threads on CB about this issue (at least that I could find) with BT LE I was hoping someone else could chime in.
    01-28-15 10:33 AM
  2. xxxmerlinxxx's Avatar
    how are you pairing the Charge HR to your phone? Fitbit devices should only be paired through the Fitbit app not through the normal way of pairing through the Bluetooth of the phone. I use the version from Snap and have had zero issues. Also, i would blitz your phone to 10.3.1.2072. I find the bluetooth syncing works best.
    jwarman likes this.
    01-28-15 10:45 AM
  3. walt63's Avatar
    Hi and welcome to CB.

    Did you setup your Fitbit through the app or just try connecting it to the device via Bluetooth?
    01-28-15 10:47 AM
  4. walt63's Avatar
    Ahhh....you beat me too it.

    Fitbit devices should only be paired through the Fitbit app not through the normal way of pairing through the Bluetooth of the phone.
    ^ is correct.
    jwarman likes this.
    01-28-15 10:48 AM
  5. xxxmerlinxxx's Avatar
    Fitbit should really put this on the first page of their app when you start it for the first time.
    01-28-15 11:01 AM
  6. walt63's Avatar
    Fitbit should really put this on the first page of their app when you start it for the first time.
    Why? Many people on Android or iOS understands this. It's not really rocket science. Most wearables work the same way...it has to be connected and set up through the actual app. The app has to be able to communicate with the device too.
    01-28-15 11:12 AM
  7. xxxmerlinxxx's Avatar
    because for some it is rocket science
    walt63 likes this.
    01-28-15 11:38 AM
  8. SleepyMSP's Avatar
    how are you pairing the Charge HR to your phone? Fitbit devices should only be paired through the Fitbit app not through the normal way of pairing through the Bluetooth of the phone. I use the version from Snap and have had zero issues. Also, i would blitz your phone to 10.3.1.2072. I find the bluetooth syncing works best.
    After wiping the phone and re-installing the app (no backup restore data) I entered the application and turned on bluetooth on the phone and in the app. It asked me for authorization and then nothing, just says can't find tracker and goes back to the loop of asking for Authorization again.

    At first I thought the problem was the tracker and after borrowing my friends S4 it connected on the first try.

    I could try blitz'ing to 10.3.1.2072 but I read that there is a flicker bug going on with it on some devices so was a little worried about being in a worse situation than I am now.
    01-28-15 11:40 AM
  9. SleepyMSP's Avatar
    also for further information I've tried this on both the production release version of the Fitbit app and the Fitbit Beta app after reading some threads about syncing the tracker to your BB10 device.
    01-28-15 11:43 AM
  10. walt63's Avatar
    also for further information I've tried this on both the production release version of the Fitbit app and the Fitbit Beta app after reading some threads about syncing the tracker to your BB10 device.
    Did you try both the Amazon and Google Play versions?

    After wiping the phone and re-installing the app (no backup restore data) I entered the application and turned on bluetooth on the phone and in the app. It asked me for authorization and then nothing, just says can't find tracker and goes back to the loop of asking for Authorization again.
    Remove the device from your BT pairings. Then re-install the app and don't try to do anything immediate...go directly to Setup New Device and start from their.
    01-28-15 11:50 AM
  11. SleepyMSP's Avatar
    Did you try both the Amazon and Google Play versions?



    Remove the device from your BT pairings. Then re-install the app and don't try to do anything immediate...go directly to Setup New Device and start from their.

    I've tried both google play and amazon version in the past but not after the wipe.

    I'll try both suggestions and report back.

    thanks for the quick reply's all!
    01-28-15 11:53 AM
  12. Easy-G's Avatar
    I'd love to know if you get this working seamlessly. My girlfriend wants a FitBit Charge HR and has a Z10 running 10.3.1.2072.

    Posted via CB10
    01-28-15 11:53 AM
  13. SleepyMSP's Avatar
    Did you try both the Amazon and Google Play versions?



    Remove the device from your BT pairings. Then re-install the app and don't try to do anything immediate...go directly to Setup New Device and start from their.
    Just tried both suggestions and unfortunately it gets stuck when it's says connecting just after the authorization request. Seems like it times out trying to communicate with the tracker.

    I do notice now that the tracker has not been registered with my by devices under setting though
    01-28-15 12:21 PM
  14. xxxmerlinxxx's Avatar
    I have a question regarding the "authorization" part you wrote about. The way it should go in the fitbit app is, you log in you with your fitbit account. It brings you to your dashboard. Your phone's bluetooth should be on, this is the only thing on the phone side that you need to worry about, everything else is done through the Fitbit app. In the app, click on where it says dashboard, select devices and then add a device. Choose your device and go through the setup. If the Fitbit app has trouble finding your tracker, you may want to get to a computer and see if there are any updates available for your device. I know my surge and my wife's charge HR both had updates out of the box. From what I remember I had to update her Charge HR before it wanted to sync with her z10. So maybe thats the step missing. Plug in the USB bluetooth dongle, install the sync software from fitbit http://forums.crackberry.com/e?link=...token=sV1UZDAq , and get it to sync there. You will probably get a notification about a device update. Let it update and then try to sync with your phone.
    01-28-15 12:30 PM
  15. xxxmerlinxxx's Avatar
    @easy-g
    I have both a surge and charge HR syncing with a z30 (surge) and z10 (Charge HR) with no problems. Both are running 10.3.1.2072. So it can be done. I have done nothing special to get these to work.
    Easy-G likes this.
    01-28-15 12:32 PM
  16. SleepyMSP's Avatar
    I have has the charge HR for a few weeks but have been syncing via the USB dongle and a computer pre-10.3.1.

    The reason it asks for authorization at the beginning is because the tracker is already assigned to the account and immediately tried to sync to the tracker.

    walt63:
    I've tried both suggestions but unfortunately no progress. When I try to replace my device through the process "Setup a new device" on the app it seems to find the tracker and say "Connecting..." at the bottom at this point there is the Authorization request again but once I tap yes to authorize the device it will wait for a while and eventually fail.

    It appears that there is a connection timeout taking place causing the problem. When I look in the device settings of Z10 after the attempt I can see that my tracker is not paired though.

    I've tried this process with both the amazon and snap versions (Fitbit V2.2)

    P.S. sorry if a bunch of duplicate answers shows up later. because its a new account sometimes it says it needs to wait for mod authorization to post the reply or quoted reply....dunno
    Last edited by SleepyMSP; 01-28-15 at 12:50 PM.
    01-28-15 12:36 PM
  17. walt63's Avatar
    You're stumping me.
    01-28-15 12:54 PM
  18. SleepyMSP's Avatar
    is it possible its a bad Sachesi install? and moving to 2072 might correct it?
    01-28-15 12:57 PM
  19. IGeeve's Avatar
    The new leak that just came fixes the issue with Fitbit. I had the same problem with that leak as well. So upgrade using blitz and your Fitbit will work amazing.

    Red Passport SQW100-1/10.3.1.1154 /Rogers
    01-28-15 12:59 PM
  20. SleepyMSP's Avatar
    The new leak that just came fixes the issue with Fitbit. I had the same problem with that leak as well. So upgrade using blitz and your Fitbit will work amazing.

    Red Passport SQW100-1/10.3.1.1154 /Rogers

    going to try this now. I really hope this fixes the problem
    01-28-15 02:00 PM
  21. IGeeve's Avatar
    going to try this now. I really hope this fixes the problem
    It will....

    Red Passport SQW100-1/10.3.1.2072 /Rogers
    SleepyMSP likes this.
    01-28-15 02:08 PM
  22. clowrym's Avatar
    I also have a charge HR & Z30 with no issues, My wife's Z10 however worked great with the first one....But when I replaced it with a different size (First fitbit was too small) the second one wouldn't pair....I could always get it to work the first time, but after that it would rarely connect. I ended up going with [MOD][4.3+][2.2] Fitbit Mobile Sync Bluetoot… | Android Development and Hacking | XDA Forums which has solved the issue.
    apk files: https://mega.co.nz/#F!5lNngaaQ!3j2RC3W1PmjUPGYzSV1XxA
    01-28-15 03:17 PM
  23. SleepyMSP's Avatar
    It will....

    Red Passport SQW100-1/10.3.1.2072 /Rogers
    you are the mother eff'n MAN!

    blitzed the Z10 to to latest leak and on the first shot...bang working like it should.

    thanks for the help!

    side question. does anyone know if the call notifications feature works with our devices?
    Easy-G likes this.
    01-28-15 03:33 PM
  24. IGeeve's Avatar
    you are the mother eff'n MAN!

    blitzed the Z10 to to latest leak and on the first shot...bang working like it should.

    thanks for the help!

    side question. does anyone know if the call notifications feature works with our devices?
    To be honest never tried that. I'm assuming it should work. Let us know if it works.

    Red Passport SQW100-1/10.3.1.2072 /Rogers
    01-28-15 07:36 PM
  25. greatwiseone's Avatar
    Using fitbit flex with the Passport and it works great. Really happy with the performance.
    01-28-15 11:53 PM
33 12

Similar Threads

  1. Emails on BB10 q5 aren't updating
    By ja9frncsc in forum Ask a Question
    Replies: 4
    Last Post: 02-07-15, 06:49 PM
  2. BB10: convergence in your hand
    By berry4life99 in forum BlackBerry 10 OS
    Replies: 33
    Last Post: 02-05-15, 01:05 AM
  3. Replies: 1
    Last Post: 01-28-15, 09:40 AM
  4. My bb10 speaker stopped working suddenly
    By sam91777 in forum Ask a Question
    Replies: 2
    Last Post: 01-28-15, 09:14 AM
  5. Countrywise BB10 smartphone sales
    By Grafic111 in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 01-27-15, 01:25 AM
LINK TO POST COPIED TO CLIPBOARD