1. hbada's Avatar
    Hey Fellow BB Enthusiasts

    Wondering if anyone would have an answer to this new issue? I have been swapping out video files by means of mass storage access on my phone and connecting to my Mac Air. Just last night, my phone ran the software update 10.3.2.2474. When I tried to access mass storage OR even get onto BB Link, i am having no luck what so ever.

    I get the pop up on my passport saying "Device is connected to computer". Yet it does not show on BB Link at all.

    When i turn Mass Storage on, I get the typical pop up about what it is then i click continue. Yet, the phone does not appear on my Mac Air Finder left nav window.

    I have been getting "USB Connected" pop up about the options. "No drivers were detected on the computer" to a) Install driver, b) Access SD Card, c) Use charge only and d) Ignore.
    I have tried tried A and B with no luck.

    I have done numerous reboots to the phone and computer. Not sure what has changed with the latest release and why it has affected by ability to access Mass Storage which I really need to add videos. I would use BB Link but my phone will also not be recognized by BB Link anymore.

    Any suggestions?

    Thanks :-)
    10-13-15 11:56 PM
  2. Bla1ze's Avatar
    Yet, the phone does not appear on my Mac Air Finder left nav window..
    Are you on El Capitan?
    10-14-15 01:23 AM
  3. hbada's Avatar
    Hey Bla1ze!
    I did not upgrade to El Capitan yet! Not sure why this is happening. I will continue to trouble shoot.

    Thanks for the response
    10-14-15 07:04 AM
  4. JREwing's Avatar
    I upgraded my Mac, and Link doesn't work at all with my SE Passport. BB needs to fix the bug soon. I need Link to drag and drop my photos into Google Photos, and I can't do it without Link.
    10-16-15 08:34 AM
  5. ankitchahal's Avatar
    Capta(i)n sank my link to my passport...

    Posted via my awesome Passport
    10-17-15 06:07 AM
  6. David Ibarra2's Avatar
    I found postings showing people having issues since Sept 1st and not able to use LINK. I wonder why? BB is not issuing a patch???
    10-17-15 07:40 PM
  7. hbada's Avatar
    I have also found many postings with people having the same issue. Unfortunately, those affected have not found a way to resolve their issue.

    Please update if anyone has had success trouble shooting.

    Trouble Shooting Attempts I made
    1) Removed Blackberry Link and re-installed. Did this twice. NO SUCCESS
    2) Used brand new BB USB cable (computer to phone). NO SUCCESS
    3) Used Windows lap top instead of my Mac. NO SUCCESS
    4) Numerous restart of BB Passport. NO SUCCESS
    5) Tried to access data via wireless and not USB. NO SUCCESS

    Still Outstanding
    1) Revert to older version by means of Auto loader. I have not gone this route since I have no way of saving my data. Can't access Link to save data nor can I access Mass Storage. So pointless to revert OR even wipe my phone at this point. I will hang on for a bit hoping a patch is released or a new version is released resolving this issue.
    10-20-15 08:40 PM
  8. Joshu42's Avatar
    The first step after the update is to install the last version of Link, found here : http://www.blackberry.com/blend (the package includes Blend, Link and drivers). If you are on windows and have still issue, use Ccleaner to remove all the BlackBerry tools before installing the new version. And of course, sign in Link with the same BlackBerry ID as the phone.

    Now, to be sure the phone is not the issue, check its configuration :
    - In Settings > Storage and Access, switch off Access Using Wi-Fi.
    - In Settings > Storage and Access > Access using USB, switch off both Charge Only Mode and Manual IP Address.
    - Start BlackBerry Blend on the phone and switch it off.

    If you still have issue, it's time to detail on what computer OS you are. As the mount of both the internal and SD card with Link is done through a network driver, you're sure to have issue with your firewall...

    P.S: If you want to backup before doing a reload, remember that the Access Using Wi-Fi is still an option.
    10-20-15 09:19 PM
  9. hbada's Avatar
    Thanks Joshu42,

    I tried most of the above. I removed Link but not w/ Blend. I will remove both and re-install and see what happens.

    Thanks
    10-21-15 10:08 PM
  10. MasterJediDan's Avatar
    I have noticed that BlackBerry Link doesn't work anymore either with my Mac running El Capitan. Same connection issues with my Passport that others are having. Blend works fine though. I'll try what others have suggested. Thanks.

    Posted via CB10
    10-24-15 08:32 AM
  11. joeyjay's Avatar
    I also have the same issue since upgrading my MacBook to El Capitan. Can someone let me know if these steps work? My passport connects. I get a yellow caution sign. The only option is to restore my device, which I have not done. However, link works fine on my Windows 7 PC. Seems like Apple is not playing nice with BlackBerry!

    Posted via CB10
    10-24-15 09:41 AM
  12. MasterJediDan's Avatar
    Blend works fine with my Passport SE on my El Capitan iMac. But Link is not working. I uninstalled the BlackBerry software and reinstalled it. Blend works but not link. There is that yellow circle with the message that the computer is not communicating with the Passport. This is all when connecting via USB. Blend does not work when the phone is connected via USB. Blend only works over wi-fi. Do we need to bring this to the attention of BlackBerry? Link and Blend worked great before El Capitan.

    Posted via CB10
    10-24-15 05:12 PM
  13. Joshu42's Avatar
    Link and Blend worked great before El Capitan.
    Did you try to disable the default firewall of El Capitan in System Preferences > Security & Privacy ?

    Update: No answer yet, so I will assume you're still searching for a solution...
    So, open a terminal and type :
    /Applications/Server.app/Contents/ServerRoot/usr/libexec/afctl -d
    That will disable the existing rules in the firewall. Try Link again... (You can enable it again by replacing the -d by -e by the way.)

    If it works, it's time to hunt down what IP has been blacklisted and solve your issue once and for all... Well, I'll wait for your answer first
    Last edited by Joshu42; 10-25-15 at 03:20 PM.
    joeyjay likes this.
    10-24-15 08:54 PM
  14. PeterC4's Avatar
    10-25-15 03:23 PM
  15. joeyjay's Avatar
    Thanks for the trouble shooting. I will try this hopefully this evening!

    Posted via CB10
    10-25-15 05:22 PM
  16. hbada's Avatar
    I am still on OS X Mavericks! I will try the suggestion above.

    There are many similar posts on the BB Support forum as well around this issue:
    All Topics - BlackBerry Support Community Forums

    Thanks
    10-26-15 09:53 PM

Similar Threads

  1. Email with attachments not sending
    By jason18 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 09-05-17, 03:45 PM
  2. Passport GPS map issues...
    By BDinthecrowd in forum BlackBerry Passport
    Replies: 13
    Last Post: 11-08-15, 03:26 PM
  3. Replies: 14
    Last Post: 10-21-15, 11:02 AM
  4. Blackberry Passport
    By Denveryj in forum Ask a Question
    Replies: 2
    Last Post: 10-15-15, 07:35 PM
  5. Passport SE just got
    By Thalakar in forum BlackBerry Passport
    Replies: 3
    Last Post: 10-13-15, 11:10 PM
LINK TO POST COPIED TO CLIPBOARD