1. MrGlenn's Avatar
    In the advanced email settings for BB10, there appeared a toggle called "append messages to sent folder" in recent OS versions.
    I have this set to "off", but I can see my sent items just fine when sync'ing. Is this setting supposed to do something special, something I am missing?
    12-23-13 09:39 AM
  2. J Morehouse's Avatar
    I must be looking in the wrong place because I cannot find this setting. Where are you looking and which OS version are you using? Who is hosting your email service?

    Posted with my BlackBerry Z10!
    12-23-13 10:44 AM
  3. MrGlenn's Avatar
    I think it has been there for me since 10.2, it shows for me when setting up an IMAP account..."Append messages to sent folder", what does it do?-img_20131223_175912.png

    BlackBerry 10 signed.
    12-23-13 11:00 AM
  4. J Morehouse's Avatar
    Interesting. I'm on 10.2.0 with Bell, and have an IMAP account with Gmail, but I don't see the last two options. I don't know what to tell you, or how to help. I've been thinking of setting up an Outlook.com address, so if I see the option after that I'll experiment and let you know the results.

    Posted with my BlackBerry Z10!
    12-23-13 11:20 AM
  5. MrGlenn's Avatar
    It could very well be 10.2.1 only, I am not sure anymore. I am just not willing to try it on my regular accounts in case it messes with something serverside.
    12-23-13 11:49 AM
  6. J Morehouse's Avatar
    I still don't see that option. It must be something particular to your account.

    Posted with my BlackBerry Z10!
    12-25-13 07:28 PM
  7. guygardner73's Avatar
    It could very well be 10.2.1 only, I am not sure anymore. I am just not willing to try it on my regular accounts in case it messes with something serverside.
    I've got it set to on and I haven't noticed anything different.

    Z10STL100-2/10.2.1.1925 O2 UK
    12-26-13 07:52 AM
  8. MrGlenn's Avatar
    Maybe it is for webmail clients that do not support 'sent' labels by default on or something.
    On my Google accounts it does nothing either.

    BlackBerry 10 signed.
    12-26-13 10:53 AM
  9. cevag's Avatar
    Ok I got fed up with my emails showing up as already read, so I looked into this a little further. I have my email sync with my outlook account saves me lots of problem and I always have access to my email regardless of what's going on, or wherever I might be and I can search previous years because I don't delete anything work related.

    With Append being ON (which is the phone setting) when outlook syncs or download the message from my server, my account gets automatically marks as READ, that is a huge problem, I miss quite a few emails because of this setting. I turned Append messages OFF and now it leaves my email unread on the phone.
    01-02-14 07:41 PM
  10. guygardner73's Avatar
    Ok I got fed up with my emails showing up as already read, so I looked into this a little further. I have my email sync with my outlook account saves me lots of problem and I always have access to my email regardless of what's going on, or wherever I might be and I can search previous years because I don't delete anything work related.

    With Append being ON (which is the phone setting) when outlook syncs or download the message from my server, my account gets automatically marks as READ, that is a huge problem, I miss quite a few emails because of this setting. I turned Append messages OFF and now it leaves my email unread on the phone.
    Thanks for the info.

    Z10STL100-2/10.2.1.1925 O2 UK
    01-02-14 11:41 PM
  11. cevag's Avatar
    Thanks for the info.

    Z10STL100-2/10.2.1.1925 O2 UK
    Sorry Man, it is still happening, I had 2 email show up tonight and showed already read, didn't check my phone for 2 hours between 9 and 11PM.... B...S, I'm not sure if there's a setting or something that can fix this issue, this is the one thing that is really making me angry. It happens with Q10, with OS 10.1 then 10.2 and now 10.2.1.xxxx. If anyone has an answer for this issue I'd like to hear it.

    No one else reads my emails but me, never happens on my older bbos 4-5-6-7.

    So basically: email shows up, I don't read it right away, yellow envelop is in my inbox, then after a half hour or so the yellow envelop disappears, my new message becomes a read message, with me never looking or reading the actual message. WhY?? I've even taken my work email out of the HUB due to this issue, it makes it easier for me to double check that one account. up till now I've been getting away with it, for the most part.

    I missed a very important message a couple days ago, when I looked at my phone I had no new messages, while I actually did receive about 5 new emails, my phone was on silent due to a meeting, I never notice this one major email, because it showed as already read. the other 4 well, whatever didn't loose sleep over those ones. This is now a big problem, it happens all the time any of the OS10 I've had. I technically never had to worry about this since the early days of using Blackberry BBOS 4-7, but the one missed due to this issue makes me want to go back to my 9810, If anyone has the answer to this please post away!
    01-03-14 12:26 AM
  12. cevag's Avatar
    Double Post
    Last edited by cevag; 01-03-14 at 01:13 AM.
    01-03-14 12:28 AM
  13. guygardner73's Avatar
    Sorry Man, it is still happening, I had 2 email show up tonight and showed already read, didn't check my phone for 2 hours between 9 and 11PM.... B...S, I'm not sure if there's a setting or something that can fix this issue, this is the one thing that is really making me angry. It happens with Q10, with OS 10.1 then 10.2 and now 10.2.1.xxxx. If anyone has an answer for this issue I'd like to hear it.

    No one else reads my emails but me, never happens on my older bbos 4-5-6-7.

    So basically: email shows up, I don't read it right away, yellow envelop is in my inbox, then after a half hour or so the yellow envelop disappears, my new message becomes a read message, with me never looking or reading the actual message. WhY?? I've even taken my work email out of the HUB due to this issue, it makes it easier for me to double check that one account. up till now I've been getting away with it, for the most part.

    I missed a very important message a couple days ago, when I looked at my phone I had no new messages, while I actually did receive about 5 new emails, my phone was on silent due to a meeting, I never notice this one major email, because it showed as already read. the other 4 well, whatever didn't loose sleep over those ones. This is now a big problem, it happens all the time any of the OS10 I've had. I technically never had to worry about this since the early days of using Blackberry BBOS 4-7, but the one missed due to this issue makes me want to go back to my 9810, If anyone has the answer to this please post away!
    I really think that due to the problem persisting over many os updates, that it is some setting in outlook that is causing the problem. I use Hotmail and have no issues. Do you use the outlook desktop client at all? That may be where the problem lies.

    Z10STL100-2/10.2.1.1925 O2 UK
    01-03-14 07:28 PM
  14. Dave79's Avatar
    In the advanced email settings for BB10, there appeared a toggle called "append messages to sent folder" in recent OS versions.
    I have this set to "off", but I can see my sent items just fine when sync'ing. Is this setting supposed to do something special, something I am missing?
    Anyone can make some light on this setting? What is supposed to do?
    01-19-14 09:29 PM
  15. MrGlenn's Avatar
    I happened to find this site, saying some IMAP servers can reject saving messages to the 'Sent' folder.
    http://atmail.com/kb/2005/imap-append-sent-folder/

    I have tried some more on my device:
    for my Gmail accounts (1 free, 1 GApps) the 'Sent' folder seems to work fine with the setting to 'Off', but maybe some other email clients need it to be 'On' before messages are sync'ed? I can see no difference between my phone/online 'Sent' folders.
    01-21-14 08:43 AM
  16. LiteBulb's Avatar
    My guess is "Append messages to sent folder" simply means saving a copy of the sent email to your local sent folder.

    Example:
    Say you send an email from your BB. Then you go to your gmail webmail and you delete that email from your sent folder. When your BB syncs with your gmail, the below will occur:

    (a) If "Append messages..." is ON = You will still be able to see the sent email in your BB.
    (b) If "Append messages..." is OFF = That sent email will be gone.
    01-28-14 08:54 AM
  17. MrGlenn's Avatar
    That... makes perfect sense. I wonder why I never thought of that possibility, lol. I hope it works that way.
    My guess is "Append messages to sent folder" simply means saving a copy of the sent email to your local sent folder.
    01-28-14 09:33 AM
  18. slickvguy's Avatar
    My guess is "Append messages to sent folder" simply means saving a copy of the sent email to your local sent folder.

    Example:
    Say you send an email from your BB. Then you go to your gmail webmail and you delete that email from your sent folder. When your BB syncs with your gmail, the below will occur:

    (a) If "Append messages..." is ON = You will still be able to see the sent email in your BB.
    (b) If "Append messages..." is OFF = That sent email will be gone.
    Is there a separate local "Sent" folder I am unaware of? As good as your reasoning sounds, I don't think it's correct.

    I tested this feature. With one of my email accounts, unless the setting is ON, the sent emails will NOT be stored in the Sent folder of the account (on the server) and obviously won't appear in the hub. It seems that this particular mail server requires that setting to be on, while others like gmail do not require it to be on. Thus, I'm thinking that some IMAP implementations require this. Probably a flag.
    02-01-14 08:28 PM
  19. LiteBulb's Avatar
    I have tested and my BlackBerry acted the way as per my explanation.

    Gmail is setup as imap.

    I sent an email using q10.

    The sent email shows up in both my q10 and z30.

    I delete that email from gmail.

    Sync both q10 and z30.

    The sent messages got removed from the z30 but remained in the q10.
    Last edited by LiteBulb; 02-01-14 at 09:33 PM.
    MrGlenn likes this.
    02-01-14 09:21 PM
  20. slickvguy's Avatar
    I have tested and my BlackBerry acted the way as per my explanation.

    Gmail is setup as imap.

    I sent an email using q10.

    The sent email shows up in both my q10 and z30.

    I delete that email from gmail.

    Sync both q10 and z30.

    The sent messages got removed from the z30 but remained in the q10.
    Are you saying that you have the Q10's "append messages to sent folder" set to ON and the Z30's set to OFF? And that even when the SENT message is deleted from the gmail imap server that it is still being kept on the handset? Correct?

    Are sent messages stored locally separately? Is there a separate folder? Not to my knowledge. I see no way to access sent messages ASIDE FROM those that are stored locally to sync with the imap servers. You're saying that the handset is flagging those messages to not be removed when the folder is sync'd w/ the server. If you're right, why would anyone want to store sent messages on the handset but not on the server?

    This is why I believe it has to do with servers that don't automatically sync messages sent from the handset to its SENT folder. In other words, to force the sent messages to be saved in the server's sent folder. This is what I tested. On my videotron account, if I send an email from the handset, it will NOT be stored on the server in its sent folder unless that "append message" is set to ON. However, on gmail it does it regardless of the setting.

    To me, it seems clear. "Append messages to sent folder" means append the sent message to that account's server's sent folder.
    Last edited by slickvguy; 02-04-14 at 02:10 PM.
    MrGlenn likes this.
    02-01-14 10:05 PM
  21. Help_BB10's Avatar
    Append messages to sent folder: to synchronize folders in mail client and on the server .
    03-19-16 10:07 AM

Similar Threads

  1. Sad Announcement - HUB++ LED Disco has lost its head!
    By devcellent in forum App Announcements
    Replies: 103
    Last Post: 07-25-14, 04:27 PM
  2. Replies: 26
    Last Post: 12-27-13, 02:09 PM
  3. Replies: 2
    Last Post: 12-23-13, 08:47 AM
  4. Replies: 5
    Last Post: 12-23-13, 07:24 AM
  5. Replies: 1
    Last Post: 12-23-13, 07:23 AM
LINK TO POST COPIED TO CLIPBOARD