09-27-18 04:20 AM
41 12
tools
  1. The_Passporter's Avatar
    I have been downloading different versions of WAZE and some don't work or load or work well at all. Just wondering if anyone uses it or an alternative that works well.

    Posted via CB10
    09-14-16 11:22 PM
  2. conite's Avatar
    The very latest from Google Play Store works perfectly. v4.7.0.1 I think.
    09-14-16 11:55 PM
  3. The_Passporter's Avatar
    The very latest from Google Play Store works perfectly. v4.7.0.1 I think.
    On my Passport it is extremely sluggish. What device are you using it on?

    Posted via CB10
    09-15-16 09:06 AM
  4. conite's Avatar
    On my Passport it is extremely sluggish. What device are you using it on?

    Posted via CB10
    Z30 and Z10.

    "Sluggish" is in the eyes of the beholder. I'm usually satisfied with "runs pretty well" when it comes to new Android apps on a BB10 device.
    09-15-16 09:17 AM
  5. The_Passporter's Avatar
    Z30 and Z10.

    "Sluggish" is in the eyes of the beholder. I'm usually satisfied with "runs pretty well" when it comes to new Android apps on a BB10 device.
    No it was really bad, to a point where I just stopped using it. I will try and download the latest and see. I was experimenting with older versions in the hope of finding one that worked best with fewer features implemented. Unfortunately that proved futile.


    Posted via CB10
    09-15-16 09:31 AM
  6. CyberMan2013's Avatar
    You can try the latest from Amazon App Store but be careful when multitasking and charging while Waze is running since it already heats up the phone quite a bit. Hot CPU can lead to slow and then unpredictable performance.

    Posted via CB10
    The_Passporter likes this.
    09-15-16 10:02 AM
  7. eiruvrav's Avatar
    The one from amazons app store works great for me.
    09-15-16 08:12 PM
  8. seletok's Avatar
    Latest from Play Store. Works perfect. Except few freeze when need to restart the app.

    Posted via CB10
    09-15-16 11:05 PM
  9. The_Passporter's Avatar
    The very latest from Google Play Store works perfectly. v4.7.0.1 I think.
    I downloaded many versions and they all did not work or work well. I finally got the one from the Play Store installed today and even though it's not much better than the one I originally had at least it works. This is one of few apps I like that we on BB10 yearn to have working well. Still holding out with my Precious Passport lol.

    Posted via CB10
    09-16-16 11:50 PM
  10. melander's Avatar
    The screen positioning never worked well on the q10.
    09-17-16 03:27 AM
  11. CarelStarreveld's Avatar
    Latest versions worked well for me on a passport and q10. Had to change the screen settings so all functions were available. Moved to android now so cant test it atm

    Posted via the CrackBerry App for Android
    09-18-16 05:34 AM
  12. melander's Avatar
    What screen settings were used for the q10?
    09-18-16 08:14 PM
  13. pvphooman's Avatar
    Latest version doesn't detect my location. (Location is on.)
    Can someone link me with a working version?

     Z30STA100-5/10.3.2.2876/2814 CB10
    09-29-16 03:07 PM
  14. conite's Avatar
    Latest version doesn't detect my location. (Location is on.)
    Can someone link me with a working version?

     Z30STA100-5/10.3.2.2876/2814 CB10
    Not my experience.
    09-29-16 03:25 PM
  15. mm2061's Avatar
    Also my version did not detect my location and hangs at startup.
    Is there a native version?

    Posted via CB10
    09-30-16 06:44 PM
  16. conite's Avatar
    Also my version did not detect my location and hangs at startup.
    Is there a native version?

    Posted via CB10
    Nope. Android only.
    09-30-16 10:31 PM
  17. conite's Avatar
    4.8.0.2 works perfectly.
    09-30-16 10:33 PM
  18. The_Passporter's Avatar
    Using ver. 4.7.0.1 and works well

    Posted via CB10
    09-30-16 10:55 PM
  19. pvphooman's Avatar
    Latest version doesn't detect my location. (Location is on.)
    Can someone link me with a working version?

     Z30STA100-5/10.3.2.2876/2814 CB10
    I figured out my issue. I forgot I had disabled location in Android settings. I used ghost commander to correct it. Waze works now.

     Z30STA100-5/10.3.2.2876/2814 CB10
    10-15-16 09:18 AM
  20. p1800nut's Avatar
    I'm using 4.9.0.2 on my Z30 and it's barely tolerable. I'd say about 1 in 4 attempts actually works; my usual routine is to start it up and it freezes and gives a Waze stopped working error. Close and re-try and it may work, but then often it freezes at some point in my drive and I again need to close and restart. I was hoping it would improve with 10.3.3, but so far it hasn't. For grins, I've tried using an iPhone 5S and a Windows Phone that I've been experimenting with, and the experience is SO much better. Sad.
    12-06-16 02:31 PM
  21. semime's Avatar
    I'm using 4.9.0.2 on my Z30 and it's barely tolerable. I'd say about 1 in 4 attempts actually works; my usual routine is to start it up and it freezes and gives a Waze stopped working error. Close and re-try and it may work, but then often it freezes at some point in my drive and I again need to close and restart. I was hoping it would improve with 10.3.3, but so far it hasn't. For grins, I've tried using an iPhone 5S and a Windows Phone that I've been experimenting with, and the experience is SO much better. Sad.
    Those of us, still holding onto our Z30s, will face increasing frustration in dealing with and tolerating the sub-par android performance/experience of apps running on the aging android runtime. It's not specific to Waze.

    As you mentioned, getting it to load is hit or miss and, more often than not, requires multiple attempts. An attempt following a device reboot barely improves that outcome. Unfortunately, the situation isn't going to improve on the Z30 or any other BB10 device.
    12-06-16 04:07 PM
  22. p1800nut's Avatar
    Semime,

    You're probably right. In fact, I'm regretting updating to 10.3.3 because it's made things worse. Or maybe it was because I updated to the latest version of Waze this afternoon. Headed home tonight it failed 7 attempts; I finally gave up and pulled out my test iPhone and got instant results. <sigh> I got my wife a Priv on Black Friday to replace her Q5--maybe it's time for DTEK60 for me.
    12-06-16 11:22 PM
  23. conite's Avatar
    The latest version of Waze has always worked very well on my BB10 devices. We are currently at v4.15.0.2.
    12-06-16 11:24 PM
  24. semime's Avatar
    The best opportunity for me to share Conite's experience with Waze on my Z30 is following a fresh reboot, sitting at home (connected to wifi) and merely plugging in a destination. It works great! Load time is less than a minute (30-60s).

    In practice, my experience is more closely aligned with that of p1800nut. When I require directions on the road (connected to the Verizon 4G network, or not) load time can literally take several attempts/minutes before getting to the start screen even after a reboot. Once navigating, if for any reason I have to minimize the app then, it's back to waiting minutes for the screen to reappear (if at all). More than once, I've had the shame of asking my girlfriend to open Waze on her Galaxy S5 with near instant load time (seconds, at most).

    Obviously, we all share different experiences. But, given my own, I find it frustrating that some would have that experience effortless lol
    12-07-16 07:12 AM
  25. JG_Agustin's Avatar
    The best opportunity for me to share Conite's experience with Waze on my Z30 is following a fresh reboot, sitting at home (connected to wifi) and merely plugging in a destination. It works great! Load time is less than a minute (30-60s).

    In practice, my experience is more closely aligned with that of p1800nut. When I require directions on the road (connected to the Verizon 4G network, or not) load time can literally take several attempts/minutes before getting to the start screen even after a reboot. Once navigating, if for any reason I have to minimize the app then, it's back to waiting minutes for the screen to reappear (if at all). More than once, I've had the shame of asking my girlfriend to open Waze on her Galaxy S5 with near instant load time (seconds, at most).

    Obviously, we all share different experiences. But, given my own, I find it frustrating that some would have that experience effortless lol
    I've had a varying experience using Waze on BlackBerry 10. While I was using a Z30 in 2014 and later on my beloved Passport as main drivers, I'd stick with the latest version from Google Play Store. However, now it's kind of a hit and miss experience.

    For the last semester or so, I have been switching between my Passport and PRIV, and the best way to use Waze on the former is definitely opting for the version available on the Amazon App Store (3.8.1.1). While it's an older version, it runs quite well, integrates fine with my Facebook account and generally works smoother on BlackBerry 10 devices than the latest version from GPS.

    Posted with my powerful and masterful  Passport!
    12-20-16 11:54 PM
41 12

Similar Threads

  1. BlackBerry Link stopped working
    By pneumasax in forum BlackBerry 10 OS
    Replies: 79
    Last Post: 04-16-17, 11:33 AM
  2. Replies: 1
    Last Post: 09-30-16, 08:32 AM
  3. Offering Google Maps android app. Works without Play Services
    By HanzWurst in forum Android Apps (Amazon Store & APK Files)
    Replies: 1
    Last Post: 09-17-16, 12:39 AM
  4. Play store app on my Q10 is not working.
    By jacobs jay in forum Ask a Question
    Replies: 2
    Last Post: 09-15-16, 12:58 AM
  5. Replies: 1
    Last Post: 09-14-16, 07:24 PM
LINK TO POST COPIED TO CLIPBOARD