1. Vistaus's Avatar
    The one Android app my dad has to use for his job on his Leap stopped working for *him* because the app reports that TLS 1.0 is deprecated and that his employer shut down access for any device that still uses TLS 1.0
    Which raises the question if the Android Runtime on BB10 actually supports anything higher than TLS 1.0? Is there any workaround for this?
    02-01-17 10:17 AM
  2. thurask's Avatar
    https://developer.android.com/refere...SSLSocket.html

    Apparently Android has supported TLS 1.1/1.2 since API 16 (4.1) but has only enabled it by default since API 20/21 (4.4 for wearable/5.0). The BB10 runtime is 4.3, so it's within that limbo band.

    The easiest course of action that keeps a BB10 phone involved is to update the app to accommodate 4.1-4.4, although that's easier said than done.
    02-01-17 10:25 AM
  3. Vistaus's Avatar
    https://developer.android.com/refere...SSLSocket.html

    Apparently Android has supported TLS 1.1/1.2 since API 16 (4.1) but has only enabled it by default since API 20/21 (4.4 for wearable/5.0). The BB10 runtime is 4.3, so it's within that limbo band.

    The easiest course of action that keeps a BB10 phone involved is to update the app to accommodate 4.1-4.4, although that's easier said than done.
    The app already supports 4.4 Is there any workaround my dad can use to use the app still?

    Posted via CB10 using my amazing  Passport (OG Red) <3
    02-01-17 05:07 PM
  4. thurask's Avatar
    The app already supports 4.4 Is there any workaround my dad can use to use the app still?

    Posted via CB10 using my amazing  Passport (OG Red) <3
    Besides an Android phone? None that I can think of.
    02-01-17 05:27 PM
  5. conite's Avatar
    The app already supports 4.4 Is there any workaround my dad can use to use the app still?

    Posted via CB10 using my amazing  Passport (OG Red) <3
    Requires 4.4?
    02-01-17 05:28 PM
  6. Vistaus's Avatar
    Besides an Android phone? None that I can think of.
    Ouch, that sucks! Thanks for helping though! :-)

    Posted via CB10 using my amazing  Passport (OG Red) <3
    02-02-17 12:56 AM

Similar Threads

  1. Blend Alternate for Priv and Android - Fuse by ToZ Inc
    By BriniaSona in forum BlackBerry Priv
    Replies: 59
    Last Post: 02-19-18, 12:34 PM
  2. BBM should not have ads on BlackBerry Android phones.
    By skstrials in forum BlackBerry Android OS
    Replies: 23
    Last Post: 02-27-17, 06:42 PM
  3. some Newby android questions
    By OTCHRussell in forum Ask a Question
    Replies: 1
    Last Post: 01-31-17, 10:37 AM
  4. Latest on Android Pay Canada?
    By nucks26 in forum Android Apps
    Replies: 3
    Last Post: 01-30-17, 02:32 PM
  5. help setting up hub on android?
    By Anel Kapur in forum Ask a Question
    Replies: 2
    Last Post: 01-30-17, 09:11 AM
LINK TO POST COPIED TO CLIPBOARD