1. Cam Funk's Avatar
    Blackberry Z10 running I received a new phone under warranty and restored my previous data to the new Z10. I loaded snap and I can login and see apps and download. But I don't get a permissions screen and then it just stay stuck on a black screen saying "initializing". I have done a restore and numerous restarts and battery pulls. The allow apps from other sources is also turned on in settings. Even if I sideload apps they do not open, just a blue progress bar on the bottom of the screen and eventually it just closes the app. I also noticed my amazon kindle app which is from blackberry app world doesn't open. It acts just like the sideloaded apps I try to open.
    My previous Z10 worked perfectly other than the speaker failing which is why i had it replaced. Any help would be appreciated.
    03-27-14 02:30 PM
  2. Elite1's Avatar
    Hi Cam,
    First off, welcome to CrackBerry!
    Please update your profile to include device, carrier, and location. This makes it easier for others to help you.

    FYI, don't battery pull on BB10. The equivalent for BB10 is a device reset, which isn't quite the same as a Restart.

    You can try a device reset first. (NOT the same as a restart.)
    Hold down both your Volume Up & Down keys for about 10-20 seconds. Keep pressing them, ignoring screenshot notification, BB splashscreen, black screen, red LED, and BB splashscreen again. I don't release the Volume keys until I see the blue startup icon.

    Anything work better after that reboot?
    03-27-14 02:46 PM
  3. Cam Funk's Avatar
    Ok, thank you I will give this a go. And I will also update my profile.
    Thanks for now
    03-27-14 05:16 PM
  4. Cam Funk's Avatar
    OK, I did the reset holding the volume buttons.
    Did not make any difference. Any other ideas?

    Posted via CB10
    03-27-14 05:36 PM
  5. Cam Funk's Avatar
    Definitely seems like a runtime issue to me. Did some research and apparently there is a runtime available in app world, but it says request is not found. Here is a screen shot of what it does when I try to open an app.
    Android apps won't open-img_20140327_171915.png

    Posted via CB10
    03-27-14 10:12 PM
  6. Dave Bourque's Avatar
    The runtime in BBW is out of date..

    03-27-14 10:14 PM
  7. omega supreme's Avatar
    They did a poll on this as this happened to a lot of people in here that updated to10.2 including me. Apparently over 300 or so users went through the same thing. I have yet to find a solution. There is a thread floating around with supposedly links that will fix it but midway in the thread people began saying the links were dead.
    I'm going to try calling t-mobile and see what they say. More than likely they will tell me blackberry isn't supposed to run android apps anyway and tell me they cannot help.

    Posted via CB10
    03-28-14 03:42 AM
  8. Cam Funk's Avatar
    So frustrating. Strange thing is that my Kindle app from bb world doesn't run either. Is this a separate issue?

    Posted via CB10
    03-28-14 05:02 AM
  9. Markmab's Avatar
    I have had this same problem on my Z10 since 10.1. (Bell mobility)

    My sister has a Z10 and hers doesn't have this problem. (Rogers)

    My Friend has a Z10 and his also works fine. (Telus)

    It would be nice to have the fix.
    03-28-14 08:00 AM
  10. Cam Funk's Avatar
    I would seriously take back my old z10 with a blown speaker right now.....

    Posted via CB10
    03-28-14 09:08 AM
  11. Dave Bourque's Avatar
    You need to sideload the newest runtime.... but you've downloaded a older one off BBW.

    03-28-14 02:30 PM
  12. Cam Funk's Avatar
    Hey Dave,
    Where do I get a current runtime?

    Posted via CB10
    03-28-14 03:08 PM
  13. Dave Bourque's Avatar
    You would get it off one of the leaks and use Sachesi, or the chrome sideload tool. Latest leak came out today so just taking the 2 android bars off it and loading it should do.

    03-28-14 03:22 PM
  14. Cam Funk's Avatar
    Thanks, I'll give it try this weekend

    Posted via CB10
    03-28-14 03:56 PM
  15. D.Vader's Avatar
    Which runtimes are you loading to fix this issue? How do I search for them in Sachei?
    04-04-14 12:24 PM
  16. Cam Funk's Avatar
    Does anyone have a link for a run time? I'm using Chrome side load tool. I have discovered something is wrong with my back up. I did a security wipe and before I restored my data I tried my Kindle app which was one app not working... and it worked. proceeded to restore my data and then after it doesn't work

    Posted via CB10
    04-06-14 09:28 AM
  17. janesy01's Avatar
    Any follow up to this? Just went from z10 to z30, and I'm having the same issues
    09-18-14 08:24 PM

Similar Threads

  1. Learn BlackBerry 10 Native App Development - Book - eBook
    By qabb in forum New to BlackBerry App Dev
    Replies: 24
    Last Post: 07-02-14, 12:16 PM
  2. Nokia android app store
    By usman_hidayat19 in forum Android Apps (Amazon Store & APK Files)
    Replies: 2
    Last Post: 04-12-14, 12:10 PM
  3. Today Theme - App idea
    By labyrinth9 in forum BlackBerry 10 Apps
    Replies: 5
    Last Post: 04-11-14, 04:50 PM
  4. Mr Chen please allow app installs to SD Card
    By Ferrari430Spider in forum BlackBerry 10 OS
    Replies: 33
    Last Post: 03-28-14, 05:14 AM
  5. Question About new OS - Android Apps No Longer Working!
    By martymart87 in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 03-27-14, 04:03 PM