1. gcarloni's Avatar
    Every time I try to open an app, What's App or CleanMaster it's almost like the app is loading first, takes about 20-30 seconds each time. Is there a fix for this...I get a blank screen with a line starting across the middle progressing until it's full, then the app starts....very frustrating.

    Posted via CB10
    06-03-17 09:16 AM
  2. Drenegade's Avatar
    That's how it is on BB10.

    Posted via CB10
    06-03-17 09:21 AM
  3. brookie229's Avatar
    The fix is to get rid of CleanMaster--it is not needed (IMHO). Realize that the green line that you see slowly progressing across your screen is the android runtime initializing. Do you have a lot of android apps on your Passport? The more you have, the worse that your device will perform. What OS are you on? You may also improve by doing an update. My advice is to remove CleanMaster first, then reboot, wait 10-15 minutes then open your WhatsApp.
    06-03-17 09:29 AM
  4. Invictus0's Avatar
    What version of BB10 are you on? Is it a black screen with a green line in the middle? If so that means the Android runtime is starting up, in most cases you should only see it once (if at all).
    06-03-17 09:34 AM
  5. Huussi's Avatar
    This happens every now and then to me, a reboot always fixes it.
    06-03-17 09:54 AM
  6. jefbeard911's Avatar
    Yeah, ditch Cleanmaster. Not necessary. The Android version of Whatsapp opens for me in less than 5 sec.



    Posted via CB10
    06-03-17 10:15 AM
  7. gcarloni's Avatar
    Removed Cleanmaster, still same problem, software is 10.3.3.1463, I have two other Android apps, BB10 worked much better.

    Posted via CB10
    06-03-17 11:13 AM
  8. brookie229's Avatar
    Removed Cleanmaster, still same problem, software is 10.3.3.1463, I have two other Android apps, BB10 worked much better.

    Posted via CB10
    Did you do an OTA update to 10.3.3 or an autoloader? If you did OTA then you may have to do a clean OS install with an autoloader. With only minimal android apps you should not be having those problems. I am sure that a clean install of 10.3.3.2205 (.1463) will solve your problems.
    06-03-17 11:17 AM
  9. brookie229's Avatar
    Also, you may want to follow and install WhatsApp this way: https://forums.crackberry.com/blackb...olved-1108531/ if you haven't already. That would be after a clean install of the OS. Maybe you have a funky version of WA that does not go well with the runtime on your Passport?
    06-03-17 11:29 AM
  10. pgg101's Avatar
    As Android apps get updated and optimized for new Android versions, the poorer they perform on BB10. It's a three year old phone, and 3 is the new 5. Time to move on if you are more dependent on Android apps.


    RedBerry Passport / 10.3.3.2205 / Telus
    06-03-17 12:26 PM
  11. brookie229's Avatar
    Time to move on if you are more dependent on Android apps.
    While I agree with your statement generally, he states that he ONLY has 3 android apps, one of which he uninstalled (the unneeded CleanMaster). Any BB10 device should be able to handle a couple of android apps. That is why I pointed him to the WhatsApp thread above in my previous post. It seems to work well (for now anyway!).
    06-03-17 12:34 PM
  12. gcarloni's Avatar
    I un installed the Android app for now, re installed bb10 app until the end of June, very frustrating...shouldn't have to be a techy programer to get this stuff to work properly.

    Posted via CB10
    06-05-17 04:35 AM
  13. jefbeard911's Avatar
    I un installed the Android app for now, re installed bb10 app until the end of June, very frustrating...shouldn't have to be a techy programer to get this stuff to work properly.

    Posted via CB10
    Agreed. Unfortunately this is the BB10 world as is stands now and it will only get worse.

    I've learned to give up on some of my favorite Android apps and either use the mobile website version (which can work surprisingly well) or substitute a sub-par BlackBerry App.

    It's the price I pay for wanting a smooth, hassle-free Passport: experience.

    Posted via CB10
    06-05-17 04:52 AM
  14. gcarloni's Avatar
    Love my Passport, probably being forced to the Key 1 eventually. What's app is the only app I'm having an issue with, seems all android apps on this phone get funky with long start ups, too frustrating to try and resolve...

    Posted via CB10
    06-05-17 04:59 AM
  15. jefbeard911's Avatar
    Love my Passport, probably being forced to the Key 1 eventually. What's app is the only app I'm having an issue with, seems all android apps on this phone get funky with long start ups, too frustrating to try and resolve...

    Posted via CB10
    What version of Whatsapp are you downloading? I downloaded 2.7, which just came out, from apkmirror and it opens and runs very fast on my OG Passport. I'm giving up on it cuz it can't send media (pics, vids). There's a fix but it's too much of a hassle.

    Posted via CB10
    06-05-17 05:04 AM
  16. gcarloni's Avatar
    2.17 from Google Playstore, takes forever to load, everytime, won't stay online, has to be open for messages.

    Posted via CB10
    06-05-17 05:08 AM
  17. jefbeard911's Avatar
    2.17 from Google Playstore, takes forever to load, everytime, won't stay online, has to be open for messages.

    Posted via CB10
    Ah, I meant 2.17 as well.

    So you're using Cobalts patch to get the Play Store huh?

    Try just downloading the apk from apkmirror and installing it that way. If you do, delete the GPS version first. Worth a try.

    Posted via CB10
    06-05-17 05:24 AM
  18. Huussi's Avatar

    Try just downloading the apk from apkmirror and installing it that way.
    I recommend getting the app straight from whatsapps website.

    https://www.whatsapp.com/android/
    06-05-17 05:56 AM

Similar Threads

  1. slow
    By 69reichertm in forum BlackBerry KEYone
    Replies: 18
    Last Post: 06-05-17, 04:34 PM
  2. Failed download on Native browser 10.3.3
    By tegar ramadhanu kariadinata in forum BlackBerry Passport
    Replies: 12
    Last Post: 06-04-17, 03:14 AM
  3. Is There An Android App To Swipe Screen To Open Apps?
    By shriscean in forum BlackBerry KEYone
    Replies: 4
    Last Post: 06-03-17, 01:56 PM
  4. Cant shortcut when panels on scren
    By todena in forum BlackBerry KEYone
    Replies: 1
    Last Post: 06-03-17, 09:58 AM
  5. Replies: 0
    Last Post: 06-03-17, 05:40 AM
LINK TO POST COPIED TO CLIPBOARD