06-22-16 08:05 AM
29 12
tools
  1. dkonigs's Avatar
    The "dummy" accounts get backed up and when you restore this backup, it is no longer linked to the original app
    Hence, it will keep asking for password etc
    The problem is a mixture of two things... This is the first. Basically, a backup/restore sets a "password change needed" flag on the account that causes the system to generate that annoying prompt. If the app is still installed, then it can "update" the dummy account to clear that flag and make the notification go away. If the app isn't installed, then it obviously cannot do that.

    The second issue is that a the hub integration examples/docs a lot of developers got do something very bad. Specifically, they say that an app should "remember" the ID of its dummy account inside its own settings. As such, any delete/reinstall of that app will cause it to lose that data and create a second account.

    The solution is for the app to actually find its dummy account in the system, rather than just remembering its ID internally.

    The first issue is something BlackBerry absolutely needs to fix.
    The second issue is something app developers need to address.

    Of course if the system actually removed these dummy accounts when their respective apps were deleted, these problems would be far less common.
    02-08-15 03:01 PM
  2. lakes76's Avatar
    The Sachesi/Blitz update definitely worked to resolve the problem. It's been several days and there have been no daily notifications....thanks to masterscarhead1 for that solution.

    No, actually if you do an OTA/sachesi update with the preexisting problem, it will be fixed.
    Why this is, I do not know

    Posted via CB10
    02-11-15 01:55 PM
  3. schwede's Avatar
    This app helped me to fix the issue on my Q10 --> https://appworld.blackberry.com/webs...countrycode=US
    blakobecwa and Doug_M like this.
    01-27-16 12:07 PM
  4. Doug_M's Avatar
    This app helped me to fix the issue on my Q10 --> https://appworld.blackberry.com/webs...countrycode=US
    Thanks Schwede, worked for me too!
    06-22-16 08:05 AM
29 12

Similar Threads

  1. Replies: 15
    Last Post: 04-16-15, 11:30 AM
  2. Can Anybody make Clash of Clan work on BB 10?
    By Naziem13 in forum Ask a Question
    Replies: 3
    Last Post: 02-05-15, 11:44 AM
  3. Replies: 16
    Last Post: 01-30-15, 12:24 PM
  4. I'm tired of adding words in the dictionary
    By SaveurBlackBerry in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 01-29-15, 05:02 AM
  5. Images are not visible
    By Muhammad Shoukath in forum Ask a Question
    Replies: 1
    Last Post: 01-28-15, 04:29 PM
LINK TO POST COPIED TO CLIPBOARD