1. M812 BB's Avatar
    Hi everyone.

    This is my problem with STL100-4
    I'm in EU - Latvia.
    Updated to this one from Google Drive: Z10_10.3.03.2163_STL100-4.7z (thanks thurask).

    Installed new SIM from operator.
    1) Switching on/off the phone - Verizon logo shows up (my op is not Verizon though).
    2) I was able to configure data service APN using escreen only.
    3) SMS service center address filled by operator and is correct. No other SMS options are available.
    4) Configured smart dialing according to my location. (Defaults were USA).

    Everything is working fine except one thing - I can send SMS only to local numbers (without country code prefix).
    When I'm replying to SMS or sending a new one to contact with full number saved I got "Network out of order" error.

    With SIM from other operator - no Verizon logo, all SMS are sent and APN setting are available.

    Any clues what could be changed here?
    Thanks.
    01-12-17 04:00 PM
  2. thurask's Avatar
    I'm not entirely sure the STL100-4 would fully work off of Verizon. If anything a network in Europe should be using the STL100-2, since that's the Europe LTE/GSM model.

    Since the STL100-4 is only for Verizon that would explain the Verizon/USA stuff, but not how it ended up there. Was it working on a prior OS version?

    And about this operator, I have a feeling that your carrier might not be in the carrier database contained within the OS, while the other one might be. Do you have the names of both carriers?
    01-12-17 06:33 PM
  3. M812 BB's Avatar
    OK. Thanks for pointing.

    I will try to flash STL100-2 version.

    Here are the operators:
    With this SIM Verizon logo shows up:
    MCC MNC Brand Operator Status Bands (MHz) References and notes
    247 01 LMT Latvian Mobile Telephone Operational GSM 900 / GSM 1800 / UMTS 900 / UMTS 2100 / LTE 1800 / LTE 2600 [84][143]

    With this SIM everything is working as expected:
    247 05 Bite Bite Latvija Operational GSM 900 / GSM 1800 / UMTS 2100 / LTE 800 / LTE 1800 / LTE 2600 Bite's postpaid customers are still being assigned SIM cards with 246 02 MNC[84]
    According to reference could be 246 02 MNC as I have pospaid.
    01-13-17 04:39 AM
  4. M812 BB's Avatar
    Was it working on a prior OS version?
    Yes but very shortly.
    As when I have inserted new SIM from 247 01 and got WiFi signal the phone received carrier approved update (have not noticed which one but I some of 10.3.2.xxx) and Verizon stuff shows up. Then I flashed 10.3.3.2163
    01-13-17 04:43 AM
  5. ali76_BHR's Avatar
    I have a BlackBerry Passport SE, till now I can't see the os update 10.3.3 , mine is a Sim free phone. Can anyone help me.
    01-13-17 08:36 AM
  6. M812 BB's Avatar
    If anything a network in Europe should be using the STL100-2, since that's the Europe LTE/GSM model.
    This one does not work either Z10_10.3.03.2163_STL100-2-3.7z
    All the same

    I have to admit that this 247 01 SIM works as expected in other phone STL100-1 on 10.3.2.

    What can I try else?
    01-13-17 03:30 PM
  7. thurask's Avatar
    STL100-1/2/3/4 are hardware, you can't flash one to the other.

    Anyway, checking the BB10 carrier data list (i.e. the list of IDs), there's support for Tele2 (247/002) and Vodafone/Bite (247/005 and 246/002). Since LMT (247/001) isn't in the list it defaults to whatever is standard; since it's a Verizon phone that's why the Verizon stuff shows up.

    Inside the OS are individual settings files for each carrier in the big list of IDs, files that determine tethering rules, SMS/MMS configuration, available network settings, etc. Such a file exists for Bite and Tele2 but not LMT, hence your problem. Verizon only exists inside the United States.

    Now as for the STL100-1 on 10.3.2, that's a mystery. Perhaps the fact that the STL100-1 isn't designed specifically for one carrier (unlike the STL100-4) allows it to receive settings from the provider. Which version of 10.3.2 is it running?
    01-13-17 07:31 PM
  8. M812 BB's Avatar
    Thank for info.

    STL100-1/2/3/4 are hardware, you can't flash one to the other.
    I was able to flash autoloader Z10_10.3.03.2163_STL100-2-3.7z on STL100-4.

    Such a file exists for Bite and Tele2 but not LMT, hence your problem
    Is it possible to manually create such a file and embed it to OS somehow?
    Or maybe necessary setting could be changed via escreen?

    I will return with update regarding STL100-1 as soon as I will turn it on after the wipe.
    01-15-17 11:22 AM
  9. thurask's Avatar
    Thank for info.


    I was able to flash autoloader Z10_10.3.03.2163_STL100-2-3.7z on STL100-4.


    Is it possible to manually create such a file and embed it to OS somehow?
    Or maybe necessary setting could be changed via escreen?

    I will return with update regarding STL100-1 as soon as I will turn it on after the wipe.
    The software between the STL100-2/3/4 is compatible, but again, you can't magically change STL100-4 hardware into STL100-2 hardware. It's still a Verizon phone at the end of the day.

    And as for the latter, you can't create system files, only BlackBerry can. Not sure about escreens, but I doubt it.
    01-15-17 12:03 PM

Similar Threads

  1. Replies: 7
    Last Post: 01-14-17, 11:51 AM
  2. Does the Gasbuddy app still work on BB Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 8
    Last Post: 01-13-17, 11:48 AM
  3. How do I transfer photos from Z30 to Box?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 01-13-17, 07:18 AM
  4. How to uninstall android apps on z3
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 01-12-17, 11:30 PM
  5. how to attach picture ina text message - Priv
    By CrackBerry Question in forum Ask a Question
    Replies: 21
    Last Post: 01-12-17, 01:23 PM
LINK TO POST COPIED TO CLIPBOARD