09-03-14 02:44 PM
115 ... 2345
tools
  1. project_x's Avatar
    Same symptoms after the reboot. Not working headless.

    Tried toggling the the permissions. No change.
    I'm on Z10STL100-3/10.2.1.1925

    Other headless apps are still working.

    Any ideas, before I delete and reinstall
    01-07-14 08:47 PM
  2. QtHelex's Avatar
    Got last night a bug report by reversekcid.

    My headless module stops working as soon as a different headless app gets installed!

    I wonder if the reason may be because we have unstable leaked firmwares or if I've done something wrong.

    Seems to affect project_x, too.
    Anyone able to confirm, if yes at which firmwares?
    Does this happen also other way around?
    01-07-14 11:19 PM
  3. FF22's Avatar
    Got last night a bug report by reversekcid.

    My headless module stops working as soon as a different headless app gets installed!

    I wonder if the reason may be because we have unstable leaked firmwares or if I've done something wrong.

    Seems to affect project_x, too.
    Anyone able to confirm, if yes at which firmwares?
    Does this happen also other way around?
    Is there an order of loading of Headless apps on reboot? Alphabetic, date when initially installed, other? Or does it matter?
    01-07-14 11:44 PM
  4. QtHelex's Avatar
    Is there an order of loading of Headless apps on reboot? Alphabetic, date when initially installed, other? Or does it matter?
    I have no idea. This kind of stuff was not documented by BlackBerry.

    Seems to affect so far:
    OS Version: 10.2.1.1925
    Software Release: 10.2.1.537
    Device: Z10 STL100-2

    and:
    Z10STL100-3/10.2.1.1925

    I had so far no time to doublecheck or test this myself. Hopefully it is only firmware related and works fine at the stable release, but I need to go to work now and can't investigate.

    To all beta tester: Please check if this bug also affects you.
    01-08-14 12:53 AM
  5. reversekcid's Avatar
    Same symptoms after the reboot. Not working headless.

    Tried toggling the the permissions. No change.
    I'm on Z10STL100-3/10.2.1.1925

    Other headless apps are still working.

    Any ideas, before I delete and reinstall
    Are you running Flip Hush or SayIt? Both are headless and both got updated yesterday. I experienced the same issue as you mentioned after installing or updating these apps. Reinstalling ClipMan after updating/installing a headless app solves the problem as a workaround.


    Posted via CB10
    01-08-14 02:39 AM
  6. Masonle3's Avatar
    Mee

    Posted via CB10
    01-08-14 03:01 AM
  7. project_x's Avatar
    I did update flip shush and I am running Callx as well.
    01-08-14 04:13 AM
  8. QtHelex's Avatar
    Today was version 1.7.0 released for the public. This is a bugfix release for firmware 10.2.0.x and lower. The code for the active Frame was rewritten and it should scale now automatically, no matter what kind of resolutions BlackBerry will release at future devices.
    So buying a ClipMan license is a safe investment!

    The update should be visible to you elite1, since you're not a beta tester. (you haven't replied to my private message)
    Please check out if it gets now displayed correctly at your device.
    01-08-14 12:39 PM
  9. QtHelex's Avatar
    To all Beta Testers:

    Release canidate 1.9.9.6 of ClipMan (headless) was uploaded. A lot of stuff was changed and reorganized (the download file is about 300kB smaller as the previous)

    Get it via the method and code I've written you in the private message.

    This version has no german language support. Apart from this everything should work (hopefully) as expected.
    Please check again, based on this version I would like to finally release the first headless version of ClipMan to the public.
    01-08-14 01:24 PM
  10. just_luc's Avatar
    Update installed, seems to be working well, but I was one of the few it seems who didn't have any problems with the last version. That's likely because I don't have any other headless apps installed. I'll have to see if I can find a other and test that.

    Posted via CB10
    QtHelex likes this.
    01-08-14 04:15 PM
  11. just_luc's Avatar
    I've added another headless app. Both seem to be getting along fine. ClipMan has not crashed for me. The led function remains and everything I've tried to copy has been recorded.

    I have noticed one small glitch though, but I'm not sure if it's new or if I just didn't notice before.. when something is copied that has an apostrophe it doesn't display properly in the list view..it copies properly, it displays properly if I open it, and it pastes properly, but the list shows up wrong.

    Example:

    This is what was copied:

    Attachment 237196


    This is how it shows up in the list view:

    Attachment 237197


    Posted via CB10
    Last edited by just_luc; 01-09-14 at 12:16 AM.
    01-08-14 11:43 PM
  12. BigBadWulf's Avatar
    Haven't had the opportunity to upgrade yet, but I am staying running.

    Have the same glitch here Luc.
    01-08-14 11:58 PM
  13. theninjew's Avatar
    To all Beta Testers:

    Release canidate 1.9.9.6 of ClipMan (headless) was uploaded. A lot of stuff was changed and reorganized (the download file is about 300kB smaller as the previous)

    Get it via the method and code I've written you in the private message.

    This version has no german language support. Apart from this everything should work (hopefully) as expected.
    Please check again, based on this version I would like to finally release the first headless version of ClipMan to the public.
    If you still need a beta tester, I'm on Z10STL100-3/10.2.1.1925.

    Sent from my Z10 using CB Forums mobile app
    01-09-14 12:19 AM
  14. QtHelex's Avatar
    If you still need a beta tester, I'm on Z10STL100-3/10.2.1.1925.
    We're currently (hopefully) in the final stage before a public release. So with some luck you will get it anyway this week.

    I have already some testers with firmware 10.2.1.1925 at which a "installation issue" happens in case a second headless app gets installed. It affects as it seems only this firmware which you're using, too.
    I'm just waiting for feedback from especially one certain tester.
    But in case you have already access to several more headless apps and willing to delete and reinstall those several times while checking out ClipMan Headless please drop me a private message. :-)


    Posted via CB10
    extisis likes this.
    01-09-14 12:51 AM
  15. project_x's Avatar
    Tried that, uninstalled flip shush and reinstalled it. Clipman keeps on clipping.

    Z10STL100-3/10.2.1.1925
    QtHelex likes this.
    01-09-14 07:59 AM
  16. reversekcid's Avatar
    I have now tested a lot of different combinations (installation order, remove app, reboot or not, permission change, open ClipMan before or after installing an app or testing, etc.) to get more information what is triggering the problem and finally figured out that the bug is only triggered when the app "Data Volume Report" is installed on the phone. I have now removed Data Volume Report as a work around and I am not experiencing the issue anymore.

    To reproduce the issue:
    1. Install ClipMan (if it is not already installed)
    2. Install "Data Volume Report" and another headless app (Flip Hush for example as it is free and it seems that the bug is also triggered without buying the headless function (can not say for sure as I bought it, but it triggers without restoring this purchase))
    3. Open the other headless application (e.g. Flip Hush) (I think this step is not really required)
    4. Reboot the phone.

    I have performed my tests using the following headless apps: ClipMan, Flip Hush, Data Volume Report, SayIt and CallX.

    Cheers,

    Frank
    QtHelex likes this.
    01-09-14 08:32 AM
  17. QtHelex's Avatar
    Thanks Frank!

    Genius finding. I'll give you a big hug in case we're able to finally met in February at the hackathon in Frankfurt.

    I know the app "Data Volume Report" (only available for T-Mobile customers at Germany) well. It's my own!

    Sounds really strange. It works in case Data Volume Report is not installed?

    Sadly (or luckily) I'm currently unable to reproduce this on the official SDK built 10.2.1.1927 - so maybe at the 10.2.1.1925 leak was a issue if there are two or more headless apps per developer key installed. It's only 2 built numbers in between, but I have no idea what maybe have changed behind the curtains between the leak and the official developer built.

    I will risk now a global release of ClipMan 2.0.0 - Headless

    This glitch is maybe not worth to let the rest of the world wait any longer. The fallback mechanism will gurantee that ClipMan works at least like before in case someone is running a leaked 10.2.1.1925, has Data Volume Report and ClipMan installed and installs a additional headless app. I will try to flash at the weekend the 10.2.1.1925 leak at my Dev Alpha B. Maybe I'm able to reproduce it and find the root of the problem and fix it with the next update. Currently I have no idea because both apps are running in their own sandbox, absolutely separated. But I will doublecheck this.

    Thanks to all beta testers for participating. I will deactivate now the beta program for ClipMan. The official built with minor changes will get released as soon as the BlackBerry World testing team has approved the new version. In case you haven't purchased before I hope you learned to love ClipMan and the purchase won't hurt you in case you would like to benefit from all future updates.

    I hope you will enjoy ClipMan as it was designed from the beginning. As a service which works in the background to make your BlackBerry expirience even more enjoyable.


    EDIT: By the way, in case you would like to recomment ClipMan to others, vote here: ClipMan Clipboard Manager | CrackBerry.com
    Last edited by QtHelex; 01-09-14 at 03:54 PM. Reason: added the last sentence
    FF22 and BigBadWulf like this.
    01-09-14 02:29 PM
  18. just_luc's Avatar
    Hmm.. I just had the headless process for ClipMan crash for me for the first time. I'm not sure what caused it because I'm not sure when it happened. I just went to copy something and noticed I didn't get the LED, so I checked. Opening the app didn't even bring it back. It would copy while open, but to bring the headless process back I had to hard reset the device.

    Posted via CB10
    QtHelex likes this.
    01-09-14 10:32 PM
  19. QtHelex's Avatar
    Oh, well. I have in the meantime the suspicion that the detection if the headless module is running or not may crash it sometimes. I just asked at the supportforum of BlackBerry for a recommended solution and will rewrite this part during the weekend.
    I hope I were not too impatient and have not pushed the headless version to release too early.
    On the other side, there is anyway still no official 10.2.1, so some more hours to get this rocking solid.

    Oh, and I really hope you mean reboot, not hard-reset. Thanks a lot for your posting. I will take it to finally decide to rewrite it with a different approach.
    01-10-14 12:37 AM
  20. just_luc's Avatar
    Oh, and I really hope you mean reboot, not hard-reset. Thanks a lot for your posting. I will take it to finally decide to rewrite it with a different approach.
    No, I do in fact mean a hard reset. Volume keys up/down 30 seconds. I tried a soft reboot first and the module didn't reload.


    Posted via CB10
    01-10-14 07:45 AM
  21. BigBadWulf's Avatar
    Definite buy!
    Attached Thumbnails WANTED: Beta Testers for ClipMan - HEADLESS!-img_20140110_091138.png  
    QtHelex likes this.
    01-10-14 10:00 AM
  22. just_luc's Avatar
    Agreed, despite whatever is causing the occasional crash it's still a GREAT app and we'll worth the price of admission. I used it a lot before. But now that it's headless I use it ALL THE TIME. This functionality should be built in, but since it's not this app is a must have. And even if the headless does crash, it just reverts to the original functionality which is still pretty good.

    Everyone should buy it!

    Posted via CB10
    QtHelex and extisis like this.
    01-10-14 10:21 AM
  23. QtHelex's Avatar
    I had not a single crash over here for the whole week. But I'm running 10.2.1.176 and 10.2.1.1927, not 10.2.1.1925

    I found a different solution for the TCP/IP socket communication I'm using inside the headless module and what potentially causes the crash. And apart from the current "fallback" mechanism which returns to the old functinallity in case the headless module is not running I found even a way to start a not running headless module without rebooting as soon as ClipMan gets opened once. This also respects the application permission setting in case someone wouldn't like to let this app running always. But this only for the emergency case or if someone gives ClipMan the permission to run headless at some point without rebooting the device. It will just begin to work headless as soon as he opens ClipMan or just shares something to ClipMan.

    Anyway, as soon as I've replaced the whole TCP/IP thing the headless module will get rocking solid. I'm absolutely sure. The Version 2.1.0 of ClipMan (Headless) will arrive at the beginning of next week.
    01-10-14 01:32 PM
  24. just_luc's Avatar
    That sounds like the right move! good luck!

    Posted via CB10
    QtHelex likes this.
    01-10-14 01:38 PM
  25. FF22's Avatar
    I had not a single crash over here for the whole week. But I'm running 10.2.1.176 and 10.2.1.1927, not 10.2.1.1925
    I keyed in on that. What does it offer? More stability? And where is it found?

    I've only got one other headless running and so far no issues with crashing.
    01-10-14 03:36 PM
115 ... 2345

Similar Threads

  1. EasyGo for GoPro Hero : control your camera from BB10
    By C0rt0 in forum BlackBerry 10 Apps
    Replies: 8
    Last Post: 01-19-14, 10:34 PM
  2. Should BlackBerry make its own detachable keyboard for iphone?
    By Knightcrawler in forum General BlackBerry News, Discussion & Rumors
    Replies: 73
    Last Post: 01-19-14, 10:28 AM
  3. A closer look at Diaree for BlackBerry 10
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 01-03-14, 02:30 PM
LINK TO POST COPIED TO CLIPBOARD