1. FortressBB10's Avatar
    I was running a version of Signal on my Passport flawlessly. I had the dreaded antenna issue, so I've switched to a new Z30. (Wow, that Passport form factor really fits my hands. Switching to a candybar phone reminds me.)

    So now I can't find a version of Signal that will install and allow me to send messages. I tried the most recent version on Signal's website. (Link posted in the last Signal thread.) It seemed like it almost installed once or twice but gave up.

    I installed an older apk I had saved. It's version 4.23.4. It installs but I can't send messages. It even tells me to update or I won't be able to send messages.

    The version on my Passport that worked perfectly might be 4.36.2. This is the only thing I can find in settings under "debug." I presume this is the version. (Was it updating on its own?)

    Question: could this be an issue of the CPU not being fast enough on the Z30 to install? I think I had this problem on a Z10 before.

    Question: could I install an old version and try to update via Yalp? I'm not familiar with Yalp. I played around with it but couldn't figure out how to log in.

    Many thanks!
    11-06-19 10:32 AM
  2. conite's Avatar
    I was running a version of Signal on my Passport flawlessly. I had the dreaded antenna issue, so I've switched to a new Z30. (Wow, that Passport form factor really fits my hands. Switching to a candybar phone reminds me.)

    So now I can't find a version of Signal that will install and allow me to send messages. I tried the most recent version on Signal's website. (Link posted in the last Signal thread.) It seemed like it almost installed once or twice but gave up.

    I installed an older apk I had saved. It's version 4.23.4. It installs but I can't send messages. It even tells me to update or I won't be able to send messages.

    The version on my Passport that worked perfectly might be 4.36.2. This is the only thing I can find in settings under "debug." I presume this is the version. (Was it updating on its own?)

    Question: could this be an issue of the CPU not being fast enough on the Z30 to install? I think I had this problem on a Z10 before.

    Question: could I install an old version and try to update via Yalp? I'm not familiar with Yalp. I played around with it but couldn't figure out how to log in.

    Many thanks!
    There is no compatibility differences between BB10 devices - apart from some problems sometimes on 1:1 devices.

    If it works on the Passport, it will work on the Z30.

    Is it the same OS version?
    11-06-19 11:24 AM
  3. FortressBB10's Avatar
    There is no compatibility differences between BB10 devices - apart from some problems sometimes on 1:1 devices.

    If it works on the Passport, it will work on the Z30.

    Is it the same OS version?
    No, the latest version on the Signal website is newer. I thought they were keeping it generally compatible with the Amazon devices and other older android devices though. Maybe that is not true anymore.

    I guess I could try to dig up a version of 4.36.2. I do not understand why I cannot find it on my Passport somewhere like in the downloads folder. This is why I think maybe it was updating on my phone. Maybe I started with an older apk and it updated.

    Is this possible if I am not running the play store? I have Yalp on both phones but have no idea what to do with it.

    I'm pretty sure I had apk's that I could run on the Passport that the Z10 would not even install. I could tell the processor wasn't able to run whatever emulation is going on. Did no one else ever notice this?

    Thanks.
    11-06-19 06:39 PM
  4. conite's Avatar
    No, the latest version on the Signal website is newer. I thought they were keeping it generally compatible with the Amazon devices and other older android devices though. Maybe that is not true anymore.

    I guess I could try to dig up a version of 4.36.2. I do not understand why I cannot find it on my Passport somewhere like in the downloads folder. This is why I think maybe it was updating on my phone. Maybe I started with an older apk and it updated.

    Is this possible if I am not running the play store? I have Yalp on both phones but have no idea what to do with it.

    I'm pretty sure I had apk's that I could run on the Passport that the Z10 would not even install. I could tell the processor wasn't able to run whatever emulation is going on. Did no one else ever notice this?

    Thanks.
    I was asking if you're running the same OS on your two BB10 devices.
    11-06-19 06:41 PM
  5. FortressBB10's Avatar
    There is no compatibility differences between BB10 devices - apart from some problems sometimes on 1:1 devices.

    If it works on the Passport, it will work on the Z30.

    Is it the same OS version?
    https://signal.org/android/apk/

    That is the link that was posted in the other thread titled "good experience with signal app" or something along those lines. It has version 4.49.16. I suppose that is the most recent version.
    11-06-19 06:42 PM
  6. FortressBB10's Avatar
    I was asking if you're running the same OS on your two BB10 devices.
    Sorry. Yes, it is the most recent BB 10 version. I am pretty sure I ran autoloaders for both of them.
    11-06-19 06:43 PM
  7. conite's Avatar
    Sorry. Yes, it is the most recent BB 10 version. I am pretty sure I ran autoloaders for both of them.
    So, you're certain they are both 10.3.3 ?
    11-06-19 06:43 PM
  8. FortressBB10's Avatar
    So, you're certain they are both 10.3.3 ?
    Yes. But keep in mind that the version on the Passport that works is not one that I have available right now. I have the one that is listed on the official website which appears to be newer. Than I have an older one that installs but will not run because it is outdated.
    11-06-19 07:37 PM
  9. conite's Avatar
    Yes. But keep in mind that the version on the Passport that works is not one that I have available right now. I have the one that is listed on the official website which appears to be newer. Than I have an older one that installs but will not run because it is outdated.
    https://www.apkmirror.com/apk/signal...-apk-download/
    11-06-19 07:40 PM
  10. FortressBB10's Avatar
    Thanks! That must be apk I installed on the Passport. I will have to reluctantly install an apk not directly from Signal. But don't have much choice.

    I'll let you know how it turns out! Can't work on it tonight but tomorrow. Thanks again.
    11-06-19 08:09 PM
  11. conite's Avatar
    Thanks! That must be apk I installed on the Passport. I will have to reluctantly install an apk not directly from Signal. But don't have much choice.

    I'll let you know how it turns out! Can't work on it tonight but tomorrow. Thanks again.
    Apkmirror is extremely safe. Android Police runs it, and they have a very strict vetting policy.
    FortressBB10 likes this.
    11-06-19 08:10 PM
  12. FortressBB10's Avatar
    Thanks, Conite! That version is the right blend of new and old enough to work on Android 4.1. Anyone wanting to run Signal -- which is awesome -- I recommend this version. There is a notification at the top that there is a newer version available, so you just have to ignore that. Not a big deal.
    11-07-19 03:10 PM

Similar Threads

  1. Landing folder when attaching images to email in BB Hub
    By zlatko23 in forum BlackBerry KEY2
    Replies: 5
    Last Post: 11-08-19, 01:05 PM
  2. ACF301 2019-11-06 07:54.59 CET KEYone BBB100-1
    By rolfep in forum BlackBerry KEYone
    Replies: 1
    Last Post: 11-06-19, 10:34 AM
  3. BlackBerry Hub+ beta apps updated with bug fixes
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 11-05-19, 06:40 PM
  4. How to get paid apps again?
    By tomkranz in forum PlayBook Apps & Games
    Replies: 7
    Last Post: 11-05-19, 03:16 PM
  5. Wallapop app for BlackBerry 10?
    By gonstax in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 11-05-19, 11:01 AM
LINK TO POST COPIED TO CLIPBOARD