1. Damatrix02's Avatar
    Anyone know of a good port forwarder? I have an network of computers all using RDP(3389) but none are external except for my SSH port (5900).

    In Putty I forward/tunnel through 5900, assign a random port, and get to 3389.

    Each port assigned to a different ip.

    I tried BBconnect which works flawlessly for the SSH/KEYS/CONNECTION portion but port forwarding is a flop.

    Any other progs out there?

    Thanks,
    02-26-13 08:41 AM
  2. lcohen999's Avatar
    Try Telnet/SSH in Appworld

    It is basically a port of Putty

    https://appworld.blackberry.com/webstore/content/64401/
    02-26-13 09:09 AM
  3. Damatrix02's Avatar
    Do you have it on the z10,

    No trial so can you confirm the port forwarding works?
    02-26-13 09:35 AM
  4. Produktyf's Avatar
    It works. I established ssh session to my home server (over mobile network with my wifi off) using Telnet/SSH (which as Icohen999 pointed is a solid Putty port which I did not need to re-purchase - I already had it purchased for my PlayBook). I then setup port forwarding to forward port 5555 to remote server (server.domain.local:3389). Launched RDP+ Enterprise and connected to localhost:5555 which connected to my server at home. Never mind though that RDP session on such a small screen is almost unworkable without some sort of more precise pointing device... But it works!
    HedoBum likes this.
    02-26-13 10:37 AM
  5. Damatrix02's Avatar
    Awesome amazing support,

    Thanks man!
    02-26-13 12:03 PM
  6. Snake785's Avatar
    It works. I established ssh session to my home server (over mobile network with my wifi off) using Telnet/SSH (which as Icohen999 pointed is a solid Putty port which I did not need to re-purchase - I already had it purchased for my PlayBook). I then setup port forwarding to forward port 5555 to remote server (server.domain.local:3389). Launched RDP+ Enterprise and connected to localhost:5555 which connected to my server at home. Never mind though that RDP session on such a small screen is almost unworkable without some sort of more precise pointing device... But it works!
    I haven't been successful with port forwarding. I also have Telnet/SSH for the Playbook and port forwarding works there. The configuration I'm using is the same as on my PlayBook as well so I'm not sure why it's not working for me.

    Are there any special settings you've checked when configuring your port forwarding? I might be missing some setting that needs to be set only on the Z10.
    02-27-13 09:19 AM
  7. Damatrix02's Avatar
    The developer got back to me:

    Hello Mike,
    Thank you for your interest to this application.

    Port forwarding and key based authentication is supported by Telnet/SSH application. It successfully used by many customers on PlayBook platform. I believe it was even mentioned in reviews.

    However BB10 Z10 phones have a newer version of QT library (user
    interface) which introduce a bug which prevents port forwarding from working. Key based auth works fine. I'm working right now on resolving this issue. I'll let you know as soon as it'll be fixed.

    Regards,
    Dmytro
    Snake785 likes this.
    02-27-13 12:01 PM
  8. Produktyf's Avatar
    This is REALLY odd because it worked for me!
    02-27-13 12:32 PM
  9. Damatrix02's Avatar
    Dev Alpha? Or full Z10-- there might be some core library differences between the two. I know that the hardware isn't 100% the same either. But with no trial/free version I had no option but to email the dev and ask. Just relaying the message.
    02-27-13 06:02 PM
  10. Damatrix02's Avatar
    Just for anyone wondering in the future, the update fixed the bSSH free I was using.

    Port forward is now confirmed working.
    03-01-13 08:24 AM
  11. Snake785's Avatar
    This is REALLY odd because it worked for me!
    We're you on Wifi when it was working? I've been successful using it over Wifi but not over the carrier network

    Posted via CB10
    03-01-13 03:26 PM
  12. Omnitech's Avatar
    We're you on Wifi when it was working? I've been successful using it over Wifi but not over the carrier network
    Rogers could be selectively blocking protocols or some other networking blunder.

    When the Z10 first rolled-out, IMAP IDLE or some other sync protocol wasn't working on Rogers either, they eventually sorted that out within a few days after launch.
    03-01-13 06:53 PM
  13. Snake785's Avatar
    If that was the case, then I wouldn't be able to connect to any SSH server at all. A prerequisite for ssh port forwarding is an active ssh session. Once the ssh session is active, Rogers can't tell that you are using port forwarding because it would appear as normal encrypted ssh traffic.

    Besides, when I had my bold 9900, I would tether it with my Playbook and port forwarding worked. I haven't changed my data plan when I upgraded to the Z10 either.



    Posted via CB10
    03-01-13 08:20 PM
  14. Damatrix02's Avatar
    Both WiFi and carrier traffic port forwarding confirmed.

    Snake is right. After you open the SSH connection all ports are then tunneled through that port. And the ISP cant de-crypt the traffic without using your private key used in the session.
    03-02-13 10:41 AM
  15. Omnitech's Avatar
    I wasn't suggesting that they could have been decrypting the traffic, I was suggesting that they could have been either blocking it or doing something dumb that breaks it. (like using some sort of proxy server that breaks it)

    IMAP IDLE for example requires a long time persistent open TCP connection, and many firewalls and NAT devices break it because they close the open session before the client has a chance to issue another keepalive packet to keep it open. I don't know what Rogers was doing that was breaking it, but they resolved it within a few days of launch. They could have had an element somewhere in their network that was not holding the TCP sessions open long enough.

    In this case for example, they could be blocking port 5900 or something. If you're already using that port for regular SSH sessions, obviously that's not the issue. In general, I tend not to make assumptions about whether or not carriers do traffic blocking of one form or another.
    03-02-13 10:00 PM

Similar Threads

  1. Port Forwarding with PDAnet/Tethering software?
    By loper324 in forum BlackBerry Style 9670
    Replies: 0
    Last Post: 11-27-11, 08:57 AM
  2. Need to Forward Ports for BPS?
    By cray1000 in forum BlackBerry Administrators
    Replies: 5
    Last Post: 12-14-08, 05:46 AM
  3. Port Forwarding with Tethered 8330
    By TFLogic in forum BlackBerry Curve 83xx
    Replies: 2
    Last Post: 06-09-08, 01:30 PM
  4. Forwarding emails to your BlackBerry's email address...
    By naviwilliams in forum General BlackBerry Discussion
    Replies: 5
    Last Post: 01-15-08, 02:11 AM
  5. Porting a phone number(s)...
    By naviwilliams in forum Rehab & Off-Topic Lounge
    Replies: 6
    Last Post: 03-25-07, 02:38 PM
LINK TO POST COPIED TO CLIPBOARD