Home CrackBerry Q&A > BlackBerry 10 Apps

How to install WhatsApp on Passport?

Asked: Oct 02 2019 | 9:47 am EDT 1850 Views 32 Answers

Hello to everyone,

I'm a new in the blackberry world,because some days ago I bought the passport. The first thing that I did has been to install the google play store following this guide :

https://sideloadplaystore.com/instal...blackberry-10/

and then I went on the playstore and I've installed whatsapp,version : 2.19.258.

the problem is that it does not work,telling that the google play services are not supported by my device. How can I fix this error ?


More Answers

28,511
Oct 02 2019 | 1:01 pm EDT Bla1ze

How can I fix this error ?
You don't really. Uninstall that version and download it from WhatsApp directly. Android. When it says that, tap outside the box and it will mostly work fine.
44,832
Oct 02 2019 | 1:08 pm EDT conite

Hello to everyone,

I'm a new in the blackberry world,because some days ago I bought the passport. The first thing that I did has been to install the google play store following this guide :

https://sideloadplaystore.com/instal...blackberry-10/

and then I went on the playstore and I've installed whatsapp,version : 2.19.258.

the problem is that it does not work,telling that the google play services are not supported by my device. How can I fix this error ?
You can also remove all of that Cobalt stuff and simply replace it with Yalp:

https://f-droid.org/repo/com.github....lpstore_46.apk
10
Oct 02 2019 | 1:46 pm EDT marietto2008

can u show me how to remove the cobalt stuff ? thanks.
44,832
Oct 02 2019 | 4:42 pm EDT conite

can u show me how to remove the cobalt stuff ? thanks.
Just delete the Cobalt apps you installed - same as you would any other app.
10
Oct 02 2019 | 4:55 pm EDT marietto2008

I don't know if I remove the right apps. For example between the apps I see something like this : 1) account google 2) blackberry google ID 3) google settings. Are these the apps that I should remove ?
44,832
Oct 02 2019 | 6:33 pm EDT conite

I don't know if I remove the right apps. For example between the apps I see something like this : 1) account google 2) blackberry google ID 3) google settings. Are these the apps that I should remove ?
Yes.
10
Oct 03 2019 | 7:55 am EDT marietto2008

what's the trick here ? why whatsapp works great even without the cobalt stuff ? is yalp which contains the necessary libraries to make it works ? or some other component ?
44,832
Oct 03 2019 | 8:15 am EDT conite

what's the trick here ? why whatsapp works great even without the cobalt stuff ? is yalp which contains the necessary libraries to make it works ? or some other component ?
No, Yalp is just a simple Play Store client.

WhatsApp works fine by itself.
10
Oct 06 2019 | 4:27 pm EDT marietto2008

Hello. I have a lot of apps that are installed on the android phone that I want to transfer in the passport. what's the method ? how can I install the apps directly on the passport ?
15,478
Oct 06 2019 | 4:44 pm EDT Chuck Finley69

Hello. I have a lot of apps that are installed on the android phone that I want to transfer in the passport. what's the method ? how can I install the apps directly on the passport ?
Unfortunately, the answer is just no. Except for when the answer is also no.

Use Yalp for installing apps you absolutely need if there’s not any native BB10 app currently or ever available.

Keep in mind you’re running BB10 OS hardware. It’s not meant to be Android replacement. The Android version is stuck on 4.3 Jellybean and installing or running too many could actually result in hardware problems from overheating.
2,383
Oct 07 2019 | 7:35 pm EDT TrumpetTiger

Hello. I have a lot of apps that are installed on the android phone that I want to transfer in the passport. what's the method ? how can I install the apps directly on the passport ?
Hey marietto,

You can't transfer these apps directly to the Passport, but you can install them on the Passport itself in many cases. Do you have a lot of Android games or just apps mainly?

However, it's important to note that as Chuck says the Passport is NOT an Android phone. It runs Blackberry 10, an OS that provides a very smooth experience for native apps but which has limited Android compatibility. If you want an Android phone you may not want the Passport, but if you're wanting a security and privacy-based phone that can also run some Android apps it's definitely a solid device.
15,478
Oct 07 2019 | 7:46 pm EDT Chuck Finley69

Hey marietto,

You can't transfer these apps directly to the Passport, but you can install them on the Passport itself in many cases. Do you have a lot of Android games or just apps mainly?

However, it's important to note that as Chuck says the Passport is NOT an Android phone. It runs Blackberry 10, an OS that provides a very smooth experience for native apps but which has limited Android compatibility. If you want an Android phone you may not want the Passport, but if you're wanting a security and privacy-based phone that can also run some Android apps it's definitely a solid device.
I forgot we had some actual serious threads going on here. We’re have too much fun...
2,383
Oct 07 2019 | 7:47 pm EDT TrumpetTiger

I forgot we had some actual serious threads going on here. We’re have too much fun...
It's sometimes easy to get lost in the back-and-forth among the frequent posters here. The more fun the better, I say....
10
Oct 08 2019 | 4:36 am EDT marietto2008

oh come on boys. who of us don't want everything ? I'm not the only one who wants a full BB and Android experience ? don't blame me for this. I know that the android emulation is old,but I hope that most of the apps that I want can run on my passport. And I don't care if they can run natively or with the emulation. I care only that they work. These are the apps that I really need : 1) adblock 2) microsoft authenticator 3) automate 4) ho. mobile manager 5) kasa 6) lettera senza busta 7) new pipe 8) rapido screenshot (or any other equivalent) 9) shazam 10) vlc 11) textra...
15,478
Oct 08 2019 | 8:22 am EDT Chuck Finley69

oh come on boys. who of us don't want everything ? I'm not the only one who wants a full BB and Android experience ? don't blame me for this. I know that the android emulation is old,but I hope that most of the apps that I want can run on my passport. And I don't care if they can run natively or with the emulation. I care only that they work. These are the apps that I really need : 1) adblock 2) microsoft authenticator 3) automate 4) ho. mobile manager 5) kasa 6) lettera senza busta 7) new pipe 8) rapido screenshot (or any other equivalent) 9) shazam 10) vlc 11) textra...
You won’t find a more zealous BB10 proponent than Mister TrumpetTiger and few others as well. It’s stuck on ART 4.3 while many apps require ART 4.4 or even higher nowadays. Perhaps TT can help some but his earlier reply suggested initial realities in 2019 for many reasons.
3,154
Oct 08 2019 | 8:25 am EDT The_Passporter

oh come on boys. who of us don't want everything ? I'm not the only one who wants a full BB and Android experience ? don't blame me for this. I know that the android emulation is old,but I hope that most of the apps that I want can run on my passport. And I don't care if they can run natively or with the emulation. I care only that they work. These are the apps that I really need : 1) adblock 2) microsoft authenticator 3) automate 4) ho. mobile manager 5) kasa 6) lettera senza busta 7) new pipe 8) rapido screenshot (or any other equivalent) 9) shazam 10) vlc 11) textra...
I think your (APK) app appetite may need to be placed on a leaner diet and I'm not sure all those are able to work or needed.
I think best thing to do is enjoy and explore what BB10 does well and then decide what is absolutely needed for addons
Example: textra and rapido screenshot are definitely not needed.

Instead of NewPipe I use Videoder (version videoder_v14.1)

Blackberry World has an authentication app.
http://appworld.blackberry.com/webst...ntent/29401059

Hammered out on my Precious Passport
10
Oct 08 2019 | 10:26 am EDT marietto2008

I checked and I can use youtube via Firefox browser. It plays in background. not needed new pipe anymore. -1 :P. I haven't a big appetite,man. I can survive with a few apps. I love the passport too much and I accept it for what it can give me. But try to understand that I'm new in this world. Until yesterday I used android...for shazam I can use SoundHound. what about a ads blocks ? it is important to avoid the invasion of the ads...
44,832
Oct 08 2019 | 10:53 am EDT conite

I checked and I can use youtube via Firefox browser. It plays in background. not needed new pipe anymore. -1 :P. I haven't a big appetite,man. I can survive with a few apps. I love the passport too much and I accept it for what it can give me. But try to understand that I'm new in this world. Until yesterday I used android...for shazam I can use SoundHound. what about a ads blocks ? it is important to avoid the invasion of the ads...
Nothing you can do about ads, at least from a system-wide point of view.

You can use ad-blocking browsers though.

Unfortunately you can't block trackers at all in BB10 as you can with Android.
3,154
Oct 08 2019 | 11:00 am EDT The_Passporter

I checked and I can use youtube via Firefox browser. It plays in background. not needed new pipe anymore. -1 :P. I haven't a big appetite,man. I can survive with a few apps. I love the passport too much and I accept it for what it can give me. But try to understand that I'm new in this world. Until yesterday I used android...for shazam I can use SoundHound. what about a ads blocks ? it is important to avoid the invasion of the ads...
I use Shazam also and if you have a problem I can let you know what version I'm using
7,189
Oct 08 2019 | 11:08 am EDT brookie229

I checked and I can use youtube via Firefox browser. It plays in background. not needed new pipe anymore. -1 :P. I haven't a big appetite,man. I can survive with a few apps. I love the passport too much and I accept it for what it can give me. But try to understand that I'm new in this world. Until yesterday I used android...for shazam I can use SoundHound. what about a ads blocks ? it is important to avoid the invasion of the ads...
NewPipe (legacy version) works fine on the Passport.
5
Oct 27 2019 | 4:48 am EDT bbuser2019

Many apps do not show up on my google play store. When I look up on priv, I can see them. For eg. I simply cannot see meercat app. My husband could see it on his iphone. I could see it on my priv. I cannot see it on my passport. It is the case of many apps.

I see above a suggestion of removing cobalt. I had downloaded something like that from this forum years ago. I don't know how to remove them. I don't even know where to look for it. Would you be able to help me using screenshots please because I am simply don't understand how all this works. Sorry for sounding difficult. Thanks in advance for any advise to help me fix these problems.

ps: my blackberry passport version is 10.3.3.2137. It is updated as far as I know.
5
Oct 27 2019 | 4:58 am EDT bbuser2019

I posted for an advise here. I cannot find it!
20
Oct 27 2019 | 8:39 am EDT MeMeCe

Passport has very old Android version 4.3 and there is no way to upgrade it. Any app demanding newer version of Android does not show in play store, because it is not able to install/run on Passport.

Posted via CB10
5
Oct 27 2019 | 12:18 pm EDT bbuser2019

I cannot upload image


How do I do this please, thanks

It looks like this thread has reached a dead end with no help!

do I start a new thread. I really would have liked some guidance on fixing app issues.

I have downloaded this thing called yalp.

When I clicked to update google play services, it said that there was a conflict and that I had to uninstall an existing one (presumably downloaded one from cobalt). HOwever I don't know if other apps like watsapp and my two to one rail card etc would be affected

I am fed up of my phone not allowing me much needed apps. Either they are not seen on playstore or that they are dysfunctional.

Why is the images upload button not working on this forum?!!
2,670
Oct 28 2019 | 9:01 am EDT emanuel0ss0

I cannot upload image


How do I do this please, thanks

It looks like this thread has reached a dead end with no help!

do I start a new thread. I really would have liked some guidance on fixing app issues.

I have downloaded this thing called yalp.

When I clicked to update google play services, it said that there was a conflict and that I had to uninstall an existing one (presumably downloaded one from cobalt). HOwever I don't know if other apps like watsapp and my two to one rail card etc would be affected

I am fed up of my phone not allowing me much needed apps. Either they are not seen on playstore or that they are dysfunctional.

Why is the images upload button not working on this forum?!!
if I'm not mistaken, uploading images on CB10 has been broken for some time.

If you are that fed up with your phone, just get a new one. No sense in taking out your frustration on users of Crackberry. This is a fan site, not a help desk where you can demand help or service.



Posted via my Awesome Passport SE SQW100-4/10.3.3.2163 pin:2C33423A
1,242
Oct 28 2019 | 9:11 am EDT Ben xfg

Many apps do not show up on my google play store. When I look up on priv, I can see them. For eg. I simply cannot see meercat app. My husband could see it on his iphone. I could see it on my priv. I cannot see it on my passport. It is the case of many apps.

I see above a suggestion of removing cobalt. I had downloaded something like that from this forum years ago. I don't know how to remove them. I don't even know where to look for it. Would you be able to help me using screenshots please because I am simply don't understand how all this works. Sorry for sounding difficult. Thanks in advance for any advise to help me fix these problems.
This is an old device that is running an antique runtime (4.3), if you can't run the apps that you need you may want to look at a newer, more up-to-date device.
However, let us know which apps you need, and we may be able to find older working versions.

ps: my blackberry passport version is 10.3.3.2137. It is updated as far as I know.
That is the latest, yes.

" You can also remove all of that Cobalt stuff and simply replace it with Yalp:

https://f-droid.org/repo/com.github....lpstore_46.apk "


1. will this help
2. should i remove all cobalt downloads
I'm afraid this won't help very much with your apps problem, but like I said, let us know which apps you need and there's a chance there are older versions that will still work.


Posted via CB10
1,242
Oct 28 2019 | 9:59 am EDT Ben xfg


do I start a new thread. I really would have liked some guidance on fixing app issues.
Very good idea.

Why is the images upload button not working on this forum?!!
The CB10 app upload function is broken and won't be fixed. Use the browser to upload photos.

Posted via CB10
5
Oct 28 2019 | 3:50 pm EDT bbuser2019

demand help or service.
I haven't done either. I can't help it if it were your interpretation. And this is not just a fan site. it would have survived only as long as blackberry has if it were one! This is more than a fan site. If you can't help or share the frustration may be you shouldn't have responded. You have anger management issues.
You are the weakest link. Good Bye! Lol
44,832
Oct 28 2019 | 4:44 pm EDT conite

I cannot upload image


How do I do this please, thanks

It looks like this thread has reached a dead end with no help!

do I start a new thread. I really would have liked some guidance on fixing app issues.

I have downloaded this thing called yalp.

When I clicked to update google play services, it said that there was a conflict and that I had to uninstall an existing one (presumably downloaded one from cobalt). HOwever I don't know if other apps like watsapp and my two to one rail card etc would be affected

I am fed up of my phone not allowing me much needed apps. Either they are not seen on playstore or that they are dysfunctional.

Why is the images upload button not working on this forum?!!
You can't download the normal Google Play Services on a BB10 device.

The only version that will run is a specially modified one by Cobalt - but it is so old now that it barely works.

Try to satisfy yourself with the apps from the Play Store that you get through Yalp. Apart from those, you can try the Amazon Appstore, or root around other 3rd party stores for some older, deprecated, and insecure versions.
3,154
Oct 31 2019 | 1:27 pm EDT The_Passporter

I cannot upload image

Why is the images upload button not working on this forum?!!
You can download the CB Forums APK and it will allow you to upload pictures.

How to install WhatsApp on Passport?-img_20191031_132252.png