1. ddsixty's Avatar
    I put it in the last two nights at 100% and in the morning i'm at 40%

    the only thing i can think of is twitter, but i've always had twitter set the same with other phones (curves) and it's never happened.

    only difference is that i'm not using Ubrertwitter, i'm using the preloaded twitter that came on the phone.

    can anyone help...this is brutal.
    06-07-10 07:44 AM
  2. anon(368121)'s Avatar
    Putting it in the case only shuts down the LCD backlight and changes some alert behaviors . . . it doesn't prevent the BB from communicating with the BIS and BES (if you're Enterprise Activated) servers. If you want to minimize battery consumption, turn off the radio (Wi-Fi too).

    Most of us are conditioned to put the Blackberry on the charger overnight.
    06-07-10 07:56 AM
  3. ddsixty's Avatar
    is this much more drastic than with the curve? it's never been an issue in the past when i have no activity overnight and the phone is in the case it drains 60% in 6-7 hrs? Thats not cool.

    I used to charge overnight as well, but it's been interfering with the baby monitors so i stopped. Like i said was never an issue to this extent, something is definitely different
    06-07-10 08:03 AM
  4. tommynap01's Avatar
    u have to be running some programs in the background . theres no reason why it would drain that much. i charge my battery fully and then take it off the charge when i go to sleep and when i wake up i have it around 95 percent or so
    06-07-10 08:09 AM
  5. eve6er69's Avatar
    Yeah that's way more drain than usual. Try pulling your battery right before you go to be to assure all of of your apps have been shut down.

    I don't know if it the processor or what but I know we have the S2 processor in our phones and my buddy was complaining to me about the same thing on his storm. He would be at 60% and hos phone would be in his pocket in the pouch so its in standby and he would pull it out a few hrs later and it would close to dead.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-07-10 08:16 AM
  6. world saviour's Avatar
    If you are new verizon users remember battery life get better with usage. My 9650 with sprint did the same thing now after half a day (usually 3pm with moderate usage) I have about 70% battery left. I make sure I close anything I have opened that I don't want still running and still forget sometimes.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-07-10 09:48 AM
  7. AndrewB55's Avatar
    Do you have WiFi running? I think by default WiFi was automatically running, and I know that can drain the battery as well.
    06-07-10 10:07 AM
  8. cbreze's Avatar
    Yes, I noticed my wifi was running by default from out of the box. Once I figured this out I disable and run as needed.
    06-07-10 10:47 AM
  9. ddsixty's Avatar
    Do you have WiFi running? I think by default WiFi was automatically running, and I know that can drain the battery as well.
    I noticed that also, although I turned it off.

    I noticed that I had Bloomberg opened on a webpage in Bolt so i closed that...didn't matter. Noticed i had a page open in Opera....closed them all...didn't matter.

    Cant figure this out. I just charged to 100% several times, put in the case and 10 minutes later it's at 90%. So weird.
    06-07-10 11:18 AM
  10. Monty2004's Avatar
    How do I turn off WIFI when I'm away frm my house?
    06-07-10 01:29 PM
  11. AndrewB55's Avatar
    Just go in the "Manage Connections" area and uncheck the WiFi Box. As far as I can see, thats the only way to make sure it wont be draining your battery when you aren't using it.
    06-07-10 01:42 PM
  12. SevereDeceit's Avatar
    With this device, if you have a poor signal, it will keep polling for one and will severely drain the battery. Also, check to see how often you have Twitter "Poll" for tweets, default is 3 or 5 minutes, that will definitley murder your battery...
    06-07-10 01:48 PM
  13. HeroBerry's Avatar
    Your battery on the 9650 is going to drain much faster than on your curve regardless of what you do. This is just the trade off with having a nicer screen and a more powerful processor.

    It is probably best practice to get used to charging your blackberry every night. It's good to keep these batteries topped off anyway rather than draining them completely.
    06-07-10 02:22 PM
  14. eve6er69's Avatar
    I noticed that also, although I turned it off.

    I noticed that I had Bloomberg opened on a webpage in Bolt so i closed that...didn't matter. Noticed i had a page open in Opera....closed them all...didn't matter.

    Cant figure this out. I just charged to 100% several times, put in the case and 10 minutes later it's at 90%. So weird.
    try going to settings>mobile network and set it from global to 1XEV.
    06-07-10 09:33 PM
  15. anon(368121)'s Avatar
    You don't have a GPS-enabled application such as Google Maps running, do you? Hold down the Menu key for a couple of seconds and scroll through the running apps to see what's there.

    GPS can reduce battery life, and if you're using an app like GMM, it's constantly fetching map updates from the wireless network as you move around . . . which further reduces battery life.
    06-07-10 09:49 PM
LINK TO POST COPIED TO CLIPBOARD