1. wiBBred's Avatar
    Anybody outhere that has used or currently uses this device? If so what are your thoughts?

    10-20-09 08:12 AM
  2. stu9876's Avatar
    I have had the speaker paired to my tour for about 6 weeks, overall very similar to the Jabra model for in-car. It is a solid device, very dependable, with good battery life.
    10-20-09 08:34 AM
  3. dzarambo's Avatar
    I've had my VM-605 for four days now. Easy 'out of the box' pairing to my Pearl Flip. Easy to understand controls if you read the User Guide. Sound quality very good in either phone mode or playing music over my car radio and with it's built-in speaker. In the area I am living there are a lot of radio stations so there aren't many open frequencies but it is easy to change the frequency matching on the fly and even overrides some crossover noise. I like the slim design, I took off the wire clip and placed velcro hook on the back so it mounts nice and out of the way on the headliner of my car. I'd definitely recommend this.
    10-26-09 07:52 PM
  4. mjbesen310's Avatar
    I have one for my Tour. I like it, does what its suppose to do without a hicup.
    10-26-09 09:57 PM
  5. kingbernie06511's Avatar
    I have an issue with mine, somehow when playing music through the Visor mount to my car stero the song pauses for a second every minute or so. It gets annoying. I updated my blackberry's OS two times with a different version, always same thing. My gf's iphone doesnt have that issue, so i think my phone is the issue, not the BB visor mount. any thoughts?
    12-14-09 03:00 PM
  6. YJGUY's Avatar
    Can you pair two phones to this one? I know one of the Jabra models does this and that's the key feature for me.

    Thanks
    12-17-09 07:55 PM
  7. dzarambo's Avatar
    I have an issue with mine, somehow when playing music through the Visor mount to my car stero the song pauses for a second every minute or so. It gets annoying. I updated my blackberry's OS two times with a different version, always same thing. My gf's iphone doesnt have that issue, so i think my phone is the issue, not the BB visor mount. any thoughts?
    I just experienced this issue last week for the first time. When the charge on the battery of the VM-605 gets low it cuts out at regular intervals to let you know the battery needs charging. Once I connected it to the power supply it worked just fine.
    12-28-09 04:52 PM
  8. Lizard10's Avatar
    I would also like to know if it is possible to connect two phones. Any suggestions would be great!
    Thanks
    12-28-09 08:17 PM
  9. brighton405's Avatar
    I have been having issues recently with my VM-605 unit.

    When i place a call from my phone the device automatically says "Disconnected" but then connects the call.

    The front panel when pressed does not allow me to end a call, redial a number, etc.

    There is nothing in the user manual about troubleshooting these type of issues....

    any suggestions?

    Thanks
    03-02-10 06:58 PM
  10. 4cedars's Avatar
    I've had mine for 2-3 weeks and am very pleased, easy set up, no hicups. Does anyone know if it is possible to have the VZ Nav directions fed through the speakerphone?
    03-04-10 01:52 PM
LINK TO POST COPIED TO CLIPBOARD