1. websun's Avatar
    Hello I just changed the whole case with an oem white one for my gf.
    Appearsto work fine however after replacing it it seems like the unlock button doesn't work anymore... but it works for a few hours and then suddenly stops working. An battery pull fixes it...
    Also there is something strange about this, the red button doesn't work either when the unlock one fails. The click sound is ok.
    The case cam with an middle part of the phone, I switched that to the original one so now only the keyboard, back cover and front cover is new.
    The problem still persists, I have no idea what to try anymore, anyone ever seen this issue?
    12-23-11 03:13 AM
  2. jonmark's Avatar
    Usually prior to installing a new bezel, you have to be sure the metal tabs are installed in the new bezel for the lock and mute buttons. Some bezels come with it already pre-installed, which makes it easy and you don't have to worry about it, but the cheaper ones (usually the ones from overseas) will require the user kinda sauter or move those little tabs over to ensure that the buttons will work once installed. Also, some bezels don't have the tabs for the top part melted on, which will result in a loosely installed bezel, and will make the contact of the button weak and almost not work. Here is a picture to compare what it would look like with and without the metal tabs on the inside of the top part of the bezel ...
    12-23-11 05:19 PM
  3. websun's Avatar
    Hello, I can confirm those metal bezels are present. I still don't get it how that button WORKS for locking but doesn't work for unlocking since it's the same button.
    Also I cannot understand what does the red reject key have to do with this.
    12-24-11 02:46 AM
  4. jonmark's Avatar
    It may just be that the new housing isn't *exactly* the right fit for the phone. They may have been off on their measurements and for some reason it being just a little bit off is causing the buttons to not connect completely. Have you tried installing the old/original housing back on it and seeing if it works again? If so, it's definitely a malfunction with the new housing and not the phone. Maybe try to mix it up, try the old keyboard with the new housing and vice versa, just to eliminate some ideas.
    12-24-11 03:28 AM
LINK TO POST COPIED TO CLIPBOARD