11-27-09 12:48 PM
26 12
tools
  1. jbarrington's Avatar
    I have a new BB Storm, and I have no problems charging it from the OEM wall charger or from a USB data cable connected to my computer. I have a few additional chargers that are for different devices that have the same micro USB connector that I wanted to use in different locations, such as work. The only problem is that these other chargers will not charge my phone for some reason. At first, I thought I had a bad charger, but I found this was not the case. The next thing I decided to do was use my USB data cable and a special wall charger that will charge a device using the data cable, but that will not charge either. I did check to see if the amps were the same, and they meet or exceed the rating, so that should not be the issue. I cant help but feel the BB knows when it is connected to an official OEM charger or a computer. Has anyone else experience this, or is there something else happening?
    11-08-09 10:53 AM
  2. amavit's Avatar
    Are you sure they're producing enough current to charge your phone?
    11-08-09 11:02 AM
  3. jbarrington's Avatar
    Thanks for replying.
    The current specs on each of the non-OEM chargers meet or exceed the current specs on the OEM BB-S1 charger.

    So far, I've tried two different non-OEM chargers and neither worked.

    Next, I tried two other non-OEM chargers that were designed for USB data cables. I tried them with two different data cables in case a data cable or charger was bad.

    All total that's testing it with six different charging configurations.

    I do nothing different with connecting these non-OEM chargers than I do with my normal OEM charger. Each time the OEM charger is the only thing that will charge the BB-S1 (not counting when it's connected to my computer with a data cable).

    Oh, the wife has a BB-S1 too, and it's the same issue with hers.

    Everything almost indicates that it can tell the difference with OEM and nno-OEM chargers.
    11-08-09 11:17 AM
  4. Tim Casey's Avatar
    I have two electric wall chargers and a car charger along with the usb cable that i've used for charger my Storm. Ever since the last os update 5.0.0.328 none of the chargers except for the usb cable will charge the Storm and then only when the computer is turned on.

    This is very frustrating since i'm a heavey user on my phone and need to plug it in a lot while i'm driving to keep the charge up.

    When i plug the phone into one of the other chargers now i get the message "the charging source connected to you blackberry device cannot charge you battery."

    I've never had a problem using these other charges before. Does anyone have a suggestion as to what's the problem? Thanks, Tim
    11-08-09 12:16 PM
  5. WhoolioPreludee's Avatar
    Make sure they are strong enough. I think the storm charger is a 700mah

    Posted from my CrackBerry at wapforums.crackberry.com
    11-08-09 12:49 PM
  6. michaelbsc's Avatar

    Everything almost indicates that it can tell the difference with OEM and nno-OEM chargers.
    I tried two, not six, but you are correct. It won't work. Nor can I sync the phone with a non OEM usb cable either. Even after verifying the other cable is good. If it doesn't have those little BlackBerry logo it won't work.

    I spent two evenings trying to get it to work when my wife happened to take our little bag of cables out of town with her I thought "no sweat" because it is an industry standard plug. Not so. Tucked me off royally.

    MB

    Posted from my CrackBerry at wapforums.crackberry.com
    11-08-09 01:06 PM
  7. Tim Casey's Avatar
    Whoolio

    I've been using these chargers for months with no problem until the OS update. It's not the chargers.

    I'd like to hear from someone from Blackberry about this issue. Do they monitor these threads?
    11-08-09 01:34 PM
  8. jbarrington's Avatar
    I'm glad to see that other people are having charger related issues with the storm. It shows me that storm isn't allowing anything but their own chargers to be used, but this is also a pain since I can find cheaper chargers elsewhere.
    11-08-09 01:35 PM
  9. brian607's Avatar
    My storms issue is definitely the charging port, not the charger itself. It was failing before I upgraded to 5.0. Mine usually works after some messing around with the charger (pulling it out/pushing until it works). I know its not the charger because I have used the AC/USB from my storm and my pearl flip both at home and at work - and both in USB hubs/power strips and without- both have failed and worked at different times. I went down to NYC for a night and forgot my charger and got one from a newsstand right outside of times square for $5 and that one works the same as the OEM.

    edit: that being said I guess it could be a software issue? sometimes recognizing whats there and sometimes not? I don't know.
    Last edited by Brian607; 11-08-09 at 02:12 PM. Reason: .
    11-08-09 01:40 PM
  10. Tim Casey's Avatar
    Quick Reply
    11-08-09 02:02 PM
  11. jbarrington's Avatar
    UPDATE

    I forgot that my daughter has a storm also, and I just talked to her a few moments ago when she stopped by with the grandkids.

    She says the sales rep at verizon told her the BB can only use BB chargers because of a circuit that is built into it related to overcharging. I have chargers that have charge protection circuits in them, but they will not work with my BB anyway. It is sounding like there is something communicating between the OEM charger and the BB that says it's ok to proceed with charging.

    If this is true, then it makes it risky to ever purchase a non-OEM charger and hoping that it will work with the storm.
    11-08-09 02:33 PM
  12. Tim Casey's Avatar
    That doesn't explain why then I've been able to use these other three chargers (two wall chargers and one car charger) for at least the last 6 to 8 months and now all of a sudden since the new OS update the only charge it will except is from the USB cable to the computer, which doesn't charge when the computer is off so it makes it impossible to charge overnight unless I leave the computer on all night. So if I don't get a good charge before I turn off the computer and the little time I'm on the computer before running out, then I'm up the creek if my battery runs low because my car charger isn't working now either.

    Okay I just looked and my car charger is a BB charger, but I get the same error message when I plug it in as the wall chargers.

    Something ain't right here..
    11-08-09 02:52 PM
  13. jbarrington's Avatar
    Okay, I've been digging around in my treasure chest of electronic stuff and found a wall charger that is a dual USB charger. The charger will take two usb data cables and charge two devices. The wall charger is a Belkin unit that I bought from eBay a while back. It works with the BB-S1!!!
    11-08-09 05:24 PM
  14. buxleyp's Avatar
    My [release day] Storm [1] works fine with non-OEM chargers before and after the .328 update. Just make sure they provide 5V @ (500mA or higher).

    As for micro USB cables, every cable I've tried works just fine. There's nothing special about the micro USB cable from BB. In fact, the cables I use most of the time to sync/charge are the cheapo $2 no-name variety.
    11-08-09 05:28 PM
  15. jbarrington's Avatar
    And that's the strange thing. All of those non-OEM chargers that I tried showed they would meet or exceed the 500mA.
    11-09-09 05:24 AM
  16. stillborn86's Avatar
    I bought a Wal-Mart charger and it works just fine on my S1 running .328. I have never had any problems with any chargers except for my laptop. I'm pretty sure I have it set so that it doesn't charge, but that is the only one that doesn't work.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-09-09 08:54 AM
  17. johnni3's Avatar
    hmmmm....

    my 1 charger and usb cable are non-oem. I just went to check them after reading this post, but they do still charge my battery.

    The one caveat is that my non-oem usb cable seems to have trouble charging on one of my usb ports when my oem will charge from it.

    I'll have to go try my car charger next time I drive... you guys got me nervous.
    11-09-09 09:27 AM
  18. johnni3's Avatar
    quick edit... mines a 9530
    11-09-09 09:30 AM
  19. medman25's Avatar
    I cannot seem to get the phone to charge at all with any cable or charger. When you plug it in the red light comes on for about 10-30 sec. then goes out. When you have hooked up to usb you hear the computer give you the 2-tone device is attached thing, then after about 10-30 sec you get 2 tone device is detached thing. Are there any reported issues with the charging port itself?
    11-09-09 11:38 AM
  20. amgala's Avatar
    So cell phone manufacturers finally agreed to make the micro USB the universal plug, but they can't standardize the power output? What a headache...
    11-09-09 11:45 AM
  21. lbt's Avatar
    I have had my Storm since Nov. '08 and there have been no problems getting it to charge until I did the recent update. My chargers are all Blackberry and are in the same location as always. When I took the phone to a local Verizon store to try to remedy the situation, one of the clerks told me this was an issue with the update, followed by "nothing is perfect". He did offer that unplugging and replugging numerous times often works--thanks, but I had already figured that out. It is good to know from this group that plugging it directly into the computer is a solution.
    11-10-09 02:07 PM
  22. jdk2's Avatar
    I have had my Storm since Nov. '08 and there have been no problems getting it to charge until I did the recent update. My chargers are all Blackberry and are in the same location as always. When I took the phone to a local Verizon store to try to remedy the situation, one of the clerks told me this was an issue with the update, followed by "nothing is perfect". He did offer that unplugging and replugging numerous times often works--thanks, but I had already figured that out. It is good to know from this group that plugging it directly into the computer is a solution.
    Albeit a half-baked solution VZW is aware of the issue and it's present in a number of units though no solution is at hand except for what you've tried.
    11-10-09 02:29 PM
  23. bryancoxworth's Avatar
    I have the same problem after upgrading to 328. I have two wall chargers and a cigarette lighter adapter, none of them work now and all did before. they are all Black Berry Charges. The only way I can charge my phone now is with the USB. I even have a USB wall adapter and it will not work, only when plugged into my pc can I charge. Very strange.
    11-26-09 04:45 PM
  24. DigMyBBStorm1's Avatar
    Hmmm, I noticed this as well. I mistakenly used my wife's micro USB charger for her LG phone and it drained my battery instead of charging it (car charger). I also plugged my BT headset into my Storm by accident and it did the same thing.

    Interesting. It would be good to know what the issue is as I'd like to only have to keep one charger in each car for all of my microUSB devices (wasn't this the dang point of the standard?!?!?!).

    I understand the mA issue so if you go higher you should be able to use on all devices right?

    Ok, just keeping an eye on this thread for some answers/input.

    Thanks!

    Jay
    11-27-09 08:25 AM
  25. z06mike's Avatar
    I bought a non OEM cheap charger off of Ebay and it really sucked. Everytime I would plug the phone in, it would freeze and I couldn't use it until I pulled it off the charger. Just stick with the good ones.
    11-27-09 10:05 AM
26 12
LINK TO POST COPIED TO CLIPBOARD