1. jlsparks's Avatar
    I searched extensively on this topic before creating this thread; however, if there's one out there that I missed I apologize.

    I've got a Seidio 1600mAh batt that I purchased months ago for my S1. Based on Seidio's assertion, in the listing for this product in the CB store, I popped the batt in my S2 when I got home tonight, looking forward to seeing how it would perform during what's going to be a busy day tomorrow.

    My first clue that this was a bad idea should be been the fact that I practically had to shoehorn it into the battery slot on my S2. Paying little or no attention though I jammed it in, popped the cover on - which should have been my second clue given how tight the cover was with the Seidio in place - and plugged it into the USB cable on my notebook.

    After waiting patiently for about 40 seconds for the red LED to go out (third clue this was a bad idea) the S2 attempted to start its boot sequence. Instead of the BlackBerry load screen though, I was surprised to see the "no battery inserted" icon instead. Off came the cover, I pushed it in a little more, cover back on, plugged back in, same result. 10 minutes and two rollerball pens later I finally wedged the damn thing out of my phone, put the 1380mAh stock batt back in, and it fired right up.

    Question: has anyone else tried to use the 1600mAh batt in their S2? If so did you have a similar experience? If not, did you do anything out of the ordinary to get the batt to work in the S2? I'm not disgruntled or upset about it (I bought it for the S1 after all), just a little disappointed and pissed that I don't have any pens left

    Thanks for your input.

    EDIT: After reading (below) numerous reports of folks using the batt in the S2 without any problems I tried again this morning and discovered, ultimately, that my problems were entirely caused by the fact that the Seidio was just dead! Charging now, and looking forward to seeing how it performs. The fit/removal problems appear to have been the result of my trying to remove the batt in the dark. Don't ask. Thanks for the feedback.
    Last edited by jlsparks; 11-18-09 at 09:16 AM. Reason: Accepting responsibillity for the ultimate PEBKAC.
    11-17-09 09:20 PM
  2. andydmd's Avatar
    I'm using it without any problems. I'm getting 2 days between charges. It fit tight but is easily removed.
    11-17-09 10:42 PM
  3. Orio's Avatar
    I don't know...I've been using my Seidio 1600 since I got my S2 on 10/28 with no issues whatsoever...fits fine...works fine...charges fine. Sorry, got no answer for you.
    11-17-09 10:47 PM
  4. moogoo88's Avatar
    No issues either.

    Running at all times:
    Viigo
    quicklaunch
    berryweather
    socialscope
    wifi

    No idea how long I go without charging. I have the cradle at my desk and bedside table.
    11-17-09 11:52 PM
  5. npstup's Avatar
    I use one with no issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-18-09 03:47 AM
  6. pkcable's Avatar
    Just bought one and will let you know.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-18-09 03:55 AM
  7. leojon's Avatar
    I had purchased one of the stronger batteries for my 8900 and it didn't last a week before it completley discharged and now I have just purchased the storm2 through crackberry and the regular battery did the same in 3 days
    11-18-09 06:26 AM
  8. netwerks1's Avatar
    Have two of them, first one after I got my S1, second one after I got my S2. Use both with no issues. Keep one at work with the BB mini charger (works great). The fit is fine on both, both go in the charger and phone fine. Sorry you're having issues. Good luck!
    11-18-09 06:56 AM
  9. Ultrafied's Avatar
    Been using the 1600 on my S1 since it came out. Got the 1600 for my S2 before it came out. Fits fine and no problems on either. Get a little over 36 hours.
    11-18-09 07:57 AM
  10. jlsparks's Avatar
    Thanks for all the positive feedback gentlemen. After reading of your trouble-free use of the Seidio batt I sucked it up and popped it back in this morning. Initially I got the usual red LED, then the S2 switched to the old spinning clock icon, followed by a shutdown. I plugged in, again, to the MBP. Red LED followed by an interesting 1/2" wide white bar that extended across the entire display. After about 10 minutes of that the phone shutdown and restarted through the normal boot sequence! When it fully booted I checked MeterBerry and found that there was 3% remaining. Doh.

    Bottom line, the battery works fine in the S2. I'm charging it now at the office and look forward to seeing how it performs on a full charge. This was the ultimate in user error on my part, and I've edited my OP accordingly.
    11-18-09 09:12 AM
LINK TO POST COPIED TO CLIPBOARD