1. z0diac's Avatar
    For the love of God this is becoming an annoying trend with me.

    I've gone through 3 different Incipio cases and my gf just purchased me a car mount for my Birthday, and whenever I've attempted to install the phone into either case or holder, the screen becomes automatically unresponsive.

    I get the feeling that there is too much pressure being applied to the frame, that forces the screen into a position that does not allow it to read my touch...but if anything this all seems like the fault of BB and not of my own or the manufacturers of cases.

    Anyone have a similar experience? Is there anything I can do to tweak the screen for this to change?

    01-04-10 09:47 AM
  2. debitsohn's Avatar
    For the love of God this is becoming an annoying trend with me.

    I've gone through 3 different Incipio cases and my gf just purchased me a car mount for my Birthday, and whenever I've attempted to install the phone into either case or holder, the screen becomes automatically unresponsive.

    I get the feeling that there is too much pressure being applied to the frame, that forces the screen into a position that does not allow it to read my touch...but if anything this all seems like the fault of BB and not of my own or the manufacturers of cases.

    Anyone have a similar experience? Is there anything I can do to tweak the screen for this to change?

    Do u have any screen click fixes under the battery door? If so u can take that out. If not then I dono. If u r thinking "I tried that u moron" then sorry. I found my s1 usually clicked better with my innocase on.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-04-10 10:03 AM
  3. z0diac's Avatar
    The only tweaking I've done to make the screen more responsive was the technique in which you unscrew the screws on the back of the LCD until a desired position in which the screen has more of a "click" to it is engaged.

    I guess I might have to tweak that again. I just find it funny...
    01-04-10 10:48 AM
  4. z0diac's Avatar
    I really hate to bump my own thread, but this truly is becoming frustrating.

    Anyone else ever have this issue?
    01-04-10 07:44 PM
  5. z0diac's Avatar
    Seriously, no one has ran into this issue?
    01-05-10 11:22 AM
  6. chuckh0308's Avatar
    It clicks fine but just doesn't sense when your finger is present, right? That's really weird...I have two Incipio cases, an Otter Box AND a car mount, and I have never experienced that problem. Only thing I can think of is that your phone isn't grounding well to the battery door (there are contacts behind the door). Other than that I'm at a loss...

    Posted from my CrackBerry at wapforums.crackberry.com
    01-05-10 01:06 PM
  7. z0diac's Avatar
    Yeah, I think that's ultimately the culprit. Going to try and tweak the screws tomorrow and see what I come up with.

    THanks for the suggestion.
    01-07-10 11:33 PM
  8. kyamabe's Avatar
    I had a similar problem. When I put my Storm in a car mount mounted in my A/C Vent the touch would work intermittently and/or not at all. I thought it was because the arms on the side of the mount was squeezing on the buttons. After scouring the Internet, I found a solution. I tried connecting the car power adapter to the phone while it was in the car mount. Lo and behold, the touch screen works all the time now. I ended up buying another mount that had holes in the arms so that my power connector could fit while the device was mounted. I think the issue is with capacitance or grounding, not sure. Hope this solves your problem.
    03-27-10 07:33 PM
  9. DrewCSchultz's Avatar
    Yea the phone has yo be grounded to work. If you put the phone flat on a desk, it hardly recognizes your input. That's weird though that you're having case problems. Maybe the contacts behind the battery door are damaged?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-27-10 09:14 PM
LINK TO POST COPIED TO CLIPBOARD