1. jacobite11's Avatar
    during the Otterbox sale posted by someone here (thank you!). I love the case, love the way it feels, love the way it looks, BUT, it's screwing with my signal. I have signal issues anyway where I live. Have had a hybrid PRL, switched to 1EVDO, done all the things mentioned here, but as soon as I slip the rubber part on, I lose whatever meager signal I had. Is that normal?
    07-17-10 06:07 AM
  2. coolguy78240's Avatar
    I would imagine that a case that thick would disrupt an already weak signal. But i would check with your carrier. Maybe there is something they can do
    07-17-10 09:42 AM
  3. wrwrx's Avatar
    Steve Jobs ... Is that u?

    Ur holding wrong...

    Posted from my CrackBerry at wapforums.crackberry.com
    07-17-10 10:20 AM
  4. FF22's Avatar
    Which Otterbox? Make sure the case is not accidentally pressing against the two-stage camera (right convenience) button. If partially pressed, it can cause a variety of issues.
    07-17-10 10:45 AM
  5. LrdAnkh's Avatar
    I have both the Defender and the Commuter Otterbox cases and have not had issues like that described with either.
    07-17-10 12:00 PM
  6. kostnkost's Avatar
    Never had issues with an Otterbox and my phones signal.

    I would switch to an Iphone.....
    07-17-10 12:09 PM
  7. jacobite11's Avatar
    Thanks to those of you who answered without being snarky . I think that it comes down to being in a somewhat marginal service area, and the case just blocks a bit too much. I will keep it - phone works great on my trips overseas...
    07-17-10 02:50 PM
  8. asianguy80's Avatar
    It might be your service area. I had an otterbox commuter and didn't have any signal issues and currently use a Case Mate full protective case and same thing no signal issues. What OS version are you using? I'm using a version of OS5 with the .419 radio and get excellent reception compared to the original 4.7 the phone came with.
    07-17-10 07:53 PM
  9. jacobite11's Avatar
    I had 4.7 originally, just updated to .732. Signal does seem to be better with this, but battery drain is more pronounced. How do I change to the .419 radio?
    07-19-10 06:03 AM
LINK TO POST COPIED TO CLIPBOARD