1. SquirrelNuts's Avatar
    Hi folks,

    A strange problem with the cradle - the phone won't charge in it!

    Some information: I'm on my third Storm, never got to test the cradle with the second one as it was nothing more than a brick but the cradle always worked perfectly with the first one.
    Here's what happens. I drop my phone into the cradle, it switches to clock display and bedside mode with radio off, as programmed. I wake up in the morning to a dead phone. Interestingly, if I do this without the charger connected to the cradle the phone does nothing, as I would expect.

    On the other hand, if I simply connect the charger lead directly to the phone, it switches to clock etc. as above, but it charges!!!

    Can anyone shed any light on this? Or tell me how to take the cradle apart so I can try and find the fault myself?

    Thanks in advance,
    Stu.
    03-27-09 06:41 PM
  2. TheChampJT's Avatar
    If it doesn't work, get a replacement.
    03-27-09 07:03 PM
  3. SquirrelNuts's Avatar
    Heck, I've thought about that. Both the phone and the charger have been replaced because of faults, why not the cradle?

    I'm just curious as to why the phone behaves as if it has a charging feed when it doesn't. And why Storm 1 worked perfectly with it, while Storm 3 doesn't?
    03-27-09 07:18 PM
  4. allmixedup93's Avatar
    off topic...but i love that cradle. every time someone see's it in the pod they want to throw their iphone out the window and buy a storm
    03-27-09 07:52 PM
  5. SquirrelNuts's Avatar
    I know. I love the cradle. That's why this problem is peeing me off. How can I impress the babes when my phone won't work in the morning? :LMAO:
    03-27-09 08:09 PM
LINK TO POST COPIED TO CLIPBOARD