1. _james44's Avatar
    it has been messing up lately since the .85 update and now it went dead, and wont charge back up.. what shall i do?
    01-09-09 11:58 PM
  2. howie's Avatar
    I would say let it sit on the charger for an hour or two without bothering it. If it still does not turn on after that we can try other steps.
    01-10-09 12:04 AM
  3. _james44's Avatar
    its been on the charger for 7 hours and still nothing
    01-10-09 09:09 AM
  4. Freetoride78's Avatar
    It could be a bad battery.... I work for a verizon store and we had one returned for this reason...put another battery in and it worked fine but leave it on the charger with the old battery for 2 hours and nothing would happen
    01-10-09 09:17 AM
  5. eddy4iu's Avatar
    after using a "Cellet" wall charger (from OrionGadgets). I took the phone to a Verizon store and they replaced it with a brand new one (I was within my 30 day worry-free period). OrionGadgets approved my return of the charger - no questions asked.

    The Verizon guy said it would reset on the charger but I told him the screen click had issues as well and that I wanted a replacement. New one is GREAT!
    01-10-09 09:29 AM
  6. howie's Avatar
    Try plugging it in by USB on the computer to see if perhaps the wall charger has gone bad. If that doesn't work then I would try the above about replacing battery at the store.
    01-10-09 09:31 AM
  7. xnight's Avatar
    Only one solution to that problem... check my thread

    http://forums.crackberry.com/f86/pho...t-pull-133473/
    01-10-09 10:02 AM
  8. woodyou's Avatar
    Return if nothing works
    01-10-09 11:30 AM
  9. MPSmith1's Avatar
    I agree, its likely going back to VZW.
    Can you try a JL_Cmdr wipe first?
    01-10-09 11:32 AM
  10. _james44's Avatar
    im sending it back, new one should be here in 3 days, thanks for all your help
    01-10-09 04:16 PM
LINK TO POST COPIED TO CLIPBOARD