1. finetune's Avatar
    Hi,

    I'm at my wits end. Problem is I can't get "GPRS" on my 8900, and this is preventing me from enabling enterprise activation or connecting to any data services.

    I was given the 8900 by Vodafone a couple of years ago. I've had it unlocked and now it works fine as a phone, SMS etc using my new SIM (service provider is my employer: Cable&Wireless, which runs over Orange). However I can't get any data services. Cable&Wireless have tried connecting me to the corporate BES but can't proceed until I get "GPRS" upper case. I tried a SIM swap with a colleague who has the same model phone, fully working. His SIM does NOT work in my phone and my SIM DOES work in his phone - so it must be a problem with my phone - hardware or settings.

    I've deleted all service books
    I'm running the latest version of o/s 4.6
    Mobile network is connected
    Data services are turned "on" in options
    Wi-fi is working fine so I can browse the web

    Please help - I really want to get this phone working so I can enjoy Google maps etc. If I can't make it work, the company want to give me an 8520 which would be rubbish!
    03-19-12 08:23 AM
  2. blackberry-unlocking710's Avatar
    Contact your carrier ans ask them to send you the service books they use, then install the service books.
    03-20-12 11:28 AM
  3. finetune's Avatar
    Thanks blackberry-unlocking710; I'll contact them and see what they can do
    03-20-12 03:47 PM
LINK TO POST COPIED TO CLIPBOARD