1. jimt1000's Avatar
    On my Bold 9700, when I locked the keyboard prior to putting it in the holster, it remained locked after I withdrew the device out of the holster until I unlocked it. With my new 9800 Torch, I lock the screen but as soon as I holster it, the holster magnet - I guess - unlocks it and whenever I take it out of the holster, I always hit "keys" on the screen undesireably. Is there a way to lock the Torch prior to going into the holster and have it stay locked until I unlock it out of the holster - like I did with my 9700?? Thanks.
    09-14-10 04:20 PM
  2. frankko55's Avatar
    i have the same problem
    09-14-10 08:47 PM
  3. Mikey52's Avatar
    Isn't there an option that locks the device when you put it in the holster? Then you need you physically unlock it when you take it out? On my storm it's in - Options - Password - Lock Handheld Upon Holstering
    Last edited by Mikey52; 09-14-10 at 08:55 PM.
    09-14-10 08:52 PM
  4. epiguards's Avatar
    I was not having this problem, but to make things simpler for mself I set the convenience key to the lock icon. I hit the convenience key now before I place it in to the holster.
    09-14-10 09:01 PM
  5. jimt1000's Avatar
    I've tried locking the Torch automatically when holstered using the Options; Security; Password; however, you've got to input a rather long password to make the "Lock Handheld Upon Holstering" option work. I don't want a password - I simply want the unit to stay locked unitl I unlock it to avoid hitting screen keys inadvertantly... There's gotta' be some way to keep the screen locked prior to holstering, while in the holster, and then after retrieved from the holster - just like with the 9700. Any other ideas or advice is appreciated. Thanks.
    09-15-10 05:25 AM
  6. stillmoi's Avatar
    I was wondering about this... so upon holstering you device doesn't go into the sleep mode? I tried using several off brand holster and mine seem to never lock and if so... it doesn't go into the sleep mode. This morning I finally broke down and ordered the BB holster designed for the Torch because I'm hoping that would keep my device either locked or at least in the sleep mode.

    (anyone care to share)
    09-15-10 06:19 AM
  7. jimt1000's Avatar
    Ok... The best solution i found was to download the free app called PatternLock. You can do this from the BB app site... There is a pay version and a free version. The free version works great and solves this whole problem. Once you lock it with this, problem solved. I'd also suggest making sure the Torch is not set to answer automatically in holster or out... So make sure automatic answer/calls is set to "never". This is the best Solution I've found.
    09-15-10 10:00 AM
  8. hunoosh's Avatar
    Love the patternlock app! Actually thinking of ug to pd version.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-15-10 10:06 AM
  9. bold007's Avatar
    Work great.
    09-15-10 11:35 AM
  10. frankko55's Avatar
    trying to use pattern lock but after i downloaded, it tells me change the setting in the advanced menu under option..where is that?
    thanks!
    09-16-10 09:50 AM
  11. mrro82's Avatar
    trying to use pattern lock but after i downloaded, it tells me change the setting in the advanced menu under option..where is that?
    thanks!
    Go to options. Then 3rd party apps. It's under there. I use patternlock too and I love it. When I pull my torch out of the case it comes right up to the pattern. Good stuff.
    09-16-10 09:55 AM
  12. stillmoi's Avatar
    I got the stormlock or berryslider... it works perfectly as well. I sort of like the BB animation without the battery drain. Both locks works well (have pattern lock, too)
    09-16-10 10:17 AM
  13. carbide50's Avatar
    Ok... The best solution i found was to download the free app called PatternLock. You can do this from the BB app site... There is a pay version and a free version. The free version works great and solves this whole problem. Once you lock it with this, problem solved. I'd also suggest making sure the Torch is not set to answer automatically in holster or out... So make sure automatic answer/calls is set to "never". This is the best Solution I've found.
    Kudos to you Jim! This is exactly what I've been looking for. I bought the paid version, and after seeing all of the customizations, I'm glad I skipped the free version. Very cool proggie. Does exactly what is says it'll do... amazing

    Bryan
    09-16-10 12:54 PM
  14. frankko55's Avatar
    Go to options. Then 3rd party apps. It's under there. I use patternlock too and I love it. When I pull my torch out of the case it comes right up to the pattern. Good stuff.
    thanks but after I did that, it says please click on the application icon first to run through the startup wizard but when i click on the icon, it is asking me to go to options first...
    i am sorry..am i doing something wrong?
    09-16-10 01:13 PM
  15. carbide50's Avatar
    Hi Frank,

    Try this: Go to "Options", then "Device", then "Application Management". Scroll down until you see "Pattern Lock", click it, and then click "Edit Permissions". All three need to be set to "Allow".

    Myself, I too received the message you've encountered., When I originally went to Options/3rd Party Apps as instructed, Pattern Lock was there. When I clicked on it the first time, it opened the screen where you set the permissions. Once I set them all to "Allow" and saved it, clicking on the same item, (Pattern Lock), opened the list of options for the program. In my case with the paid version, the list of configurable options is quite awesome.

    I just noticed later that you can also change the permissions for installed programs under Options/Device/Application Management/. I hope some of this helps. If not, chime back in and we'll try something different. I'm sure you'll love the program. I know I hunted long enough.

    Bryan

    Posted from my CrackBerry at wapforums.crackberry.com
    09-17-10 10:33 AM
  16. KahneFan's Avatar
    If you use the KeyBoard Lock (in my signature), it will lock your entire screen until YOU unlock it. It comes default as *+talk to unlock, which means sliding the keyboard. However, you can change that. I have made mine the BB button, so I slide it out of my holster, tap the BB button and I'm ready to go. Before I put it back in the holster, I hold down the BB button for 1.5 seconds to bring up the running apps screen, click the lock icon and it's locked and ready to go in the holster without activating the screen. It has a trial version, which doesn't allow you to adjust the time setting, if you want to try it.
    09-17-10 02:32 PM
  17. merlin5353's Avatar
    Nice! I'll check it out. Thankx.
    09-18-10 11:40 AM
  18. frankko55's Avatar
    Hi Frank,

    Try this: Go to "Options", then "Device", then "Application Management". Scroll down until you see "Pattern Lock", click it, and then click "Edit Permissions". All three need to be set to "Allow".

    Myself, I too received the message you've encountered., When I originally went to Options/3rd Party Apps as instructed, Pattern Lock was there. When I clicked on it the first time, it opened the screen where you set the permissions. Once I set them all to "Allow" and saved it, clicking on the same item, (Pattern Lock), opened the list of options for the program. In my case with the paid version, the list of configurable options is quite awesome.

    I just noticed later that you can also change the permissions for installed programs under Options/Device/Application Management/. I hope some of this helps. If not, chime back in and we'll try something different. I'm sure you'll love the program. I know I hunted long enough.

    Bryan

    Posted from my CrackBerry at wapforums.crackberry.com
    it worked! great! thanks! i am just wondering why does the device turns on by itself everytime i put it in the holster even after i lock it.
    is there anyway to prevent that?
    09-18-10 12:02 PM
  19. merlin5353's Avatar
    Pattern lock works. I'm happy. Wish BB lock worked, but PattwenLock is pretty nice. Bought the 'good' version.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-20-10 05:58 AM
  20. jmmm's Avatar
    I loaded Patternlock (free) yesterday. Works fine, but it surpresses my Outlook calendar reminders when locked. I tried playing with the permissions, but there is not a permission specific to calendars. Any ideas?

    Thank you.
    01-06-11 10:35 AM
  21. tcseacliff's Avatar
    after reading this post , dowloaded the pattern lock. it is fantastic!. i was constantly opening stuff in and out of holster. this solves it! might go for the paid version. very useful app.
    01-06-11 08:13 PM
  22. Maseroche's Avatar
    I also use Pattern Lock lite and it's a godsend! Only thing is that sleep mode now shows the Pattern Lock screen and not the usual clock.
    01-07-11 04:46 AM
LINK TO POST COPIED TO CLIPBOARD