1. reneli's Avatar
    Ok Guys so i went earlier today to get an invisible shield the told me to keep my phone off for 2 hours to let the shield dry
    so i just turned it on and there are bunch of black spots and streaks
    at first thought that it was just the invisible shield but i took the shield off
    and its under my screen!!!!!!!!!!
    has any one else had this happen to them???
    what should i do?
    05-17-09 05:27 PM
  2. benzworm's Avatar
    how much of the liquid did you use to install it?
    05-17-09 05:31 PM
  3. skyjackal's Avatar
    Oh wow. Very sorry to hear that. Hasn't happened to me but has happened to lots of people. Remove the battery and put the phone in a container with rice. This has worked for many as it helps to dry out the phone. Not sure what else to suggest but hopefully others will. Good luck to you.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 05:32 PM
  4. andyahs's Avatar
    Oh wow. Very sorry to hear that. Hasn't happened to me but has happened to lots of people. Remove the battery and put the phone in a container with rice. This has worked for many as it helps to dry out the phone. Not sure what else to suggest but hopefully others will. Good luck to you.

    Posted from my CrackBerry at wapforums.crackberry.com
    That is the best solution. Leave the phone off/battery out for at least 12 -24 hours in the rice and the liquid should dry up.
    05-17-09 05:36 PM
  5. reneli's Avatar
    Rice!!! For real!! lol
    wow ill give that a try
    hopefully it works cuz i just got my bold this week!!
    thanks guys for the quick replys!!!
    05-17-09 05:50 PM
  6. maxiang's Avatar
    Same thing happened to me. It took about week before the splotches dissappeared but it looks perfect now! I've got a thread in the tips and how to section somewhere.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 06:25 PM
  7. LittleRedDot's Avatar
    This has happened to almost everyone installing a skin with the liquid method, and in every case the marks dissipate on their own.
    05-17-09 06:27 PM
  8. waldog's Avatar
    This has happened to almost everyone installing a skin with the liquid method, and in every case the marks dissipate on their own.
    I never had them and did a liquid method.

    The best thing to do is to use soapy water and not the liquid they give you.

    Or just don't use a Invisible Shield. As long as you take care of your phone, you don't need a i.s.
    05-17-09 06:41 PM
  9. BBsnub's Avatar
    My Invisible Shield worked great...no streaks. Sounds like a case off too much of the liquid. Best thing to do is just to spray the solution on your fingers and a small amount on the screen.
    05-17-09 08:31 PM
  10. indonesianberry's Avatar
    My brother uses Phantomskinz. Easy to install, just using hot water.
    05-19-09 12:23 PM
  11. bumblesbounce's Avatar
    Never spray anything directly on any screen whether it's your TV, computer or BBerry, right? Wet the shield and then apply it or spray cleaner onto some moon floss then clean your screen with the damp moon floss..
    06-16-09 05:21 PM
  12. M7mdAA's Avatar
    Try what other members are suggesting , If that doesnt work then can you get a replacement ?
    06-17-09 11:00 AM
LINK TO POST COPIED TO CLIPBOARD