1. slackerjack's Avatar
    Hey there,

    Woke up this morning with a completely dead 9700, reason being, I plugged it into the charger I used to use with my 8900 thinking "hey, the ports the same...should work" - I was wrong. Guess there is a reason that you get a new one



    Jack
    11-14-09 06:50 AM
  2. Roscopcoletrain's Avatar
    Are they both micro usb? Not sure why it wouldn't work? My storm charger works on my 9700.
    11-14-09 07:14 AM
  3. tedzone's Avatar
    It's probably your charger that's no good buddy, cause I'm using my 8900 charger and all is good. I'm setting new personal records for talk and standby time.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-09 07:25 AM
  4. coremark's Avatar
    The 8900 charger works fine on my bro's 9700 and my wife's 8520.
    11-14-09 07:43 AM
  5. slackerjack's Avatar
    Maybe, I plugged it into my 9700 charger this morning and everything's fine...on a side note - this is one of the fastest charging phones I've ever had....- battery life to two bars worth in just under an hour...curious to see how long that'll last me

    Jack
    11-14-09 07:44 AM
  6. Roscopcoletrain's Avatar
    Yeah I noticed the same, it charges REALLY quick!
    11-14-09 07:48 AM
  7. username0001's Avatar
    Using my 8900 charger as well with no issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-14-09 07:55 AM
  8. CGI's Avatar
    Did you plug the charger into the headphone jack?

    11-14-09 09:00 AM
  9. grunty's Avatar
    Did you turn the charger on at the wall?
    11-14-09 09:04 AM
  10. Sith_Apprentice's Avatar
    Bad charger
    Bad wall port
    Bad phone port
    Bad device
    Bad battery
    User error
    Act of god(s)

    That is all
    11-14-09 09:06 AM
  11. Roscopcoletrain's Avatar
    *waves* hi Sith! Good to see you posting still
    11-14-09 09:10 AM
  12. Sith_Apprentice's Avatar
    Yeah, im around, kinda. Long story, but so far things are ok
    11-14-09 09:16 AM
  13. Roscopcoletrain's Avatar
    Good to hear. Always nice to see you as an active member You bring a lot to the table
    11-14-09 09:17 AM
  14. Sith_Apprentice's Avatar
    Well thank you. But keep on topic hahah Feel free to PM. Im actually thinking about posting my PIN again, we shall see.
    11-14-09 09:23 AM
  15. unitxer0's Avatar
    my friend charged his 9700 with my 8900 fine
    11-14-09 11:33 AM
  16. unitxer0's Avatar
    has to be either user error, wall charger bad, or wall port bad
    11-14-09 11:34 AM
LINK TO POST COPIED TO CLIPBOARD